Jump to content

OrangePi PC H3 Armbian 5.90 Ubuntu Xenial 3.4.113-sun8i trying to get a MT7601 WiFi USB card working, missing Linux headers


Recommended Posts

Hello to everyone! :) I'm trying to solve the issue which is currently being discussed here and I've been forced to revert back to the ancient version in the title. The problem is that along with my OPi PC I use a cheap wireless adapter based on the MT7601. Here, I've found out that the support for these cards had been merged to upstream since 4.2 kernel versions indeed with Armbian Focal 5.10.4-sunxi it worked out of the box like a charm. Unfortunately, it isn't the case with the version I'm currently on, this adding another massive headache! ;)

I've found this really interesting thread where it is discussed how to add support for the MT7601. Everything went fine apart from the fact that issuing the


apt-get install linux-headers-sun8i


command, I get the message that the package doesn't exist nor I was able to find a .deb package anywhere to install it by dpkg. The headers are definitively missing (I've checked) and I can't complete the driver compilation. Here I've found the headers for what should be the right arch (armhf) but for the 3.4.112 kernel version. I know it's an insane approach but I've tried to use them to build the driver. This way, I've been able to complete the procedure described in the aforementioned thread but when I try to issue the


modprobe mt7601Usta


command, I get:


modprobe: ERROR: could not insert 'mt7601Usta': Exec format error


this being certainly due to my insane choice before. I couldn't find any in spite of my extensive research but I ask "is there a way to get hold of those 3.4.113-sun8i headers?" or at least (probably even more intriguing, I have to say!) "how to build them from sources?". Regarding the latter question, I've gone through a lot of reading here, here and here but I couldn't find the answers I was looking for unfortunately. Here I've also found what I believe are the sources upon which I could try to build the missing headers exactly like the other user on the OrangePi forum had done but I don't even imagine how and where to start from.

In the meantinme, I've scoured another WiFi adapter based on the RTL8192CU which is instead supported out of the box so I'm able to go on with my other 'quest' but I'd like to solve this one too if possible, even 'only' to learn something new. As always, thanks in advance to anyone coming with a suggestion! :)

Edited by guybrushthreepwood
Link to comment
Share on other sites

  • guybrushthreepwood changed the title to OrangePi PC H3 Armbian 5.90 Ubuntu Xenial 3.4.113-sun8i trying to get a MT7601 WiFi USB card working, missing Linux headers
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines