OrangePi PC not booting up

Recommended Posts

Hello everyone

Just bought a bunch of Orange Pi PC and I'm having issues making them boot properly.
The behaviour of the board changes everytime I power it on, sometimes it just shows a black screen, others it stays frozen in the "Starting version 245" (I've waited more than 10 minutes in that screen to see if something happens but nothing) if i get lucky sometimes I get a kernel panic (first image attached), and also one time I got an "unable to handle kernel paging request" (second image attached). So, in short, after working on this for at least 4h I did not get one succesful boot and I don't know what else to try.
Also don't know if it's relevant but I never saw the red led of the board on, just the green one.

- I'm powering the board using a USB to DC cable (the barrel plug), connected to an Anker PowerPort 10, rated to 5V 2.4A per port (have a friend using the same setup with the same boards and no issue on his side) but also tried different smartphone chargers that I had laying arround,  one of them rated for 5V 4A, to no avail.
- Loaded also multiple images downloaded from this website for the Orange Pi PC, the two current versions of Armbian Buster and Focal and also a old version on Buster, burned them using Etcher.
- I'm using a 16Gb MicroSD SanDisk Ultra C10 A1, tried different ones since I have a bunch, also executed H2testw with no issues
- And as a last resort I did try Win32DiskImager and another card reader in a totally different computer just out of desesperation and to rule out anything that came to mind.

I'm starting to think that maybe it's a power issue, I had a look at the powering via MicroUSB post but I don't know how to diagnose the voltage that I'm getting since I only have a multimeter and this is my first time working on boards.

Any help would be much appreciated since I don't know what else to try.



Screnshot 5.JPG

Board: Orangepi PC
Edited by chervol
Link to post
Share on other sites
Donate and support the project!

Just checked the Voltage at the end of the barrel plug with the multimiter, I'm getting 5.21V with no load, using a cable of 91cm, and under load I'm getting (if I'm doing this right) In the GPIO pin 2 and 6 about 4.51V, so that could be the issue, I'm not getting the 4.8V requiered.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.