Evolveo H4-4k and Q5-4k with 20.10 focal 5.9.0


Recommended Posts

Hi, I came across two similar TV boxes - "Evolveo H4 4k" and "Evolveo Q5 4k" - and found this great Armbian site!

Thanks for your great work guys!

I set my expectation low and tried with latest "Armbian_20.10_Arm-64_focal_current_5.9.0".

 

The H4 seems to be an S905/p212 2GB/16GB (not sure whether w/ 1Gb lan) board and it boots here with selected:
uboot-s905 and
FDT /dtb/amlogic/meson-gxl-s905x-p212.dtb (set in extlinux.conf)


The Q5 seems to be an S905/p200 2GB/8GB board (lan w/ 1Gb) and it boots here with selected
uboot-s905 and
FDT /dtb/amlogic/meson-gxbb-p200.dtb

or
FDT /dtb/amlogic/meson-gxbb-vega-s95-telos.dtb (I added into extlinux.conf).

 

I've been using lan connection via ssh (putty) only. I flashed a 16GB card with the img and I used the toothpick reset method with the first boot.

It worked and now it boots ubuntu when the sdcard is inserted in.

I do not see any menu or any graphical output during the boot, only a standard text output with all OK during the boot.

It is my current understanding the above distro does not include any graphical environment.

I even installed the xubuntu with xcfe on it - it works "basically" (incl. my usb radio mouse connected).

 

The amlogic's ver 20.10 5.9.0 is the last one afaik - does it mean those images will be still stored there in the future?

Will the sources be available somewhere?

Thanks!

 

Edited by Pito
typo
Link to post
Share on other sites
  • Pito changed the title to Evolveo H4-4k and Q5-4k with 20.10 focal 5.9.0
Donate and support the project!