Jump to content

How to enable UART1 on Orangepi PC with Armbian Buster 19.11.6


Recommended Posts

I have an Orangepi PC with OS: Armbian_19.11.6_Orangepipc_buster_current_5.4.8_desktop... I'm trying to communicate hardware through the UART1 ports (GPIO198 and GPIO199, respectively pins 8 and 10), but I'm not able to enable the ports, I've tried modify the file "un8i-h3-orangepi-pc-plus.dtb" but I couldn't, I also tried the solution proposed in this topic: https://forum.armbian.com/topic/1524-orange-pi-one-how-to-enable-uart/ but I couldn't find the script.bin file in the boot folder... I also tried using Minicom, and the message Offline appears. I need to activate UART1 and configure it with 19200,8,1,N. Any tips?

 

 

Edited by TRS-80
fix link
Link to comment
Share on other sites

Donate and support the project!

Generally speaking, yes, just burn to some other sd card and try to boot it and see if the new version works.  Follow instructions in documentation.  Whatever latest version is for that board, which can be found on download page.

 

I don't own this hardware, I am assuming it will boot from inserted sd card first, but some devices don't work that way (most do).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...