Jump to content

New Install on Wetek Play 2 latest stable kernel / image


mfizz
 Share

Recommended Posts

Hi, I plan on installing Armbian_20.10_Arm-64_bullseye_current_5.9.0.img.xz on my rather old wetek play 2, to be used as a home server. 

 

I just want to confirm, I have been trolling through the forums that this version appears to be the latest one that can be installed? 

 

Am I also correct in assuming debian is more stable than ubuntu? Since majority of my containers are networking related, this is what I value most above, bluetooth wifi etc... 

Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

I'm not aware of anyone else trying armbian with this device, but since it it amlogic cpu based there is a chance it might work.  The latest instructions for amlogic based devices can be found in the TV box FAQ here: https://forum.armbian.com/topic/17106-installation-instructions-for-tv-boxes-with-amlogic-cpus

also look at this FAQ entry:

https://forum.armbian.com/topic/16976-status-of-armbian-on-tv-boxes-please-read-first

 

Link to comment
Share on other sites

I think there was one person on here that managed to successfully boot wp2 (sadek). I will use the device tree of gxl p200. From memory that is what use to work when you had to manually copy dtb in coreelec.

 

Question: I only have ever used coreelec on sd card, not on emmc. I can boot into android as per normal I shouldn't need to reflash just because I had coreelec booted?

Link to comment
Share on other sites

@mfizz If you have ever booted coreelec (even on SD) you will likely need to restore the original android firmware before being able to use armbian.  The 'multiboot' enabling process updates the uboot environment on emmc to enable booting from sd card.  coreelec and armbian do that in incompatible ways, so once you have the coreelec multiboot installed you won't be able to boot armbian from sd.

Link to comment
Share on other sites

Struggling to boot up here. I  have wiped the emmc, I am able to boot using libreelec and mainline u-boot but not armbian. There is an actual wetek play 2 dtb that i have referenced but it doesn't want to boot.

 

LABEL Armbian
LINUX /zImage
INITRD /uInitrd

#FDT /dtb/amlogic/meson-gxbb-p200.dtb
FDT /dtb/amlogic/meson-gxbb-wetek-play2.dtb
APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0

 

 

I have also COPIED the u-boot-s905 and renamed the copied version to u-boot.ext

 

I have also tried the generic p200. I wonder what settings @sadek used.

 

Also the moment it boots up should I see something on TV through HDMI?

Link to comment
Share on other sites

I don't have any other suggestions for you and I don't have any s905 based boxes so I haven't ever tried the u-boot-s905.  What error/messages are you getting when you try to boot?  You may need to find the serial consol pins on the board and hook up to them to see the uboot output if you want to try to figure out what is happening.

Link to comment
Share on other sites

In the process of getting myself a serial cable to see what is happening. Couple of things I noticed prior was the boot.ini file says

 

`ODROIDN2-UBOOT-CONFIG`

 

my extlinux.conf says:

 

```

LABEL Armbian
LINUX /zImage
INITRD /uInitrd

FDT /dtb/amlogic/meson-gxbb-odroidc2.dtb
APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0

```

 

This is a working libreelec mainline uboot

 

```

LABEL LibreELEC
  LINUX /KERNEL
  FDT /meson-gxbb-wetek-play2.dtb
  APPEND boot=LABEL=LIBREELEC disk=LABEL=STORAGE quiet systemd.debug_shell=ttyAML0 console=ttyAML0,115200n8 console=tty0

```

 

Whats the link with odroidn2 if anything i thought it would have been odroidc2

Link to comment
Share on other sites

Posted (edited)

Hi so managed to get my hands on a cable and this is the output:

 

GXBB:BL1:08dafd:0a8993;FEAT:EDFD718C;POC:3;RCY:0;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:1;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:2;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:3;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:4;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:5;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:6;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:7;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:8;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;

 

Also just want to clarify, that my emmc is completely clean wiped and doesn't have anything on it (android or linux). I did this by booting up using libreelec and then wiping using dd if commands. This allowed me to boot a mainline uboot kernel of libreelec.

 

Just for information, here is another SD card with mainline libreelec and how it shows up on the serial after trying the armbian sd card, taking it out and putting the libreelec one in on the same power cycle:

 

GXBB:BL1:08dafd:0a8993;FEAT:EDFD718C;POC:3;RCY:0;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:1;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:2;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:3;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:4;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:5;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:6;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:7;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:8;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:9;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:F3;USB:8;LOOP:A;EMMC:0;READ:0;CHK:F3;SD:800;USB:8;LOOP:B;EMMC:0;READ:0;CHK:F3;SD:800;USB:8;LOOP:C;EMMC:0;READ:0;CHK:F3;SD:800;USB:8;LOOP:D;EMMC:0;READ:0;CHK:F3;SD:0;READ:0;CHK:0;
no sdio debug board detected
TE: 66697062

BL2 Built : 09:01:42, Oct 11 2016.
gxb g88b04d6 - haixiang.bao@droid05

set vcck to 1100 mv
set vddee to 1000 mv
Board ID = 4
CPU clk: 1536MHz
DDR chl: Rank0+1 diff @ 912MHz
DDR0: 1024MB(auto)-2T-13
DDR1: 1024MB(auto)-2T-13
DataBus test pass!
AddrBus test pass!
Load fip header from SD, src: 0x0000c200, des: 0x01400000, size: 0x00004000
New fip structure!
Load bl30 from SD, src: 0x00010200, des: 0x01000000, size: 0x0000d460
Sending bl30......................................................OK.
Run bl30...
Load bl31 from SD, src: 0x00020200, des: 0x101000[0, size: 0x00018190
Image: gxb_v1.1.3135-18177fc 2016-06-24 11:00:09 yun.cai@droid06]
OPS=0x13
88 27 62 c4 87 12 6c 7 45 11 85 12 [66.794573 Inits done]
secure task start!
high task start!
low task start!
Load bl33 from SD, src: 0x0003c200, des: 0x01000000, size: 0x000a2ed0
NOTICE:  BL3-1: v1.0(debug):bc3419d
NOTICE:  BL3-1: Built : 14:16:22, Aug 15 2016
INFO:    BL3-1: Initializing runtime services
WARNING: No OPTEE provided by BL2 boot loader
ERROR:   Error initializing runtime service opteed_fast
INFO:    BL3-1: Preparing for EL3 exit to normal world
INFO:    BL3-1: Next image address = 0x1000000
INFO:    BL3-1: Next image spsr = 0x3c9

<debug_uart>


U-Boot 2022.04 (May 28 2022 - 12:48:46 +0000) wetek-play2

Model: WeTek Play 2
SoC:   Amlogic Meson GXBB (S905) Revision 1f:c (13:1)
DRAM:  2 GiB
Core:  156 devices, 23 uclasses, devicetree: separate
MMC:   mmc@70000: 0, mmc@72000: 1, mmc@74000: 2
Loading Environment from nowhere... OK
In:    serial
Out:   serial
Err:   serial
[BL31]: tee size: 0
Net:   eth0: ethernet@c9410000
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
Found /extlinux/extlinux.conf
Retrieving file: /extlinux/extlinux.conf
1:      LibreELEC
Retrieving file: /KERNEL
append: boot=LABEL=LIBREELEC disk=LABEL=STORAGE quiet systemd.debug_shell=ttyAML0 console=ttyAML0,115200n8 console=tty0
Retrieving file: /meson-gxbb-wetek-play2.dtb
## Booting kernel from Legacy Image at 08080000 ...
   Image Name:
   Image Type:   AArch64 Linux Kernel Image (lzo compressed)
   Data Size:    11536858 Bytes = 11 MiB
   Load Address: 01c80000
   Entry Point:  01c80000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 08008000
   Booting using the fdt blob at 0x8008000
   Uncompressing Kernel Image
   Loading Device Tree to 000000003fff3000, end 000000003ffff4e5 ... OK

Starting kernel ...

[BL31]: tee size: 0
LibreELEC:/ # [BL31]: tee size: 0
[BL31]: tee size: 0

 

 

Edited by mfizz
Link to comment
Share on other sites

44 minutes ago, mfizz said:

Also just want to clarify, that my emmc is completely clean wiped and doesn't have anything on it (android or linux).

That is your problem.  The armbian tv box image you are using uses the uboot from the android install to boot.  The sd image doesn't have a uboot on it.

Link to comment
Share on other sites

So without sounding silly, is there some way to change that? so it just uses the standard uboot as opposed to the android one. Is it just specifically the android one that is required? Or is it a one off thing and then i can install to emmc and still be able to boot mainline u-boot from sd card?

 

One other reason I don't want to be relying on android boot especially wetek as they have no support and even removed all existing files they hosted.

 

 

Link to comment
Share on other sites

@mfizz This is a signed u-boot.bin.sd.bin file (u-boot 2022.07) for WP2 that can be written to SD or eMMC in the normal way (https://github.com/LibreELEC/LibreELEC.tv/blob/master/projects/Amlogic/bootloader/mkimage#L8-L9). It allows u-boot and MBR structures to coexist so you can partition emmc as you like for an Armbian install: https://chewitt.libreelec.tv/testing/u-boot/u-boot.bin.sd.bin-wetek-play2

 

NB: The WP2 boot FIPs for signing are here (extracted from WeTek u-boot sources): https://github.com/LibreELEC/amlogic-boot-fip/tree/master/wetek-play2

Edited by chewitt
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...