Jump to content

can't SSH on new orange pi one 1st install


ice
 Share

Recommended Posts

Hi All,

 

I am a total newbie in orange pi and ambian. I just want to use orange pi one as my pi hole server.

 

i use sandisk ultra pro 32G a a huawei 2A power block using usb to barrel connector.

 

After my first install, and try to ssh, the port 22 timed out in armbian

I also tried reflashing to debian, and still cannot ssh.

 

I already tried some suggestion i found like dpkg-reconfigure openssh-server, changing time out of ssh.

 

i tried armbianmonitor -u, but im getting a Network/Firewall problem detected. you think this might be related to ssh connection.

 

thanks!

 

Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

22 hours ago, CryBaby said:

Can you ping it?

 

What does ssh -v say?

 

OpenSSH_for_Windows_8.1p1, LibreSSL 3.0.2
debug1: Connecting to 192.168.254.128 [192.168.254.128] port 22.
debug1: connect to address 192.168.254.128 port 22: Connection timed out
ssh: connect to host 192.168.254.128 port 22: Connection timed out

 

C:\WINDOWS\system32>ping 192.168.254.128

Pinging 192.168.254.128 with 32 bytes of data:
Reply from 192.168.254.107: Destination host unreachable.
Reply from 192.168.254.107: Destination host unreachable.
Reply from 192.168.254.107: Destination host unreachable.
Reply from 192.168.254.107: Destination host unreachable.

Ping statistics for 192.168.254.128:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

 

i also ssh the orange pi one within itself, orange can ssh itself

tried changing port 22 to 80, 95 and 55555, still my pc cant ssh the orange pi one.

 

here is the output of my monitor

armbianmonitorpart1

armbianmonitorpart2

Link to comment
Share on other sites

Yep.  From your diagnostic logs:

 

   793	2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
   794	    link/ether 02:81:6e:ea:b6:35 brd ff:ff:ff:ff:ff:ff

 

  2072	[   25.939521] dwmac-sun8i 1c30000.ethernet eth0: PHY [0.1:01] driver [Generic PHY] (irq=POLL)
  2073	[   25.947754] dwmac-sun8i 1c30000.ethernet eth0: Register MEM_TYPE_PAGE_POOL RxQ-0
  2074	[   25.949767] dwmac-sun8i 1c30000.ethernet eth0: No Safety Features support found
  2075	[   25.949785] dwmac-sun8i 1c30000.ethernet eth0: No MAC Management Counters available
  2076	[   25.949798] dwmac-sun8i 1c30000.ethernet eth0: PTP not supported by HW
  2077	[   25.955635] dwmac-sun8i 1c30000.ethernet eth0: configuring for phy/mii link mode
  2078	[   25.969182] dwmac-sun8i 1c30000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
  2079	[   25.969259] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

 

This needs to be sorted out first.

 

Try this command to try enable eth0

/sbin/ifconfig eth0 up

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...