Jump to content

Retroarch in Armbian

Go to solution Solved by Glock24,

Recommended Posts



I installed Retroarch from the repos, tried to install a "core" from the Retroarch updater but no cores were available. I searched about that if the installed version is too old no cores will be available, so I added the Retroarch ppa and installed the newest version, but got the same problem.


Does Retroarch work under Armbian? Do I need to manually install "core" binaries? If so, where can I get them?



Link to comment
Share on other sites

What image are you using? There are many ways to install this. I'd advice to start with a fresh, current jammy and build retroarch yourself.


The problem is that RetroArch doesn't provide arm64 cores.


There are gaming images for arm64 boards that include these cores. Good luck.

Link to comment
Share on other sites

  • Solution

I'm using the latest Ubuntu-based Armbian stable for Nanopi M4v2.


Thanks for the answer, I'll try to build the cores from source.


From what I understand, the current kernel does have 3D HW acceleration for Mali-T860, right?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines