Jump to content

Can't write to emmc


rican
 Share

Recommended Posts

Hello, I need your help to solve my problem with the eMMC internal disk of my TV box. This is the VONTAR X96 mini model, purchased in June 2019, with 2GB of RAM and 16GB disk. The processor is an Amlogic S905W. I transformed this Android TV box into a Linux server several years ago and I was satisfied with it. A few months ago, during a reinstallation, the internal 16GB eMMC disk became READ-ONLY!
It is still visible and accessible (mmcblk1) but I can no longer update it!
I tried to transfer the contents of the SD-Card to the internal eMMC storage, but no update is done.
Thank you in advance for your help !
Ricardo
PS :
1) I used these settings during installation
u-boot.ext = u-boot-s905x-s912
dtb = amlogic/meson-gxl-s905w-p281.dtb
2) Below the result of armbianmonitor -u

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

I'm not certain of this, but I've seen thumb drives that were failing change to "read only" on their own, possibly the internal eMMC  is failing, especially if it was constantly written to with swap and log files.

Have you tried deleting any files on the eMMC?

Edited by s-petersen
Link to comment
Share on other sites

My only thoughts would be to try to use the amlogic tools to reflash an original android firmware.  If that can be done, then the emmc is still at some level writeable.  If that works, then you could start over the process of installing armbian.  If reinstalling the original firmware fails, I think it may be a hardware issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...