Jump to content

RTL8188FU driver install


Recommended Posts

I was able to get RTL8188FTV $2.00 US USB wifi https://www.ebay.com/itm/123713550193 working with a script I made from a forked project. The power saver has already been disabled in the Makefile. Check out https://github.com/sgjava/rtl8188fu/tree/arm. I've tested this on ARM 32 and ARM 64, but not x86 or x86_64. This is currently a dkms module that requires beta repos to get matching kernel headers.

Link to comment
Share on other sites

Good timing!  I had a couple of these arrive yesterday.


In the script, it says

sudo -E apt -y install linux-headers-edge-$LINUXFAMILY >> $logfile 2>&1


Is this because it's only expected to work with the edge kernel, or if I change "edge" to "current" in that line, should it work for the current kernel?

Link to comment
Share on other sites



I can confirm that the script works on my Rock64 board, running bullseye CLI with the current branch.  At first I thought it wasn't working, but then I moved it to a different spot and tried an open WiFi network.  I'm still not sure if I can get it working with my normal WPA2/WPA3 network.


Oh, and you might want to change "edge" to "$BRANCH" in the manual instructions, too.

Link to comment
Share on other sites

I did a little more experimenting, and found that it connects without a problem when I tell it to use WPA2, rather than WPA3.  I don't know whether the problem with WPA3 is in my router or the client, but WPA2 is good enough for now.


I can also confirm that your script works on an A64-LTS board, too, so thank you again!

Link to comment
Share on other sites

Successfully built on armv7l. Thanks for releasing the script!

[ 2810.712732] rtl8188fu: loading out-of-tree module taints kernel.
[ 2810.818513] =======================================================
[ 2810.818520] ==== Launching Wi-Fi driver! (Powered by Rockchip) ====
[ 2810.818525] =======================================================
[ 2810.818529] Realtek 8188FU USB WiFi driver (Powered by Rockchip) init.
[ 2810.818535] RTL871X: module init start
[ 2810.818541] RTL871X: rtl8188fu v4.3.23.6_20964.20170110
[ 2810.820396] usbcore: registered new interface driver rtl8188fu
[ 2810.820456] RTL871X: module init ret=0


May I ask if I need to run it again every time I upgrade the kernel?




from Brazil

Edited by BLFC
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines