Jump to content

Boot from eMMC + system on NVME on OrangePI 3b

Go to solution Solved by joekhoobyar,

Recommended Posts


I'm trying to install Armbian using `armbian-install` on NVMe, with bootloader on eMMC.
I have installed 64GB Foresee eMMC module and 256GB WD SN530 2242 SSD.

When I boot from SD card, both storages are detected. Using fdisk, I made them both `dos` (mbr) partitioned.
Then I invoke `armbian-install`, it proceeds without any problems using eMMC+sata/nvme/usb option, and I have now 512 MB boot partition on eMMC, the rest of eMMC space as secondary, f2fs partition, and ext4 partition nvme0n1p1 containing the rest of the system.
I power the system off, take the SD card out, and boot again.. and I'm stuck in initramfs. From it, I can mount the nvme0n1p1 manually without problems, so the partition is readable and mountable.
When I mount nvme0n1p1 as `/` and try to `exit` from initramfs, I am getting kernel panic, but I don't know if it's related or not.

It seems to be not a PSU issue (I tried a few 5V 2-3A), not an SD card issue (the system boots and works fine from it), nor the eMMC issue (I installed the system onto the 64GB eMMC only, without nvme, and it worked as well).

Tried installing both Armbian_community_24.5.0-trunk.6_Orangepi3b_bookworm_legacy_5.10.160_minimal and Armbian_23.11.1_Orangepi3b_bookworm_edge_6.6.2, both exhibit the same behavior.


What's wrong with me and what can I do to fix the boot? I searched for solutions around, but did not find any similar...


Edited by bderleta
Link to comment
Share on other sites

  • Solution

For me, the following works:

  • Foresee 64GB EMMC, 512GB NVME (no SD card)
  • Running armbian-install, choosing Boot from SD + system on SATA/USB/NVME
  • Rebooting

Perhaps when you were resizing, repartitioning, etc., your boot volume, something got messed up?

Link to comment
Share on other sites

Meanwhile, I managed to do it another way:

- "Boot from eMMC / system on eMMC" via armbian-install -> that creates two partitions on eMMC, one boot, one rootfs

- fdisk, mkfs.ext4 on nvme, rsync all files from rootfs eMMC partition to nvme

- note down UUID of nvme partition from blkid, replace it in /etc/fstab and /boot/armbianEnv.txt, reboot

- nuke rootfs partition on eMMC as it's not used anymore


Did you boot from eMMC? You mention no SD card, yet somehow you could run armbian prior to install it; or PXE boot?

Edited by bderleta
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines