Jump to content

mainline u-boot on 5B


Recommended Posts

I have managed to install mainline u-boot on my 5B.  i copied the 5It boots from both MMC and the SD.  To boot from the sd, you have to interrupt the boot process and tell it to boot from MMC0.  the default boot order is:

mmc1 mmc0 nvme scsi usb pxe dhcp spi


I've tried a number of things to correct the issue but none worked.  In the aliases section of rk3588s-orangepi-5b.dts, I had to device sdchi as MMC0 (it really is MMC1).   Not it boots like it should.  Is there a better way to get u-boot to boot from SD card first?





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines