Jump to content
  • 0

8189fs driver setting MTU on Kernel 4.10.0



Hi All,


I seem to be encountering an issue with setting the MTU for the 8189fs driver on the 4.10.0-sun8i kernel


I am trying to set the MTU for wlan0 to 1532. Note this works on the 3.4.113-sun8i kernel without issue.


#uname -a

Linux orangepipcplus-02c0008115dff7be 4.10.0-sun8i #10 SMP Sun Feb 12 16:51:59 AEST 2017 armv7l armv7l armv7l GNU/Linux
auto wlan0
iface wlan0 inet6 manual
        wireless-channel 1
        wireless-essid batnet6
        wireless-mode ad-hoc
        wireless-ap 02:13:13:13:13:13
        mtu 1532
# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:e0:4c:67:db:86
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:12285 errors:0 dropped:3 overruns:0 frame:0
          TX packets:673 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1693434 (1.6 MB)  TX bytes:63171 (63.1 KB)
# ifconfig wlan0 mtu 1532
SIOCSIFMTU: Invalid argument
# /bin/ip link set mtu 1532 dev wlan0
RTNETLINK answers: Invalid argument
# ifup wlan0
sysctl: setting key "net.ipv6.conf.wlan0.mtu": Invalid argument



SIOCSIFMTU: Invalid argument

indicates that the requested MTU was rejected by the kernel. Typically this would be due to it exceeding the maximum value supported by the interface hardware. In that case you must either reduce the MTU to a value that is supported or obtain more capable hardware.


If this was a hardware restriction It wouldn't work on the 3.4.113-sun8i kernel, so this leads me to think its the driver on the 4.10.0-sun8i kernel.
Is anyone here familiar with the code of this driver and able to confirm for me if this is a known issue?



Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

This topic is now closed to further replies.

  • Create New...