Jump to content

Rupa X88 Pro 13 - RK3528 board with images


Recommended Posts

So I bought this chinise Android TV Box and would love to install armbian on it. I am new on this and discovered armbian just after buying it. I didn't know there was no support and not official open source for the Rockchip RK3528, otherwise I would have chosen any other. The box works fine but it has that known malware that send packets to suspicious links (I scanned activity with pi-hole).

 

Description says it has 2GB RAM and 16GB storage (Hynix H26M51002KPR)

WiFi chip is LGX8800D

 

I attach images of the board and all of it's componentes, including IR sensor and display. It also has a red LED that turns on when in stand-by mode.

I hope this help to develop or patch a working version of armbian for it. I have already read about some patches around that would probably work, but I' new to this and I'm not sure how to start.

What I would like to do first is a completly ROM backup, and start doing test with a pendrive or SD card, not writting directly to the eMMC (if possible) until the important things get working. And any help would be appreciated.

 

Edit: I will keep posting in this thread with my progress (or attemps!)

 

 

board1.jpg

board2.jpg

board3.jpg

board4.jpg

board5.jpg

board6.jpg

board7.jpg

board8.jpg

board9.jpg

display.jpg

Edited by fedes_gl
Link to comment
Share on other sites

Posted (edited)
12 hours ago, blust0ne said:

try to this image,  it may work for you.

Thank you. Before doing so, I would like to backup the firmware, which I'm a little troubled. I'm trying with a tool called rkdumper from xda forum, but it seems to fail with the RK3528. Seems it is read protected.

 

However, I suppose I can boot and use armbian from SD with touching the eMMC, right?

Edited by fedes_gl
Link to comment
Share on other sites

I tried to dump the full firmware to have a backup but I couldn't do this because its read protection. Apparently I could only extract uboot.img and many other files. There is  a workoround by unpacking that file, editing 4 bytes with any HEX editor, repacking and flashing, that allows to fully dump the firmware after tweaking it. 

I'm not sure of any risk of bricking the device If anything goes wrong. 

By the momment I cannot unppack the uboot.img file to do the trick.

 

Also I'm looking for some more information about how to use the UART interface with it. I have a UART USB dongle (CP2102 chip) that I believe I can use to connect it. Any information would be appreciated.

Link to comment
Share on other sites

On 4/14/2024 at 11:28 AM, Hqnicolas said:

I'm thinking about buyng an RK3528 Shit box,
but X88 pro 13 just have 10/100M Ethernet RJ45 port

Yes, mine is 10/100M. I'm using it to watch content on a 1080p TV and works pretty fine. If useful to you, it has an USB 3.0 port, to use an external HDD or probabbly a gygabit LAN to USB dongle...

Link to comment
Share on other sites

4 hours ago, Hqnicolas said:

1080p on linux?
the gpu was working?

Sorry for the confusion. For the moment I'm using it with original android firmware. 

 

I tried the build suggested by user blustOne (above in this thread), booting from SD card, GPU has signal output but seems not to have HW acceleration for playback (it loads the file, but stutter/choppy playback). Also no sound through HDMI port. 

 

I'm tring to first dump the entire firmware of the device. I don't want to get it bricked because of playing with it. Once I can dump it, I will try to play with the armbian variants, try to build my own, etc. I have never done this and I know I have a long way ahead reading and learning (and no much time), just I want to start with the backup. I will also try to debloat the android version.

I'm using it connecting a flash drive with videos, I connect it to internet as little as possible, it has many bloatware that I'm not sure of what thing it can cause in my private network. Probbaly i'm worring too much about it? ..

Link to comment
Share on other sites

Posted (edited)

So I managed to extract .dtb files from uboot.img using  this extract-dtb tool. 

 

Later on, on a  PC running Ubuntu 22.04 LTS I used "device tree compile" to decompile thos dtb files into dts files. 

 

I followed this article trying to use those DTS files to get the correct hardware informatin and/or drivers, but the /boot folder in the flashed SD card is empty. Probably, as the article says, dtb overlay is not activated in this image.

Edited by fedes_gl
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines