Jump to content

Trying to burn the latest armbian build and gets always corrupted

Recommended Posts

So i've been using the build: "Armbian_community_24.8.0-trunk.6_Aml-s9xx-box_jammy_edge_6.8.10" and trying to burn it with balenaEtcher.

The issue is that when ending to verify and configuring - inserting the sd card into a TX3 Mini (board is v1.6) goes into a bootloop.

This does happen with all of my sd cards and flash drives, and no, its not that they're faulting, CoreELEC does flash and boot correctly in all of them.

I also did the f3 test, and no issues were found.


Something particular that I have found is that macOS does detect very easily the corruption and ejects the drive/card, while Windows just lets it pass "as intended"


I've also tried in another PC but got same issue.


Any help would be appreciated, thanks!




Link to comment
Share on other sites

Posted (edited)
22 minutes ago, SteeMan said:

What size and type of sd card?

Im using mini sd cards, one is 16gb  and the other is just 8gb; i also tried with an 8gb usb flash drive

22 minutes ago, SteeMan said:

What uboot and dtb are you using?

u-boot is s905x-s912 and dtb is "meson-gxl-s905w-tx3-mini"


Also i flashed the box yesterday to stock rom (i was using atvx) but now there is not a bootloop, it just boots normal android (still detects and boots coreelec)

Edited by carlop3333
Link to comment
Share on other sites

14 minutes ago, carlop3333 said:

(still detects and boots coreelec)

Per the installation instructions, if you ever run another os (like coreelec) you will not be able to run armbian.  You have to reflash a clean android environment to run armbian.

Link to comment
Share on other sites

1 hour ago, SteeMan said:

As the instructions say, you need to try all dtbs compatible with your cpu to find one that hopefully will work.  Have you done that?

Yep, nothing

58 minutes ago, SteeMan said:

Also, this thread seems to be similar to yours.  I don't know if the board revision is the same as yours.

Where's the link?

Link to comment
Share on other sites

This is getting weirder... so i found out about ophub's armbian build.... It works


macOS does not detect any corruption on the drive, and boots without any issue...


I'm just coming to the conclusion that the issue is the armbian image itself.. tried other 3 latest builds, nope. Tried an archived build... nothing as well, same formatting error


(Just in case, the board is the same as the one detailed in this forum)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines