• 0

How to remove Bluetooth module (for good) from CT/Armbian


Giunti
 Share

1 1

Question

I'm currently running  ARMBIAN 5.25 Debian GNU/Linux 8 (jessie) 4.10.12-sunxi on my Cubietruck, which otherwise works fine as a headless data and media server. However,

as I don't need any Bluetooth service whatsoever in the given environment, I have been trying to get rid of it - in vain.

Is there a safe and lasting method of preventing the Bluetooth module from loading on reboot? Can it be stripped from the system at all completely? 

 

Many thanx in advance

Link to post
Share on other sites

7 answers to this question

Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

  • 0

On the Xenial Ubuntu image, the following worked (thanks martinayotte, I just fleshed out your suggestion):

 

sudo systemctl disable bluetooth.service
sudo systemctl stop bluetooth.service

 

You'll see if you run systemctl status bluetooth.service afterwards that it is no longer active. :D 

 

Might I ask exactly why you were wanting to disable it? I have a CT running as a media/data/intranet web server also, and can't say I ever bothered doing anything with the bluetooth, so just left it how it was as it didn't seem to be hurting anything (other some unnecessary RF and power drain, I'm sure!)

Link to post
Share on other sites

  • 0

Thank you,  martinayotte and pfeerick !

I followed your hints and got this in return.

Quote

root@CT:~# systemctl disable bluetooth
Synchronizing state for bluetooth.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d bluetooth defaults
Executing /usr/sbin/update-rc.d bluetooth disable
insserv: warning: current start runlevel(s) (empty) of script `bluetooth' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `bluetooth' overrides LSB defaults (0 1 6).
Removed symlink /etc/systemd/system/dbus-org.bluez.service.

So currently bluetooth isn't active any more. However, I haven't had the chance to reboot the system, as a weekly backup is running at the moment. So I'll have to postpone that. Then I'll see if the current status prevails.

 

@pfeerick:

The sole reason for my wanting to get rid of bluetooth was that I wanted to keep the headless system as slim as possible, save resources for purposes I do need and keep power consumption as low as posible. That's all.

Link to post
Share on other sites

  • 0

Well now, after rebooting the system, "dmesg" still lists Bluetooth in the startup log:

 

Quote

Sat Apr 29 15:54:36 CEST 2017 sun7i armv7l 4.10.12-sunxi  Cubietruck 5.25

### dmesg:

. . .

[   19.096299] EXT4-fs (mmcblk0p1): re-mounted. Opts: data=writeback,commit=600,errors=remount-ro
[   21.809943] Bluetooth: Core ver 2.22
[   21.810151] NET: Registered protocol family 31
[   21.810163] Bluetooth: HCI device and connection manager initialized
[   21.810203] Bluetooth: HCI socket layer initialized
[   21.810231] Bluetooth: L2CAP socket layer initialized
[   21.810308] Bluetooth: SCO socket layer initialized
[   21.824968] Bluetooth: RFCOMM TTY layer initialized
[   21.825025] Bluetooth: RFCOMM socket layer initialized
[   21.825080] Bluetooth: RFCOMM ver 1.11
[   21.905001] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[   21.905046] Bluetooth: HIDP socket layer initialized
[   21.997144] Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
[   22.158662] fuse init (API version 7.26)

. . .

However, when checking service status, it tells me that there is no such service running.

   >root@CT:~# service bluetooth status
   >[FAIL] bluetooth is not running ... failed!

 

I don't quite get that.

 

 

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

1 1