Firefox browser fails to launch


jimg
 Share

3 3

Recommended Posts

Firefox (not Chromium this time) is now crashing on me when I attempt to launch it on an Orange Pi PC+.  Seems to be related to a new security update I think I got (55.0.1+build2-0ubuntu0.16.04.2).  Anyone else having this problem?

Link to post
Share on other sites

Donate and support the project!

This is a known problem that appears to be compiler-related:

 

https://bugzilla.mozilla.org/show_bug.cgi?id=1391802

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1711337

 

A fix appears to have been released for Ubuntu 17.04, but that version won't install due to unmet dependencies that can't be satisfied with Armbian (libstdc++6 (>= 6)).  The last stable build I could find for armhf is Firefox 52.  You can download it from here via FTP:

 

ftp://ports.ubuntu.com/ubuntu-ports/pool/main/f/firefox/firefox_52.0.2+build1-0ubuntu0.12.04.1_armhf.deb

 

These are the steps I took to remove the broken version, install the unmet dependencies, install the older, working version, and prevent it from being automatically upgraded back to the new, broken version.

sudo apt remove firefox
sudo apt-get install libpango1.0-0
sudo dpkg -i ~/Downloads/firefox_52.0.2+build1-0ubuntu0.12.04.1_armhf.deb
sudo apt-mark hold firefox

(TIL: gdebi is a very useful tool for seeing the dependencies of a package before you install it.  You can use it from the command line like so:

 

sudo gdebi <name of deb package>

to see the dependencies you might need to install before installing a package.)

Link to post
Share on other sites

This is a late post but I got version 57 working per these instructions today -

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1711337/comments/40

 

As root I had to use this line -

root@odroidxu4:/# echo 'user_pref("gfx.content.azure.backends", "");' >> ./home/technicavolous/.mozilla/firefox/9c00y7fq.default/prefs.js

I found that using

root@odroidxu4:/# find -name prefs.js

from the root directory as root.

(didn't seem to work with sudo)

 

I'm running Armbian on an XU4 

root@odroidxu4:/# uname -a
Linux odroidxu4 4.9.61-odroidxu4 #2 SMP PREEMPT Wed Nov 22 16:34:23 CET 2017 armv7l armv7l armv7l GNU/Linux

 

Don't forget to mark firefox so it doesn't get 'upgraded' to the latest broken version -

root@odroidxu4:/home/technicavolous# apt-mark hold firefox
firefox set on hold.
 

ADD: and it plays HD!! I got 720 working fine but my bandwidth doesn't handle 1080 ... and I think the fix above may reduce the graphics capability but hey, it plays!

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

3 3