1 1
garlic

Orange Pi Zero Sound Problem

Recommended Posts

I run Armbian_5.30_Orangepizero_Ubuntu_xenial_default_3.4.113 in my zero.

I add headset in jack, A noise start with system boot and never stop,I try play music with pygame, at first can play with noise, and system crash soon.

I have to reboot it by power line.

Share this post


Link to post
Share on other sites
12 hours ago, chwe said:

Maybe start with this:

https://www.armbian.com/search_gcse/

And probably read through this:

 

I had try,but failed.

My problem is that analogue line-out output noise like electricity sound. And when I play music, the system go to crash.

 

Oh~~~!

I found that is my jack's problem!

This jace can't be put headset with mic in it.

My system crash by my power amplifier's line. I make left & right output GND in one trumpet. And my seller said that it can't be same way.

Thank you.

Share this post


Link to post
Share on other sites
On 27/9/2017 at 6:58 PM, garlic said:

I had try,but failed.

My problem is that analogue line-out output noise like electricity sound. And when I play music, the system go to crash.

 

Oh~~~!

I found that is my jack's problem!

This jace can't be put headset with mic in it.

My system crash by my power amplifier's line. I make left & right output GND in one trumpet. And my seller said that it can't be same way.

Thank you.

I have the same issue but I'm not resolving.

I'm not connecting left and right negative toghether. If I understood correctely and that was the issue there.

 

I've negatives from speakers (left/right) connected separately on their negative.

 

I've enabled analog-codec I can see the audio card but can't play sound but noise and then crash when attempt to start to play.

 

[update]

It works connecting the "LINEOUTL" pin only!

Connecting even the LINEOUTR channel results in a kernel panic and reboot when you attempt to play something.

Has anyone gone into this? Solution?

 

After some playing time, like 20 seconds it crashes even in LINEOUTL alone configuration.  It's like repeating the same 0.2seconds of song forever and only solution is to turn off the electricity.

 

thank you

Share this post


Link to post
Share on other sites

audio is continuing to work using only one channel.

 

The audio will enter in loop when more than one ssh instance is created.

 

If I create first ssh instance then start the music and leave this alone there's no problem. If I then connect with a second ssh I have audio loop. :huh:

 

[update]

from the attached imaged seems like we need some electronics to make this work? correct?

I'm using a PAM8403

opizeroLRout.jpg

Share this post


Link to post
Share on other sites

My findings so far (some of the previous findings are wrong):

- Audio will work on one channel only.

No matter whether is LINEOUTR or LINEOUTL connected, but OPI0 is allowing only one channel alone, otherwise the board will crash horribly. The green status light glows a little bit then turn off and the board reboots. Seems like a bad short circuit or something.

I tested LINEOUTR and LINEOUTL alone and both are working. So there's something wrong in the stereo configuration.

 

- Audio loops were caused by bad settings on the alsamixer. Now I'm able to start playback in background and open multiple ssh sessions.

Attached the screenshot of my alsamixer working settings.

AlsaMixerConfiguration.png

 

("DAC Reverse": what?)

 

Now I would like to have working stereo sound.

 

Welcome to ARMBIAN 5.38 stable Ubuntu 16.04.4 LTS 4.14.18-sunxi

analog-codec layer enabled in /boot/armbianEnv.txt

 

Any hint?

Share this post


Link to post
Share on other sites

Now the audio loops no matter alsa mixer settings and no matter I'm using it in single channel only.

 

This is from my dmesg

[   12.083950] sun4i-codec 1c22c00.codec: ASoC: /soc/codec-analog@01f015c0 not registered
[   12.083967] sun4i-codec 1c22c00.codec: Failed to register our card
[   12.101011] sun4i-codec 1c22c00.codec: Codec <-> 1c22c00.codec mapping ok

4.14.18-sunxi

Orange Pi Zero v1.4

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1