0
mjc

Banana Pro LCD Display over LSAD

Recommended Posts

Hi Guys,

 

I buy me in LCD-Display (BL035-RGB). This will be connect to my Banana PRO. All this I do, how it is 
described on this page "here".
After change the config, add the script.bin and reboot, the display do nothing. It all the time black. It come no flash or something.

My question is, what I have to change on my Banana Pro? I have install ARMBINA 5.31 (4.11.6-sunxi).

One thing. How I can test the LCD-Display for conection? Can I send commandos to the Display?

thanks for YOU help.

Share this post


Link to post
Share on other sites
(edited)

Hello Everybody,

 

just having the same question.I want to use a 7" display on my banana PI with the current version of Armbian (4.14.14).Do I still have to go through the build process? I could find this comment telling that the drivers are now integrated https://docs.armbian.com/boards/bananapi/.

How do I use the drivers?

Thanks for any information!

 

Regards

Vore

Edited by vore76

Share this post


Link to post
Share on other sites
On 6/20/2018 at 10:12 PM, vore76 said:

Anybody?

The driver you quoted is for legacy kernel. LCD enabling is much simpler with legacy. Mainline needs the steps mentioned in the tutorial.

Hope that helps!

Share this post


Link to post
Share on other sites

Hello!

Ok, I followed the tutorial. But I'm having issues with the file "sun7i-a20-bananapi.dtb". I'm quite sure that I'm doing everything as mentioned in the tutorial but something seams to be wrong.

I get this during the build process:

 DTC     arch/arm/dts/sun7i-a20-bananapi.dtb
arch/arm/dts/sun7i-a20-bananapi.dtb: ERROR (phandle_references): Reference to non-existent node or label "reg_dcdc2"

arch/arm/dts/sun7i-a20-bananapi.dtb: ERROR (phandle_references): Reference to non-existent node or label "edt_ft5x06_pins_a"

arch/arm/dts/sun7i-a20-bananapi.dtb: ERROR (phandle_references): Reference to non-existent node or label "edt_ft5x06_pins_b"

arch/arm/dts/sun7i-a20-bananapi.dtb: ERROR (phandle_references): Reference to non-existent node or label "led_pins_bananapi"

arch/arm/dts/sun7i-a20-bananapi.dtb: ERROR (phandle_references): Reference to non-existent node or label "gmac_power_pin_bananapi"

ERROR: Input tree has errors, aborting (use -f to force output)
scripts/Makefile.lib:327: recipe for target 'arch/arm/dts/sun7i-a20-bananapi.dtb' failed
make[2]: *** [arch/arm/dts/sun7i-a20-bananapi.dtb] Error 2
dts/Makefile:44: recipe for target 'arch-dtbs' failed
make[1]: *** [arch-dtbs] Error 2
Makefile:908: recipe for target 'dts/dt.dtb' failed
make: *** [dts/dt.dtb] Error 2
[ error ] ERROR in function compile_uboot [ compilation.sh:173 ]
[ error ] U-boot compilation failed 
[ o.k. ] Process terminated 

Could somebody check the file? Maybe I'm overseeing something?

Thank you!

sun7i-a20-bananapi.dts

Share this post


Link to post
Share on other sites

Hello!

Finally I could solve the issues and compile the files. I had issues with strange characters in the files after editing them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0