Samba Setup
0

11 posts in this topic

Recommended Posts

I have a Orange PI PC that I"m setting up as my file server with samba.  I am using a hard drive with a SATA to USB adapter for my storage device.

 

I've read and tried many HOW-TOs and none of them seem to get it working properly.  Even though, they all say it is easy and it looks easy.

 

I am able to see the shared folder over the network but Windows says that I don't have permissions to access it.

 

One idea that I've had is that I'm not accessing the share folder through the config file.  However I'm not sure how to properly access my HDD.  Right now I am using the path that you would get from opening the disk on the desktop.  Something like "\media\user\share"

 

Any ideas on first steps or fixes?

 

Thanks!

Share this post


Link to post
Share on other sites

Need to see your smb.conf file to help you on this.  Its most likely a permission problem, like allowing guests to see the samba share. 

Share this post


Link to post
Share on other sites

Mount your HDD in folder inside your Home directory, so you will have full access through you active user elevations. You can edit fstab to be sure your HDD will be mounted in the same folder and paths after reboot. Better use mount by name (if you add name to your HDD volumes), or UUID. Then add your active user as smb user:

sudo smbpasswd -a <user_name>

Then add this at the end of your smb.conf (sudo nano /etc/samba/smb.conf):

[<folder_name>]
path = /home/<user_name>/<folder_name>
valid users = <user_name>
read only = no

testparm
sudo service smbd restart

To avoid sharing of all your Home directory by Samba, comment all sections, related to ";[homes]", including. Of course you can use different user, from your actual, system user, for Samba sharing, but this is the easiest way.

hazardsneon likes this

Share this post


Link to post
Share on other sites

Thanks for the replies.

 

I am currently set up to allow guests with my current smb.conf file.

 

I will try to mount my HDD to my home folder, hopefully tonight, and modify my conf file to reflect that.

 

Thanks again!

Share this post


Link to post
Share on other sites

So I tried my hand at taking some of your advise and combining with other information I found out on the web.

 

I modified my fstab file to auto mount my HDD by UUID to /media/user/share

 

Getting it to mount in the designated folder works but when I try to mount it on a Windows machine, it still says that I don't have permission to access the folder.

 

Here is my smb.conf file.  I'm sorry that it is so long but I started with the sample configuration file and I know that at the very beginning, I changed some of the settings and they might be causing me the problems.

Spoiler

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which 
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic 
# errors. 

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
	server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 192.168.190/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# Server role. Defines in which mode Samba will operate. Possible
# values are "standalone server", "member server", "classic primary
# domain controller", "classic backup domain controller", "active
# directory domain controller". 
#
# Most people will want "standalone sever" or "member server".
# Running as "active directory domain controller" will require first
# running "samba-tool domain provision" to wipe databases and create a
# new domain.
   server role = standalone server

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
   passdb backend = tdbsam

   obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
   unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
   pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
   map to guest = bad user

########## Domains ###########

#
# The following settings only takes effect if 'server role = primary
# classic domain controller', 'server role = backup domain controller'
# or 'domain logons' is set 
#

# It specifies the location of the user's
# profile directory from the client point of view) The following
# required a [profiles] share to be setup on the samba server (see
# below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the 
# SAMR RPC pipe.  
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.  
; add group script = /usr/sbin/addgroup --force-badname %g

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
   usershare allow guests = yes

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each
# user's home directory as \\server\username
;[homes]
;   comment = OPants
;   browseable = yes

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = no

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0775

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0775

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# Un-comment the following parameter to make sure that only "username"
# can connect to \\server\username
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samb
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

[global]
netbios name = opiserver
server string = My Samba Share %v
security = user
map to guest = bad user

[OPants]
comment = Orange Pi PC Server Share
path = /media/mickey/share
browseable = yes
writeable = yes
read only = no
guest ok = yes

 

After looking at this, I probably have issues with that "security" setting.  I thought that having "guest ok" set that it doesn't matter.

 

Thanks!

Share this post


Link to post
Share on other sites

I got to modify my smb.conf file last night.  I removed the security and map to guest settings.  I also noticed in

RagnerBG's example that the folder name had to be in the path and the brackets above the stanza (i think that is the proper term).  So I modified that as well.

 

I now have access from a Windows machine and am starting to move files from my old Windows 7 machine serving files to my OrangePI PC server!!

 

Thanks for the help!

 

Here is my modified section:

[global]
netbios name = opiserver
server string = My Samba Share %v

[OPants]
comment = Orange Pi PC Server Share
path = /media/mickey/OPants
browseable = yes
writeable = yes
read only = no
guest ok = yes

 

Naguissa likes this

Share this post


Link to post
Share on other sites

I came into another possible hiccup.  I successfully mapped my new samba share on two different win7 machines but when I went to map it to a win10 machine, it said that I don't have permissions and I need to close all other connections.

 

At the time I was transferring files from my old win7 server to this one but I thought that I should still be able to at least map it and even access the files.

 

Any ideas?

Share this post


Link to post
Share on other sites

I think you should check the permission of this folder - "/media/mickey/OPants", make it 777 for guests. But i would suggest you, to make it as simple, as possible. "guest ok = yes" - you don't need this, just add your user, as samba user (or create another user, only for samba sharing) and use - "valid users = <user_name>". "browseable = yes", "writeable = yes", i don't use this, so why should you? "read only = no" is enough. Try this config, as i already post above:

sudo smbpasswd -a <user_name>

[OPants]
path = /media/mickey/OPants
valid users = <user_name>
read only = no

That's all what i add and it's worked every time. And better change the sharing path to something in your samba user, Home directory, so you don't have to touch the permission. But i haven't deal with this joke - Win 10, so there may have some other surprise. Try to add the same workgroup, as on your Win 10 machine:

[global]
workgroup = WORKGROUP

 

hazardsneon likes this

Share this post


Link to post
Share on other sites

From  the spanish link before, that I posted on mobile:

 

[global]
workgroup = WORKGROUP
server string = Samba Server %v
netbios name = <name_of_the_server_on_your_network>
dns proxy = no
max xmit = 65535
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=65535 SO_RCVBUF=65535
read raw = yes
write raw = yes
max connections = 65535
max open files = 65535

[UNIT_NAME]
comment = <you_share_description>
path = <path_to_share>
browsable = yes
guest ok = yes
read only = no
create mask = 666
directory mask = 777
force user = <your_user_here>
force group = users
printable = no
public = yes

 

 

You have to change:

 

netbios name = <name_of_the_server_on_your_network>
[UNIT_NAME]
comment = <you_share_description>
path = <path_to_share>
force user = <your_user_here>

 

 

Then execute this to change samba password for desired user:

 

smbpasswd -a <your_user_here>

 

 

Then you'll have two options to login in your server: As guest or using user/pass defined in command above.

Share this post


Link to post
Share on other sites

I did as RagnerBG said and kept it simple.

 

I removed the lines that you don't have in your example.  I rebooted my machine and now the windows 10 machine can access the samba share.

 

Thanks!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

0

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.