0
Fazik83

Debian Stretch Next freeze

Recommended Posts

Hi all,

My Armbian hangs (freeze) after 1-2 hours. Below dmesg

Aug 17 19:10:39 localhost kernel: [ 1666.194984] WARNING: CPU: 0 PID: 693 at lib/iov_iter.c:695 copy_page_to_iter+0x21d/0x35c
Aug 17 19:10:39 localhost kernel: [ 1666.194987] Modules linked in: tun xt_nat xt_tcpudp iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_filter snd_soc_hdmi_codec rc_cec dw_hdmi_i2s_audio dw_hdmi_cec evdev sun8i_dw_hdmi dw_hdmi cec ir_lirc_codec lirc_dev pl2303 usbserial sun4i_i2s sunxi_cir sun8i_codec_analog sun4i_gpadc_iio sun4i_codec sun4i_tcon sun8i_mixer snd_soc_simple_card snd_soc_simple_card_utils snd_soc_core snd_pcm_dmaengine snd_pcm snd_timer snd soundcore sun4i_drm uio_pdrv_genirq uio 8189fs cfg80211 rfkill ip_tables x_tables pwrseq_simple sy8106a_regulator uas realtek
Aug 17 19:10:39 localhost kernel: [ 1666.195093] CPU: 0 PID: 693 Comm: nfsd Not tainted 4.14.18-sunxi #24
Aug 17 19:10:39 localhost kernel: [ 1666.195095] Hardware name: Allwinner sun8i Family
Aug 17 19:10:39 localhost kernel: [ 1666.195117] [<c010db15>] (unwind_backtrace) from [<c010a0d9>] (show_stack+0x11/0x14)
Aug 17 19:10:39 localhost kernel: [ 1666.195128] [<c010a0d9>] (show_stack) from [<c0868f69>] (dump_stack+0x69/0x78)
Aug 17 19:10:39 localhost kernel: [ 1666.195139] [<c0868f69>] (dump_stack) from [<c011a233>] (__warn+0xaf/0xc0)
Aug 17 19:10:39 localhost kernel: [ 1666.195148] [<c011a233>] (__warn) from [<c011a2f5>] (warn_slowpath_null+0x19/0x1c)
Aug 17 19:10:39 localhost kernel: [ 1666.195156] [<c011a2f5>] (warn_slowpath_null) from [<c0565759>] (copy_page_to_iter+0x21d/0x35c)
Aug 17 19:10:39 localhost kernel: [ 1666.195170] [<c0565759>] (copy_page_to_iter) from [<c01d8543>] (generic_file_read_iter+0x303/0x740)
Aug 17 19:10:39 localhost kernel: [ 1666.195183] [<c01d8543>] (generic_file_read_iter) from [<c024e2ab>] (generic_file_splice_read+0x83/0xd8)
Aug 17 19:10:39 localhost kernel: [ 1666.195193] [<c024e2ab>] (generic_file_splice_read) from [<c024e68d>] (splice_direct_to_actor+0x89/0x17c)
Aug 17 19:10:39 localhost kernel: [ 1666.195203] [<c024e68d>] (splice_direct_to_actor) from [<c03271e9>] (nfsd_splice_read+0x59/0x74)
Aug 17 19:10:39 localhost kernel: [ 1666.195212] [<c03271e9>] (nfsd_splice_read) from [<c0327671>] (nfsd_read+0x22d/0x234)
Aug 17 19:10:39 localhost kernel: [ 1666.195222] [<c0327671>] (nfsd_read) from [<c0325825>] (nfsd_proc_read+0x81/0xe8)
Aug 17 19:10:39 localhost kernel: [ 1666.195231] [<c0325825>] (nfsd_proc_read) from [<c032424b>] (nfsd_dispatch+0x83/0x114)
Aug 17 19:10:39 localhost kernel: [ 1666.195243] [<c032424b>] (nfsd_dispatch) from [<c084f66b>] (svc_process_common+0x29f/0x440)
Aug 17 19:10:39 localhost kernel: [ 1666.195252] [<c084f66b>] (svc_process_common) from [<c084f8df>] (svc_process+0xd3/0x138)
Aug 17 19:10:39 localhost kernel: [ 1666.195259] [<c084f8df>] (svc_process) from [<c0323e55>] (nfsd+0xad/0xfc)
Aug 17 19:10:39 localhost kernel: [ 1666.195271] [<c0323e55>] (nfsd) from [<c0131a91>] (kthread+0xfd/0x104)
Aug 17 19:10:39 localhost kernel: [ 1666.195282] [<c0131a91>] (kthread) from [<c0106719>] (ret_from_fork+0x11/0x38)
Aug 17 19:10:39 localhost kernel: [ 1666.195286] ---[ end trace 8b890c497145bf7b ]---

 

Share this post


Link to post
Share on other sites

Orange Pi Plus 2E

Linux orangepiplus2e 4.14.18-sunxi #24 SMP Fri Feb 9 16:24:32 CET 2018 armv7l GNU/Linux

I didn't try any recommendation. Could you send me link?

EDIT.

Today morning I try to log in Armbian via Putty and I can't. When I insert password, terminal do nothing. I can't log in via SSH and probably here is fault. Could someone help me?

Share this post


Link to post
Share on other sites
8 minutes ago, Fazik83 said:

You didn't help me

 

I did. Googlefu consulting is not part of this help. If you are unable to use a search engine or invest your own 10 minutes to browse for results, there is nothing more I am willing to do for you. One more hint: A10, A20 and H3 uses the same kernel and might share some problems.

Share this post


Link to post
Share on other sites

I didn't know.

I spend a lot of time to configure my Armbian and I know google and You didn't have to teach me in this topic.

And I fresh Armbian freeze after 1-2 hours, then... something wrong in image. Why image is still on upload? If is fix, why fix is not pinned? Att Debian_stretch_next.7z dated 27.01.2018.

 

Share this post


Link to post
Share on other sites
14 minutes ago, Fazik83 said:

And I fresh Armbian freeze after 1-2 hours

 


If this happens only to you, this is your problem. Since I saw some others complaining about similar issues it is possible that the problem is not yours. If you are not able to find them on a forum and attach your complains there, the problem is still only yours and thus not worth any attention. 
 

I am also frustrated that I need to point out/teach you things which should be obvious.

Spent 10 minutes on search. You will be amazed at what can be found.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
0