Jump to content

SOLVED - How to disable armbian-ram-logging correctly?


gas_85
 Share

Recommended Posts

14 hours ago, AlexP said:

I can't provide an ouput when it fails to start as the issue happens during device boot, and it's not responsive until I do a power reset.

Then could you attach here your /var/log/syslog file after a fail / reboot and (very important) indicate at what hour the problem occurred ? Somehow this file is preserved between reboots.

Link to comment
Share on other sites

Search Before Posting!

Thanks for suggestion, Dysmas.

Now it hang w/o reboot... or rebooted and hang during load. (when looking via HDMI - it prompted to enter root user, but cursor was not blinking and I was not able to SSH to the system).

The file is attached.

The issue happened somwhere before Oct  9 1:38-39. At 1:40 I've already physically rebooted the device. 

syslog

Link to comment
Share on other sites

This shows that at this stage everything is OK. I found nothing useful in the attached file. It is very strange that there are so few log lines at the moment of the problem. But if the log system is responsible, it may be understandable.

At this stage, unfortunately, I have no idea but the first one : Try to follow the steps of the first messages in this topic  to disable armbian-ramlog. If the problem persists, at least you know this is not the source.

Computers are sometimes frustrating.

 

Link to comment
Share on other sites

I've set ENABLED=false in /etc/default/armbian-ramlog - still it has the issue.

Seems like I'm near to re-install my system in the weekend.

P.S. That statement that I've said that system still shows info via HDMI - is wrong. It's actually stale and displays latest "picture" that it had before hang(if I leave HDMI connected) or no signal (if I connect HDMI after it hangs).

 

UPDATE:

So, I've took a look at syslog once again and I believe it's still an issue with moving log files.

Seems like here is more familiar issue for my case:

https://askubuntu.com/questions/1034012/ubuntu-locks-up-at-started-clean-php-session-files

In my case it's:

Oct 10 21:48:20 localhost kernel: [    0.000000] Booting Linux on physical CPU 0x0000000000 [0x410fd034]

and then system reboots... (but at 21:48 I even wasn't at home).

 

 

I re-call I've had an issue after upgrade where lighttpd was not starting after upgrade, as it haven't created a folder in var/log, so I had to manually create it and then my pihole started(and lighttpd as well). However, not sure that re-install of the system would help it...The only option I see is to re-install and not upgrade.

syslog

Link to comment
Share on other sites

11 hours ago, AlexP said:

I've set ENABLED=false in /etc/default/armbian-ramlog - still it has the issue.

In the second message of this thread, the author recommends to disable also ramlog in cron.d and cron.daily.

But you are right to think the problem may be elsewhere. There is no obvious reason for the reboots in the log file.

Maybe you could let your Pi run with htop on screen, and see if something happens with the memory.

Otherwise reinstalling may be the good solution.

Link to comment
Share on other sites

This is really ridiculous.

I've made all the recommendations from the 2nd message - it still hung. So I've re-installed the system (was Bionic, now Buster).  And it still deadly hangs.

In addition to this Buster version queries ntp servers really often 3K queries per day (x4) to 0/1/2/3.debian.pool.ntp.org.

But when I query timedatectl service, it says that ntp service is inactive...

Have no ideas where it stems from: corrupted distributive, buggy SD card(despite it's a Sony UHS-I card),  bad microcomputer.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...