Jump to content
  • 0

u-boot network trouble


hhoeth
 Share

Question

EDIT: This seems to be a problem with the OS running on the Mikrotik router. See this thread for a work-around that "shouldn't make a difference".

 

Hi!

 

I've got some trouble with u-boot on an Orange Pi PC+ connecting to a Mikrotik router RB922UAGS-5HPacD, and I'm not sure where I should start digging. Here is what I have so far:

 

  • Orange Pi PC+ with u-boot 2017.11-armbian installed on eMMC by running nand-sata-install. But instead of booting from eMMC, I'd like to fetch the kernel via tftp, so I modified the bootcmd accordingly. The relevant configuration / commands are:

     
    
      setenv ipaddr 192.168.3.74
      setenv serverip 192.168.3.73
      tftpboot 0x44000000 some_file.scr
    
    


     
  • The Mikrotik RB922UAGS-5HPacD shall be the tftp server. The relevant configuration is:

     
    
      /ip address add address=192.168.3.73/24 interface=ether1
      /interface ethernet set [ find default-name=ether1 ] disabled=no
      /ip tftp add ip-addresses=192.168.3.0/24 allow-rollover=yes req-filename=some_file.scr real-filename=some_file.scr read-only=yes
    
    

     


If I connect Orange Pi and RB922 with a straight ethernet cable, I can see the link coming up on the RB922 (100M-half), but u-boot can't ping the RB922 and tftp times out.

If I put a switch between the Orange Pi and the RB922, everything works fine.

If I use a different Mikrotik device (CRS125-24G-1S, a 24-port gbit-switch/router) and connect the Orange Pi directly to it, everything works fine, too. Note that in this case the configuration of the CRS125 is not exactly the same as on the RB922, because the CRS125 has more than one port and the ports are configured as a bridge:


  /interface bridge add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no fast-forward=no name=bridge-lan
  /interface bridge port add bridge=bridge-lan interface=ether2
  /interface bridge port add bridge=bridge-lan interface=ether3
  /interface bridge port add bridge=bridge-lan interface=ether4   etc.
  /ip address add address=192.168.3.1/24 interface=bridge-lan network=192.168.3.0
  /ip tftp add ip-addresses=192.168.3.0/24 allow-rollover=yes req-filename=some_file.scr real-filename=some_file.scr read-only=yes
  # (yes, I changed "serverip" in u-boot for this test)


Once the Linux kernel is up and running, the straight connection between Orange Pi and RB922 works fine (100M-full). It's just u-boot, and only with a direct connection to the RB922.

Any clues what I should have a closer look at?

 

Thanks a lot,

   Hendrik

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...