0
guidol

problem updating my build-system

Recommended Posts

for compiling Next LTS 4.19.y images  

I did try to update my build-system, but I do get errors on 2 packages which I cant resolve :(

Does anyone had this problem and could tell me how to solve this?

Or would it be more easy to reinstall the build-system?

 

The following packages will be upgraded:
  libc6-armhf-cross libc6-dev-armhf-cross
2 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
Need to get 2,904 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libc6-dev-armhf-cross all 2.27-3ubuntu1cross1.1 [1,899 kB]
Get:2 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libc6-armhf-cross all 2.27-3ubuntu1cross1.1 [1,005 kB]
Fetched 2,904 kB in 4s (762 kB/s)
(Reading database ... 106803 files and directories currently installed.)

 

Preparing to unpack .../libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb ...

Unpacking libc6-dev-armhf-cross (2.27-3ubuntu1cross1.1) over (2.27-3ubuntu1cross1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabihf/lib/Mcrt1.o.dpkg-new': No such file or directory

 

Preparing to unpack .../libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-armhf-cross (2.27-3ubuntu1cross1.1) over (2.27-3ubuntu1cross1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabihf/lib/ld-2.27.so.dpkg-new': No such file or directory

 

Errors were encountered while processing:
 /var/cache/apt/archives/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
 /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

root@armbian-build:~# uname -a
Linux armbian-build 4.15.0-39-generic #42-Ubuntu SMP Tue Oct 23 15:48:01 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
(bionic)

Share this post


Link to post
Share on other sites

OK - here the solution I did found at 

https://askubuntu.com/questions/1079797/how-do-i-fix-an-error-with-libc6-dev-armhf-cross-in-ubuntu-18-04-when-trying-to

 

To prevent too many dependencies from being removed, try dpkg -P --force-depends

sudo dpkg -P --force-depends libc6-armhf-cross libc6-dev-armhf-cross
sudo apt clean
sudo apt update
apt --fix-broken install OR sudo apt -f install
apt install libc6-armhf-cross libc6-dev-armhf-cross

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0