0
Carsten

BPI M2+ no wifi channel 13

Recommended Posts

Hi,

 

my Banana Pi M2+ with Armbian Bionic doesn't see my access point on channel 13. I already set "REGDOMAIN=DE" in /etc/default/crda and also issued the command "iw reg set DE".  

 

"nmcli dev wifi list" shows a lot of other access points on channels 1, 6, 11, but not my own on channel 13.

 

On the other hand, "iw list" shows:

                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)
 

So the problem might be the Broadcom chip firmware. I found some replacement files here:

http://jwrdegoede.danny.cz/brcm-firmware/ 

 

Some of them get loaded:

root@bananapim2plus:~# dmesg | grep brcmfmac
[    5.166843] brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43430-sdio.bin for chip 0x00a9a6(43430) rev 0x000001
[    5.316277] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f

 

But no success. Please help!

 

Carsten  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0