0
hello_flowers

pxeboot initramfs issue

Recommended Posts

Hello everyone,

My hardware is Orange Pi PC2.
I'm netbooting with latest armbian kernel compiled from src:

root@hello-PC:/home/hello/armbian# cat /var/lib/tftpboot/pxelinux.cfg/default
default menu.c32
prompt 1

menu title Boot Menu
   Label Armbian
       menu label Manual load Armbian
       kernel armbian/vmlinuz-4.19.20-sunxi64
       fdt armbian/sun50i-h5-orangepi-pc2.dtb
       append initrd=armbian/uInitrd netboot=nfs nfsroot=192.168.100.1:/var/nfs debug=y

Everything is loaded and mounted, but I can't see any echoes from init script (initramfs).
Even after I added:

root@hello-PC:/home/hello/armbian/init# diff init ../init_bak
30,31d29
< mknod -m 600 /dev/console c 5 1
< mknod -m 600 /dev/tty c 5 0


i can only see the kernel messages during boot process but not able to see the output of init script.
I tried to do the same with images downloaded from armbian.com, it doesn't work.
Can anybody help me?

Share this post


Link to post
Share on other sites
3 hours ago, hello_flowers said:

Can anybody help me?

armbianmonitor -u   tells the reader all the details about your Installation, like Kernel-Version and much more

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0