0
spqr

Espressobin MAC in u-boot?

Recommended Posts

I've installed the latest u-boot for the boards I'm working with (I have a v5 and a v7) and while I have been able to figure out how to set the MAC in linux, I would like to set the WAN MAC at the uboot level if possible.

The u-boot environment variables seem to have no affect. I've flashed two boards and they both come up with the same MAC in Armbian f0:ad:4e:03:64:7f

Can this somehow be altered before flashing the new u-boot?

Share this post


Link to post
Share on other sites

I've tried every variation of boot arguments in u-boot and no luck changing from that default MAC.

Any help appreciated...

 

This is the version of u-boot I'm using

U-Boot 2018.03-devel-18.12.3-gc9aa92c-armbian (Feb 20 2019 - 09:45:04 +0100)

Share this post


Link to post
Share on other sites

Eureka! Just found the location of the mysterious MAC! Changed it and it worked!!!

The address used was the default in /boot/boot.cmd

It looks like u-boot environment is ignored...

 

You can override the default in the armbianEnv.txt file as instructed at the top of the boot.cmd file.

 

added and ethaddr= line and it worked!

eth1addr etc. do not seem to get picked up...

 

This all may have been obvious to people more familiar with armbian... sorry, I'm just learning my way around it.

Share this post


Link to post
Share on other sites

I also confirmed that settings for eth1addr eth2addr eth3addr have no effect .  lan0 and lan1 must be set in interfaces.d files to give them unique MACs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0