hjoe

  • Content Count

    12
  • Joined

  • Last visited

Reputation Activity

  1. Like
    hjoe got a reaction from Matt Alencar in PLT section(s) missing using out-of-tree module on Armbian 20.11.6 Buster orangepizero   
    Hi, have the same problem with compiling the can4linux driver.
    Why does someone suggest to remove the last line of the linker script module.lds ?
      sudo sh -c "sed '$ d' 
     
    it should include something for sure, may be the .plt section.
    #include does not work, so I added the content of  ./linux-headers-5.10.4-sunxi/arch/arm/include/asm/module.lds.h
     

    now I can load the module, but is may be not correct
  2. Like
    hjoe got a reaction from surenz in PLT section(s) missing using out-of-tree module on Armbian 20.11.6 Buster orangepizero   
    Hi, have the same problem with compiling the can4linux driver.
    Why does someone suggest to remove the last line of the linker script module.lds ?
      sudo sh -c "sed '$ d' 
     
    it should include something for sure, may be the .plt section.
    #include does not work, so I added the content of  ./linux-headers-5.10.4-sunxi/arch/arm/include/asm/module.lds.h
     

    now I can load the module, but is may be not correct
  3. Like
    hjoe got a reaction from Igor in SATA not working   
    I read on the forum:
    "Update boot loader to latest version - armbian-config -> system -> install/update boot loader ... and try again." and I did.
    I also removed power, reconnected the cables, and now the result is different: I have now the device /dev/sda available.
    Hopefully, all is good now.  
     
  4. Like
    hjoe got a reaction from guidol in Updated armbian-config v5.81   
    only added the second last printf, and of course the variable initialisation