Sergio

Members
  • Content Count

    12
  • Joined

  • Last visited


Reputation Activity

  1. Like
    Sergio reacted to Igor in SSH not working after upgrade (Orange pi Lite Armbian_Ubuntu_xenial)   
    Changes were applied also to the stable repository. No need to switch anywhere. I guess all mirrors have also been updated by now.
  2. Like
    Sergio reacted to Igor in SSH not working after upgrade (Orange pi Lite Armbian_Ubuntu_xenial)   
    Patch is applied and it seems to work, updates pushed up:
    https://github.com/armbian/documentation/commit/417821896fedd9623bfc6d7dac13cc5392729c80
    https://github.com/armbian/upload/commit/3ea43843df0ccfa7e749b41cffa27f38c3ba53e8

    ... but it seems not all problems went away. I am experiencing network troubles. 
    Lan cable was not connected to the switch 
  3. Like
    Sergio reacted to ning in SSH not working after upgrade (Orange pi Lite Armbian_Ubuntu_xenial)   
    this is only happens on legacy kernel, due to kernel is too old and has bug.
  4. Like
    Sergio got a reaction from thexman in SSH not working after upgrade (Orange pi Lite Armbian_Ubuntu_xenial)   
    Ok, thank you.  I'll try.
    This is the first such case in my practice. On raspberry this has never happened before.
  5. Like
    Sergio reacted to thexman in SSH not working after upgrade (Orange pi Lite Armbian_Ubuntu_xenial)   
    @Sergio
    You don't inevitably need to switch to Stretch to avoid the issue. Simply switching to mainline on Xenial will also work. As already said legacy kernel features will not work anymore but that would be the same for any mainline. Switching can be done through the armbian configuration tool.
  6. Like
    Sergio reacted to olivluca in SSH not working after upgrade (Orange pi Lite Armbian_Ubuntu_xenial)   
    Just found this thread that explains the problem and the possible solutions
  7. Like
    Sergio reacted to Sann-X! in SSH doesn't work on Orange Pi Zero   
    Workaround for ssh issue (create one shot service/daemon to make proper sshd dir):
    0. Log in under root
    1. Create file:
    touch /etc/systemd/system/create-ssh-dir.service
     
    2. Grant access:
    chmod 664 /etc/systemd/system/create-ssh-dir.service

    3. Edit content file:
    [Unit] Description=Creates sshd directory Before=ssh.service [Service] Type = oneshot ExecStart=mkdir -p /var/run/sshd [Install] WantedBy=multi-user.target 4. Enable service:
    systemctl enable create-ssh-dir.service
     
    5. Reboot