Jump to content

royk

Members
  • Posts

    209
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @lanefu Armbian DDR_BLOB='rk35/rk3588_ddr_lp4_2112MHz_lp5_2736MHz_v1.15.bin' BL31_BLOB='rk35/rk3588_bl31_v1.44.elf' Joshua Riek u-boot-rockchip_platforms += orangepi_5 orangepi_5_ddr := rk3588_ddr_lp4_2112MHz_lp5_2736MHz_v1.11.bin orangepi_5_bl31 := rk3588_bl31_v1.38.elf orangepi_5_pkg := orangepi-5 Xunlong Orange Pi if [[ ${BOARDFAMILY} == "rockchip-rk3588" ]]; then local rkbin_url="https://github.com/orangepi-xunlong/rk-rootfs-build/raw/rkbin/rk35" wget -qnc -P ${EXTER}/cache/sources/rkbin-tools/rk35/ ${rkbin_url}/rk3588_ddr_lp4_2112MHz_lp5_2736MHz_v1.15.bin wget -qnc -P ${EXTER}/cache/sources/rkbin-tools/rk35/ ${rkbin_url}/rk3588_bl31_v1.44.elf @Victor Pecherskiy So to rule out that the newer DDR blob is the problem you could try an Orange Pi image.
  2. @Victor Pecherskiy Then it seems like a software problem, unfortunately I don't have a 32GB to test it with. And what if you copy the dtb from Joshua Riek's image to your Armbian installation? This is a difference I found but not sure if it's possible to be the cause: https://github.com/Joshua-Riek/linux-rockchip/commit/fdf8d484eccb0949664b78b16e0a275e75c52e0d
  3. @Victor Pecherskiy To rule out if it's a hardware or software problem have you tried an "original" image from orange pi?
  4. @VanGeldon You could add the apt sources in my previous post in the 5.10.160 image. With the linux 6.1.43 image I've got Kodi working, but had to change some things, see here You can try if it works with the kernel build from the source of Joshua Riek's repo: https://drive.google.com/drive/folders/17NT-h0FWKA9irXPBUN883xVoPWganMu-?usp=sharing
  5. @VanGeldon Seems like an old image, try one from here: https://imola.armbian.com/dl/orangepi5/archive/ When you choose an image with amazingfated and Wayland like Gnome or KDE you probably only need to install Kodi. By the way when I search the package with apt search, this is the result: libgjs0g/jammy-updates 1.72.2-0ubuntu2 arm64 So or it's corrected or you've got other sources in /etc/apt/sources.list deb http://ports.ubuntu.com/ jammy main restricted universe multiverse # deb-src http://ports.ubuntu.com/ jammy main restricted universe multiverse deb http://ports.ubuntu.com/ jammy-security main restricted universe multiverse # deb-src http://ports.ubuntu.com/ jammy-security main restricted universe multiverse deb http://ports.ubuntu.com/ jammy-updates main restricted universe multiverse # deb-src http://ports.ubuntu.com/ jammy-updates main restricted universe multiverse deb http://ports.ubuntu.com/ jammy-backports main restricted universe multiverse # deb-src http://ports.ubuntu.com/ jammy-backports main restricted universe multiverse
  6. @Markus Braun In armbianEnv.txt remove the line "overlays=ssd-sata" A ftdi adapter doesn't cost the world and it saves you from a lot of hassle.
  7. @Markus Braun It might be a good idea to check the serial console to see what's going wrong, keep in mind that you need a ftdi adapter that can handle a high baudrate. Things you could check: Did you disable the sata overlay? Did you check if all the files are in the /boot folder of the nvme? Checked if the correct UUID is in /boot/armbianENV.txt and /etc/fstab Removed the SD-card at the first boot from NVME?
  8. @Markus Braun To be sure you could make one ext4 partition. "4 Boot from Flash..." is the right one indeed, after that it should ask to install/update the bootloader which you can agree and otherwise you can choose 7 install/update bootloader indeed. And by the way, the reason why it didn't work in the first place was probably because you forgot to edit /etc/fstab
  9. You should use "sudo armbian-install" to install from the sd-card to the nvme. It should copy the boot partition to the /boot folder, so only one partition. After installing to the NVME you should also write the bootloader to the MTD. If it still doesn't work check if the M.2 storage isn't SATA, otherwise you should write the SATA bootloader. To do that you could use the Armbian instructions from: https://www.reddit.com/r/OrangePI/comments/10iq625/guide_how_to_boot_orange_pi_5_from_sata_m2_ssd/
  10. @mamasaur1 It might be that it tries to read the layout of Orange Pi 5 instead of 5b, on the 5-plus I had to enter: echo "BOARD=orangepi5plus" | sudo tee /etc/orangepi-release So probably for yours it should be: echo "BOARD=orangepi5b" | sudo tee /etc/orangepi-release By the way, it's not a good idea to connect a 2-pins fan directly to a gpio pin, too much current. Search for a pwm fan instead that's compatible for a raspberry pi.
  11. royk

    Bananapi M7

    If I win I would like to use it for my cnc machine (LinuxCNC) with the rt-kernel on Armbian. At this moment I'm using the Orange Pi 5 for it with a USB WiFi dongle. This board would be more convenient with the second Ethernet port because one port is in use for a connection with the FPGA board. The built-in WiFi is usable for making a hotspot. This model seems like a better choice for the environment because it can be placed in a robust itx case.
  12. @Dbosco I've no idea what the cause is that you can't build Kodi, but now I see that I also have a dtb overlay enabled. You can install it with: armbian-add-overlay vop.dts Otherwise you can try my build, but it's built without the cec lib: https://drive.google.com/drive/folders/1yYlioTYE4X2ItldgcnkgPobLQk1rT6Wb?usp=sharing vop.dts
  13. @Dbosco (Assuming you set the settings in Kodi correct: settings->player->videos->render method Allow using DRM PRIME Decoder=enable Allow Hardware Acceleation with DRM PRIME=enable Prime Render Method=Direct to Plane) Perhaps something is wrong with your ffmpeg, mpp or rga. Try to follow the steps on: https://github.com/nyanmisaka/ffmpeg-rockchip/wiki/Compilation After that run the cmake command for kodi again before make and install.
  14. @Dbosco Build and install with at least GBM Paste the following in /usr/share/wayland-sessions/kodi-wayland.desktop [Desktop Entry] Name=Kodi Wayland Comment=This session will start Kodi media center Exec=env FFMPEG_RKMPP_DEC_OPT="afbc=on" kodi --windowing=gbm --audio-backend=alsa TryExec=kodi-standalone Type=Application Keywords=audio;video;media;center;tv;movies;series;songs;remote; Icon=kodi Otherwise try to stop the window manager and start it manually to see if it gives an error, from login window press: ctrl+alt+F2 -> sudo systemctl stop gdm3 -> env FFMPEG_RKMPP_DEC_OPT="afbc=on" kodi --windowing=gbm --audio-backend=alsa
×
×
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines