Kevin

  • Content Count

    11
  • Joined

  • Last visited

Reputation Activity

  1. Like
    Kevin got a reaction from pelitt in Orange Pi Lite doesn't connect to WiFi networks   
    This is my final solution to this issue.   I hope it works consistently for everyone.
     
    This applies to Armbian Jessie 5.15 Desktop.  No idea at this point about other versions.
     
    After many trials, I find that wicd is broken.  Some confirmation can be found here: http://forum.armbian.com/index.php/topic/1775-wicd-gets-erroneous-bad-password/?p=14708
     
    So abandoning wicd, I uncheck all "Automatcially connect to this network".
     
    I turned to this post as a guide: http://askubuntu.com/questions/406166/how-can-i-configure-my-headless-server-to-connect-to-a-wireless-network-automati/406167#406167to use /etc/network/interfaces to do my connecting instead of wicd doing the connecting.
     
    /etc/wpa_supplicant.conf
    ap_scan=1 ctrl_interface=/var/run/wpa_supplicant network={ ssid="xxxxxx" scan_ssid=1 psk="yyyyyyy" } added to /etc/network/interfaces
    auto wlan0 iface wlan0 inet dhcp pre-up sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dnl80211 post-down sudo killall -q wpa_supplicant [The following may not apply to everyone.  It might have been needed in my case because I began experimenting by plugging in a wifi dongle when I was having trouble with the built in wifi.  But if you have issues described below, it may help]
     
    I was able to connect to my wifi ONCE, after rebooting it would not connect.  I couldn't see why, until I did an ifconfig -a, and I saw that instead of wlan0, it was wlan1...  I then just changed things to wlan1, and it worked ONCE.   So why is it changing?
     
    It came down to the contents of /etc/udev/rules.d/70-persistent-net.rules, which records the mac address of the wlan interface and assigns device ids accordingly.
     
    According to this post: http://forum.armbian.com/index.php/topic/1738-opi-lite-mac-address/the realtek driver generates a random mac address under certain conditions. 
    The contents of /etc/modeprobe.d/8189fs.conf in my setup had a mac address in it that would indeed cause a new random mac to be generated.
     
    So I changed it to one of the random macs that it generated.   I'd suggest that you use 00:e0:4c:xx:yy:zz where you randomly make up 3 hex bytes for xx:yy:zz  However if you don't come to my house, nor have multiple orange pi's on your network, you can just copy the line.
     
    /etc/modeprobe.d/8189fs.conf
    options 8189fs rtw_initmac=00:e0:4c:88:b2:2c I then removed all the wlan* entries from /etc/udev/rules.d/70-persistent-net.rules
     
    That last step may not be needed if you've never plugged in any wifi dongles to the usb port.
     
     
    I'm just happy it works now, and is consistent.
     
    I'm convinced that my previous attempts at various command line and network script fixes found here and elsewhere where hindered by wicd running and trying to connect (since I had "Automatically Connect" set).  Once I determined that wicd was in the way, I was able to get things working.
     
    /K
  2. Like
    Kevin got a reaction from WarHawk_AVG in Orange Pi Lite doesn't connect to WiFi networks   
    This is my final solution to this issue.   I hope it works consistently for everyone.
     
    This applies to Armbian Jessie 5.15 Desktop.  No idea at this point about other versions.
     
    After many trials, I find that wicd is broken.  Some confirmation can be found here: http://forum.armbian.com/index.php/topic/1775-wicd-gets-erroneous-bad-password/?p=14708
     
    So abandoning wicd, I uncheck all "Automatcially connect to this network".
     
    I turned to this post as a guide: http://askubuntu.com/questions/406166/how-can-i-configure-my-headless-server-to-connect-to-a-wireless-network-automati/406167#406167to use /etc/network/interfaces to do my connecting instead of wicd doing the connecting.
     
    /etc/wpa_supplicant.conf
    ap_scan=1 ctrl_interface=/var/run/wpa_supplicant network={ ssid="xxxxxx" scan_ssid=1 psk="yyyyyyy" } added to /etc/network/interfaces
    auto wlan0 iface wlan0 inet dhcp pre-up sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dnl80211 post-down sudo killall -q wpa_supplicant [The following may not apply to everyone.  It might have been needed in my case because I began experimenting by plugging in a wifi dongle when I was having trouble with the built in wifi.  But if you have issues described below, it may help]
     
    I was able to connect to my wifi ONCE, after rebooting it would not connect.  I couldn't see why, until I did an ifconfig -a, and I saw that instead of wlan0, it was wlan1...  I then just changed things to wlan1, and it worked ONCE.   So why is it changing?
     
    It came down to the contents of /etc/udev/rules.d/70-persistent-net.rules, which records the mac address of the wlan interface and assigns device ids accordingly.
     
    According to this post: http://forum.armbian.com/index.php/topic/1738-opi-lite-mac-address/the realtek driver generates a random mac address under certain conditions. 
    The contents of /etc/modeprobe.d/8189fs.conf in my setup had a mac address in it that would indeed cause a new random mac to be generated.
     
    So I changed it to one of the random macs that it generated.   I'd suggest that you use 00:e0:4c:xx:yy:zz where you randomly make up 3 hex bytes for xx:yy:zz  However if you don't come to my house, nor have multiple orange pi's on your network, you can just copy the line.
     
    /etc/modeprobe.d/8189fs.conf
    options 8189fs rtw_initmac=00:e0:4c:88:b2:2c I then removed all the wlan* entries from /etc/udev/rules.d/70-persistent-net.rules
     
    That last step may not be needed if you've never plugged in any wifi dongles to the usb port.
     
     
    I'm just happy it works now, and is consistent.
     
    I'm convinced that my previous attempts at various command line and network script fixes found here and elsewhere where hindered by wicd running and trying to connect (since I had "Automatically Connect" set).  Once I determined that wicd was in the way, I was able to get things working.
     
    /K
  3. Like
    Kevin got a reaction from gnasch in Orange Pi Lite doesn't connect to WiFi networks   
    This is my final solution to this issue.   I hope it works consistently for everyone.
     
    This applies to Armbian Jessie 5.15 Desktop.  No idea at this point about other versions.
     
    After many trials, I find that wicd is broken.  Some confirmation can be found here: http://forum.armbian.com/index.php/topic/1775-wicd-gets-erroneous-bad-password/?p=14708
     
    So abandoning wicd, I uncheck all "Automatcially connect to this network".
     
    I turned to this post as a guide: http://askubuntu.com/questions/406166/how-can-i-configure-my-headless-server-to-connect-to-a-wireless-network-automati/406167#406167to use /etc/network/interfaces to do my connecting instead of wicd doing the connecting.
     
    /etc/wpa_supplicant.conf
    ap_scan=1 ctrl_interface=/var/run/wpa_supplicant network={ ssid="xxxxxx" scan_ssid=1 psk="yyyyyyy" } added to /etc/network/interfaces
    auto wlan0 iface wlan0 inet dhcp pre-up sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dnl80211 post-down sudo killall -q wpa_supplicant [The following may not apply to everyone.  It might have been needed in my case because I began experimenting by plugging in a wifi dongle when I was having trouble with the built in wifi.  But if you have issues described below, it may help]
     
    I was able to connect to my wifi ONCE, after rebooting it would not connect.  I couldn't see why, until I did an ifconfig -a, and I saw that instead of wlan0, it was wlan1...  I then just changed things to wlan1, and it worked ONCE.   So why is it changing?
     
    It came down to the contents of /etc/udev/rules.d/70-persistent-net.rules, which records the mac address of the wlan interface and assigns device ids accordingly.
     
    According to this post: http://forum.armbian.com/index.php/topic/1738-opi-lite-mac-address/the realtek driver generates a random mac address under certain conditions. 
    The contents of /etc/modeprobe.d/8189fs.conf in my setup had a mac address in it that would indeed cause a new random mac to be generated.
     
    So I changed it to one of the random macs that it generated.   I'd suggest that you use 00:e0:4c:xx:yy:zz where you randomly make up 3 hex bytes for xx:yy:zz  However if you don't come to my house, nor have multiple orange pi's on your network, you can just copy the line.
     
    /etc/modeprobe.d/8189fs.conf
    options 8189fs rtw_initmac=00:e0:4c:88:b2:2c I then removed all the wlan* entries from /etc/udev/rules.d/70-persistent-net.rules
     
    That last step may not be needed if you've never plugged in any wifi dongles to the usb port.
     
     
    I'm just happy it works now, and is consistent.
     
    I'm convinced that my previous attempts at various command line and network script fixes found here and elsewhere where hindered by wicd running and trying to connect (since I had "Automatically Connect" set).  Once I determined that wicd was in the way, I was able to get things working.
     
    /K