serkam

Members
  • Content Count

    9
  • Joined

  • Last visited


Reputation Activity

  1. Like
    serkam got a reaction from rlsten in How to set static IP in eth0 and wlan0 in OPi Zero   
    Hi tkaiser and martinayotte.
     
    The real problem I was facing was due incorrect static IP address. I was trying to use 192.168.1.100 without /24. Doing this, nmtui automatically places /32 and the IP MASK is set to 255.255.255.255 and broadcast IP to 192.168.1.100 ( the same IP of my device).
     
    Setting IP to 192.168.1.100/24, all the rest is adjusted correctly ( 255.255.255.0 and 192.168.1.255 ).
     
    I did the same for wlan0 ( 192.168.1.99/24 ) and now both (eth0, wlan0) are working fine.
     
    I did a test using Visual Studio with linux plugin that use SSH to communicate with OPi Zero at eth0 and all worked fine. 
     
    As I intend to use wlan0 as AP to control a MQTT's network of IoTs devices, I wonder that the routing issue will be solved too.
     
    Thank you all people. Your support are great!
     
    Sergio
  2. Like
    serkam got a reaction from manuti in How to set static IP in eth0 and wlan0 in OPi Zero   
    Hi tkaiser and martinayotte.
     
    The real problem I was facing was due incorrect static IP address. I was trying to use 192.168.1.100 without /24. Doing this, nmtui automatically places /32 and the IP MASK is set to 255.255.255.255 and broadcast IP to 192.168.1.100 ( the same IP of my device).
     
    Setting IP to 192.168.1.100/24, all the rest is adjusted correctly ( 255.255.255.0 and 192.168.1.255 ).
     
    I did the same for wlan0 ( 192.168.1.99/24 ) and now both (eth0, wlan0) are working fine.
     
    I did a test using Visual Studio with linux plugin that use SSH to communicate with OPi Zero at eth0 and all worked fine. 
     
    As I intend to use wlan0 as AP to control a MQTT's network of IoTs devices, I wonder that the routing issue will be solved too.
     
    Thank you all people. Your support are great!
     
    Sergio
  3. Like
    serkam reacted to tkaiser in How to set static IP in eth0 and wlan0 in OPi Zero   
    Great that you were able to resolve the issue and especially that you shared solution/knowledge!
     
    Please don't expect too much from legacy kernel here. This is an ancient 3.4 kernel from Allwinner that is known to have several networking issues. Also please be aware that problems on layer 3 (routing) might not even exist when the problem is solved at the appropriate layer (that would be 2 --> bridging). I did some tests with 3.4.113 and bridging that went well but in case you're running in problems it would be worth a try to test out the nightly builds with dev kernel to know whether the problem is solveable with mainline kernel (then it's just having some patience since OS images based on mainline kernel receive no end user support ATM)
  4. Like
    serkam reacted to martinayotte in How to set static IP in eth0 and wlan0 in OPi Zero   
    Right ! ... or STA but on a different network to avoid routing isues ...
  5. Like
    serkam reacted to tkaiser in How to set static IP in eth0 and wlan0 in OPi Zero   
    I was referring to a problem occuring when you connect two or more network interfaces on any H3/H2+ device with legacy kernel to the same network: https://forum.armbian.com/index.php/topic/2907-opi-zero-incoming-ssh-cant-connect/page-2 (read at the end of this thread).
     
    Just try to avoid that for your tests since it requires some networking skills to workaround the problem. So if you choose 192.168.1.0/24 for Ethernet and 192.168.2.0/24 for Wi-Fi this will work but not both interfaces in the same 'network range'.
  6. Like
    serkam reacted to tkaiser in How to set static IP in eth0 and wlan0 in OPi Zero   
    Different problem. You're using the smelly legacy kernel and try to use both NICs connected to the same network which is not working (MAC address / routing issue). Too tired to search for the thread now where everything is explained but rule of thumb: Don't do this, if you want to use both NICs they have to connect to different networks.
     
     
    So I can exchange the repo in sources.list to Jessie's and it works now mixing armhf Jessie packages with ARMv6 Raspbian packages? Of course it won't. RPi people are great telling fairy tales (the mythical RPi foundation so busy in charity that they don't need to pay taxes) and try hard to not confuse the average fanboi by always telling simple stories. That's why they call their releases 'Wheezy' or 'Jessie' since most of their stuff complies with original Debian releases.
     
    Anyway: It was about network settings and here things are different on Raspbian (see Sergio's example config, another example is Raspbian being more user-friendly and enabling ZeroConf by default starting with one of their latest releases they call 'Jessie' compared to vanilla Jessie where you don't get an 169.254.0.0/16 address when there's no DHCP server present in the broadcast domain connected to), on vanilla Jessie (even on armhf) and on Armbian (since Armbian tries to 'optimize' some settings). So the important rule is just: Forget about tutorials for Raspbian when it's about Armbian. Better look through documentation (still a lot missing but we lack contributors also in this area) or ask in the Forum first
  7. Like
    serkam reacted to jkajolin in How to set static IP in eth0 and wlan0 in OPi Zero   
    p.s) Raspbian is based on Debian Jessie. They just don't follow the normal debian development and manually merge the security patches (when ever feel like it, so not often).
    Therefore basic Debian guides will work unless we are talking something on lower level arm support etch.