bigheart

Members
  • Content Count

    6
  • Joined

  • Last visited

About bigheart

  • Rank
    Newbie

Profile Information

  • Location
    Hong Kong
  • Interests
    Computer Audio, Linux
  1. thanks! the default now set to the USB DAC now, but i found Mopidy not play to it...... trying to figure out why .... by the way, can i define card number of the USB DAC? as it will become 1 when plugged before boot, and 2 when it is plugged after the bootup. thanks! Joseph
  2. hello, i am setting up Mopidy in Orange Pi PC2 with armbian. but i found it only playback to the on-board sound card not the USB DAC i connected. root@orangepipc2:/# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Codec [H3 Audio Codec], device 0: CDC PCM Codec-0 [] Subdevices: 0/1 Subdevice #0: subdevice #0 card 1: allwinnerhdmi [allwinner,hdmi], device 0: 1c22800.i2s-i2s-hifi i2s-hifi-0 [] Subdevices: 1/1 Subdevice #0: subdevice #0 card 2: Audio [iFi (by AMR) HD USB Audio], device 0: USB Audio [USB Audio] Subdevices: 1/1 Subdevice #0: subdevice #0 i found there is no asound.conf in /etc ... i tried alsactl store 2, but Mopidy still playback in 0 in /etc/modprobe.d/ there is nothing related to sound card neither how can i set the default alsa device to card 2 ? thanks! Joseph
  3. Hi, i have a live system running (Armbian on Orange Pi PC2). i found the Serial OTG on the microUSB is not work. and i didn't modified the image in the SD as described above before first boot. so now i only need to create the symbolic link in /lib/systemd/system as shown above? i checked there is nothing in my /etc/modules and no ttyGS0 in my etc/securetty and no serial-getty@.service in /lib/systemd/system any help here? thanks! Joseph
  4. bigheart

    bigheart

  5. Hi, thanks your reply. it seems the g_serial is not loaded; root@orangepipc2:~# lsmod Module Size Used by rc_cec 16384 0 ir_lirc_codec 16384 0 snd_soc_hdmi_codec 16384 1 lirc_dev 20480 1 ir_lirc_codec dw_hdmi_i2s_audio 16384 0 dw_hdmi_cec 16384 0 snd_soc_simple_card 16384 0 sun8i_codec_analog 28672 1 snd_soc_simple_card_utils 16384 1 snd_soc_simple_card sun4i_codec 49152 3 sun4i_i2s 20480 2 snd_soc_core 155648 6 sun4i_i2s,sun8i_codec_analog,snd_soc_hdmi_codec,sun4i_codec,snd_soc_simple_card_utils,snd_soc_simple_card snd_pcm_dmaengine 16384 1 snd_soc_core sunxi_cir 16384 0 snd_pcm 106496 4 sun4i_i2s,snd_soc_hdmi_codec,snd_soc_core,snd_pcm_dmaengine sun8i_dw_hdmi 16384 0 snd_timer 32768 1 snd_pcm dw_hdmi 28672 2 dw_hdmi_i2s_audio,sun8i_dw_hdmi cec 53248 2 dw_hdmi_cec,dw_hdmi rc_core 32768 7 rc_cec,lirc_dev,ir_lirc_codec,sunxi_cir,cec sun4i_gpadc_iio 16384 0 sun8i_mixer 16384 0 sun4i_tcon 28672 1 sun8i_dw_hdmi iio_hwmon 16384 0 sun4i_drm 16384 0 industrialio 65536 2 sun4i_gpadc_iio,iio_hwmon zram 28672 5 sy8106a_regulator 16384 1 sunxi 20480 0 musb_hdrc 98304 1 sunxi i tried reboot the board with my USB connected to board microUSB OTG port, but still no g_serial loaded. how can i configure it to load g_serial?
  6. hello i just install the latest armbian on orange pi pc2 board, the kernal is already 4.14 therefore the OTG function should be there. root@orangepipc2:~# dmesg |grep musb [ 1.323924] musb-hdrc musb-hdrc.1.auto: MUSB HDRC host driver [ 1.323939] musb-hdrc musb-hdrc.1.auto: new USB bus registered, assigned bus number 9 [ 1.324416] usb usb9: Manufacturer: Linux 4.14.78-sunxi64 musb-hcd [ 1.324421] usb usb9: SerialNumber: musb-hdrc.1.auto however, i cannot enable the usb serial over OTG. anyone can show me how to do it? i tried it on debian and windows but both has nothing when i connect to the OTG port. thanks very much!
  7. Hello, i have the OMV image on my Helios4. i have it running overnight however, i found the serial console port is not work after. the system is still up and running, ssh and OMV web interference is still working. i have to reboot the Helios in order to bring the serial console back. anyone have the same problem? Joseph