Alex83

  • Content Count

    40
  • Joined

  • Last visited

Everything posted by Alex83

  1. Hi guys, i have been off for a while and restartet my Scishion V88 Mini 4K Project again. In these devices there is a rk3229 chipset with ssv6051p wireless. I installed already a while ago the legacy kernel into NAND-Flash. After using rk3229-config which is really nice nowadays, thanks again to @fabiobassa, I think everything is fine, but there are still two topics. When I use armbian-config there are networks around me when I try to use wifi and wifi already worked with former images. Then I try to connect and it asks for password. After entering the password there is nothing and
  2. Hi guys, I try to reinstall my tvheadend, but unfortunately it always tells me suddenly some depencies which I can't solve. libhdhomerun4 (>= 20200521) But it's installed and in Buster stable only available: libhdhomerun4:armhf (20180327-1) When i try to install it manuelly, then there is the next depency to libc-bin and so on... a never ending story. Actually tvheadend worked already quite well, but suddenly it stopped working. So I thought maybe it's the best idea to reinstall tvheadend. And now there is even bigger trouble.
  3. Hey guys, I stock with my device again. The wifi doesn't work as it seems and so I have no network connection anymore. If I connect it to the TV and plug a keyboard in I see there are pronlems with Failed to start Raise network interfaces. If I login and see the armbian-config I can still discover all networks around. When I try to connect it shows the error message Connection... Could not activate connection: Activation failed: The Wi-Fi network could not be found So unfortunately I can't copy now dmesg
  4. I would also love to know where we continue our very constructive discussions? I think the project shouldn't die because of a closing thread...
  5. @Igor: Hey Igor, I read you wanted to implement the bluetooth and wifi directly into the armbian-images for supported M2plus. How did this go on and what is the actual state at the moment? I use the newest image with kernel 5.8.x Armbian 20.08.13, but there is still no wifi or bluetooth found within armbian-config tool.
  6. Hi guys, I searched for an answer but couldn't find a working one. Most answers from 2017 and it's not possible to answer there. Could someone please explain how to use the wifi and bluetooth module on Armbian 20.08.7 Bionic with Linux 5.8.13-sunxi (minimal without desktop)? ____ ____ _ __ __ ____ | __ )| _ \(_) | \/ |___ \ _ | _ \| |_) | | | |\/| | __) || |_ | |_) | __/| | | | | |/ __/_ _| |____/|_| |_| |_| |_|_____||_| Welcome to Armbian 20.08.7 Bionic with Linux 5.8.13-sunxi System load: 2%
  7. That's exactly what also happens with my V88 Mini 4k Box. To say what's best you need to define what you wanna do. Rk3228 is much more powerful of it's hardware than rk3229 products. I Can't tell you what's the difference between rk3228a and rk3228b. I can tell you that I own a device Alfawise Z28 Pro which has 1000Mbit/s LAN and wifi ac with 5GHz and USB 3.0. Unfortunately not im use because im not sure if I can use the Z28 images from a similar box. Anyway I think rk3229 has no USB3. 0 and 1000Mbit/s ETH support and maybe also no wifi ac. B
  8. That's exactly what also happens with my V88 Mini 4k Box. To say what's best you need to define what you wanna do. Rk3328 is much more powerful of it's hardware than rk3229 products. I Can't tell you what's the difference between rk3328a and rk3328b. I can tell you that I own a device Alfawise Z28 Pro which has 1000Mbit/s LAN and wifi ac with 5GHz and USB 3.0. Unfortunately not im use because im not sure if I can use the Z28 images from a similar box. Anyway I think rk3229 has no USB3. 0 and 1000Mbit/s ETH support and maybe also no wifi ac. B
  9. That's exactly what also happens with my V88 Mini 4k Box. To say what's best you need to define what you wanna do. Rk3328 is much more powerful of it's hardware than rk3229 products. I Can't tell you what's the difference between rk3228a and rk3228b. I can tell you that I own a device Alfawise Z28 Pro which has 1000Mbit/s LAN and wifi ac with 5GHz and USB 3.0. Unfortunately not im use because im not sure if I can use the Z28 images from a similar box. Anyway I think rk3229 has no USB3. 0 and 1000Mbit/s ETH support and maybe also no wifi ac. B
  10. Hey, Thank you very much your explanation. I haven't tried the ssv6x5x driver. Actually I'm not sure yet if wifi mac changes every reboot or the eth0. I actually installed the newest image of you 20.08 legacy kernel. Is it maybe because I did it wrong with the option "burn flash to Rom"? But I didn't install the idbloader. It recommended not to install, so I didn't install it. As far as I understand @fabiobassahe also thinks we need the unclean workaround. How can I actually get the real Mac address? It's not the one
  11. Hey, Thank you very much your explanation. I haven't tried the ssv6x5x driver. Actually I'm not sure yet if wifi mac changes every reboot or the eth0. I actually installed the newest image of you 20.08 legacy kernel. Is it maybe because I did it wrong with the option "burn flash to Rom"? But I didn't install the idbloader. It recommended not to install, so I didn't install it. As far as I understand @fabiobassahe also thinks we need the unclean workaround. How can I actually get the real Mac address? It's not the one
  12. Hey, Thank you very much your explanation. I haven't tried the ssv6x5x driver. Actually I'm not sure yet if wifi mac changes every reboot or the eth0. I actually installed the newest image of you 20.08 legacy kernel. Is it maybe because I did it wrong with the option "burn flash to Rom"? But I didn't install the idbloader. It recommended not to install, so I didn't install it. As far as I understand @fabiobassahe also thinks we need the unclean workaround. How can I actually get the real Mac address? It's not the one
  13. Hi thanks a lot for your very quick reply! I used your compiled images. Can I also try to use ssv6x5x driver with ssv6051 chipset? Id: 3030:3030 Cheers and very good work and fantastic that it made to official armbian side! I'm very happy to see that after such a long period of collecting this electronic trash devices. Unfortunately they were never usable with original firmwares under Android... BTW is there a solution for switching eth0 mac address after each reboot?
  14. 35.4 KBytes [ 5] 4.00-5.00 sec 304 KBytes 2.49 Mbits/sec 0 35.4 KBytes [ 5] 5.00-6.00 sec 491 KBytes 4.02 Mbits/sec 0 35.4 KBytes [ 5] 6.00-7.00 sec 588 KBytes 4.82 Mbits/sec 0 35.4 KBytes [ 5] 7.00-8.00 sec 1.16 MBytes 9.77 Mbits/sec 0 35.4 KBytes [ 5] 8.00-9.00 sec 1.12 MBytes 9.43 Mbits/sec 0 35.4 KBytes [ 5] 9.00-10.00 sec 1.45 MBytes 12.2 Mbits/sec 0 35.4 KBytes - - - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr [ 5] 0.00-10.00 sec 5.96 MBytes 5.00 Mbits/sec 0
  15. Fingers crossed for development. Dpkg: error processing package linux-image-legacy-rk322x (--configure) : installed linux-image-legacy-rk322x package post-installation scripts subprocess returned error exit status 1 Errors were encountered while processing : linux-image-legacy-rk322x E: Sub-process /usr/bin/dpkg returned an error code (1) Hope you guys can tell why it's not going well with the update... Also I noticed reboot is still not working unfortunately. I need to replug the power adapter... First test with
  16. Hi @fabiobassa, Noticed a mistake. Did use wrong flash method for NAND... Reflashed with... NAND-method. Now the device is booting again... Sorry guys. This was my mistake, I didn't read carefully enough again... Thanks for your hard work which I really celebrate than just only appreciate which of course I also do! 😊 Hey is it worth to give it a try with new image kernel 5.8 or still no working wifi driver for ssv6051? Edit: guys! I'm blasted of the development! It detected and selected already everything correctly whe
  17. Hi @jockthanks for your answer unfortunately it didn't work out. It is still not booting. I decided with pain to flash the new minimal legacy image. Before flashing it asked to heavily keep the idbloader even when the image has a different one. So I followed the suggestion. Burning successfully finished, shutdown and reboot, Red led is still very weak visible and it doesn't boot... Should I try to reflash with idbloader?
  18. Hey guys I just updated my V88 mini 4k with legacy kernel. During upgrade I saw some errors for rk3229-legacy-kernel update or something. After reboot try it didn't halt as usual, but after replug the box doesn't start anymore just the red led. I installed the armbian onto NAND and it worked quite well even with wifi I used it with around 30 Mbit /s up and down. I just wanted to keep on maintaining and did the upgrade. Now I guess I lost the correct upgrade path between legacy kernels since I haven't updated for at least around 5 months. So what can you recommend and is there a ch
  19. Hey guys, great and awesome work! I hope video acceleration will work soon. I just updated my V88 Mini with working wifi, NAND installation but it hung during upgrade. After new replug and plug again the device worked again and no more upgrades. Unfortunately the reboot still isn't working... @jock Have you found a fix for the reboot problem? The upgrade wasn't enough to fix it. Update: Since the upgrade the wifi performance went drastically down! Before I got around 30 Mbit/s through Iperf3 measurements and now it went down to 0,5 Mbit/s - 1 Mbit/s.
  20. Please don't give up guys! We all hope for big developments in the arm sector and especially with that RK and Amlogic devices. As I said maybe it's worth another Thread to collect ideas what to do with that hardware. As far as I understand, YouTube, Netflix or Disney+ Player won't unfortunately be the best scenarios to use this device in the near future...
  21. @fabiobassa: Especially for you I did also setup a wireguard-tunnel to my bannana pi (also running armbian) with 1 GbE interface. Here is the result without the tunnel: root@bananapi:/etc/wireguard# iperf3 -c 192.168.178.174 -i 1 -t 5 -P 1 -R Connecting to host 192.168.178.174, port 5201 Reverse mode, remote host 192.168.178.174 is sending [ 4] local 192.168.178.193 port 35768 connected to 192.168.178.174 port 5201 [ ID] Interval Transfer Bandwidth [ 4] 0.00-1.00 sec 11.2 MBytes 94.1 Mbits/sec [ 4] 1.00-2.00 sec 11.2 MBytes
  22. @jockI would love if we can use it as a jukebox or something similar. I mean it should already work with spotify premium or something. I think there are already some scripts and software for unix environments like debian, but as I said we need to priorise the sound that this is not lagging at least. - With my S912 (CSA93, 3GB RAM, 32GB ROM, 1GbE unfortunately with AP6212 non working wifi at least for me atm) i can also try to play HD-Videos. They are also laggy, but the sound is working. - I just can't tell you if it's just the HDMI-sound or also the 3,5mm jack and SPDIF-interface....
  23. _ _________ ____ _ _ __| | _|___ /___ \|___ \__ __ | |__ _____ __ | '__| |/ / |_ \ __) | __) \ \/ /____| '_ \ / _ \ \/ / | | | < ___) / __/ / __/ > <_____| |_) | (_) > < |_| |_|\_\____/_____|_____/_/\_\ |_.__/ \___/_/\_\ Welcome to Armbian Focal with Linux 4.4.194-rk322x No end-user support: built from trunk System load: 5.36 5.08 4.99 Up time: 1:02 Memory usage: 24 % of 979MB IP: CPU temp: 59°C Usage of /: 27% of 6.9G Last login: Sun May 3 11:56:04 2020 from 192.168.178.178 root@rk322x-box:~# hexdump -C /sys/bus/nvmem
  24. Thanks for your comments! I can provide you later the informations of your comments if it helps. I flashed now your newest Ubuntu Desktop image and used the profile Rk3229 Mars Profile. This actually worked out and I can also use wifi with the ssv6051 chipset. Beside my FritzBox I can reach 72 Mbit/s and I think that's the maximum with this 1x1 hardware. Iperf3 measurement to my Gigabit Iperf3 Server showed up with a maximum Rx Rate around 35-40 Mbit/s and Tx of around 15-20 Mbit/s. With the 100 Mbit/s Ethernet I can
  25. Did you use the remote control in multitool oder used an extenal USB-Keyboard? It just works to select with external keyboard. So do you see the GPL or does the screen go black?