Jump to content

Search the Community

Showing results for tags 'orangepipc2'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community
    • Announcements
    • Feature Requests
  • Using Armbian
    • Beginners
    • Software, Applications, Userspace
    • Advanced users - Development
  • Upcoming Hardware (WIP)
    • News
    • Odroid M1
    • ROCK 5B
    • Orange Pi 5
  • Maintained Hardware
    • Board does not start
    • Amlogic meson
    • Allwinner sunxi
    • Marvell mvebu
    • Rockchip
    • Other families
  • Unmaintained (CSC/EOL/TVB) / Other
    • TV boxes
    • Off-topic
    • Amlogic meson
    • Allwinner sunxi
    • Marvell mvebu
    • Rockchip
    • Other families

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Matrix


Mastodon


IRC


Website URL


XMPP/Jabber


Skype


Github


Discord


Location


Interests

  1. My RPi PC2 was flashed the armbian OS which was downloaded from the main page ARMBIAN about 3 months ago. Yesterday, I found some packages update are available with "apt update". So I did the command "apt upgrade" . But from then on, the board never be boot up. From the console, the U-Boot version has been upgraded to 2017-09-rc4 from the old version 2017.01-rc1-g5df570f-dirty. I'd appreciate it if anyone could help with this or give me some suggestion. U-Boot SPL 2017.09-rc4-armbian (Sep 11 2017 - 03:34:11) DRAM: 1024 MiB Trying to boot from MMC1 NOTICE: BL3-1: Running on H5 (1718) in SRAM A2 (@0x44000) NOTICE: Configuring SPC Controller NOTICE: BL3-1: v1.0(debug):aa75c8d NOTICE: BL3-1: Built : 03:34:04, Sep 11 2017 INFO: BL3-1: Initializing runtime services INFO: BL3-1: Preparing for EL3 exit to normal world INFO: BL3-1: Next image address: 0x4a000000, SPSR: 0x3c9 U-Boot 2017.09-rc4-armbian (Sep 11 2017 - 03:34:11 +0200) Allwinner Technology CPU: Allwinner H5 (SUN50I) Model: OrangePi PC 2 DRAM: 1 GiB MMC: SUNXI SD/MMC: 0 *** Warning - bad CRC, using default environment In: serial Out: serial Err: serial Net: phy interface7 eth0: ethernet@1c30000 Hit any key to stop autoboot: 0 38518 bytes read in 132 ms (284.2 KiB/s) Unknown command 'bmp' - try 'help' switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... Found U-Boot script /boot/boot.scr 3362 bytes read in 190 ms (16.6 KiB/s) ## Executing script at 4fc00000 U-boot loaded from SD Boot script loaded from mmc 116 bytes read in 159 ms (0 Bytes/s) ** File not found /boot/dtb/allwinner/allwinner/sun50i-h5-orangepi-pc2.dtb ** libfdt fdt_check_header(): FDT_ERR_BADMAGIC No FDT memory address configured. Please configure the FDT address via "fdt addr <address>" command. Aborting! 4179 bytes read in 409 ms (9.8 KiB/s) Applying kernel provided DT fixup script (sun50i-h5-fixup.scr) ## Executing script at 44000000 5681602 bytes read in 488 ms (11.1 MiB/s) 12285960 bytes read in 894 ms (13.1 MiB/s) ## Loading init Ramdisk from Legacy Image at 4fe00000 ... Image Name: uInitrd Image Type: AArch64 Linux RAMDisk Image (gzip compressed) Data Size: 5681538 Bytes = 5.4 MiB Load Address: 00000000 Entry Point: 00000000 Verifying Checksum ... OK ERROR: Did not find a cmdline Flattened Device Tree Could not find a valid device tree SCRIPT FAILED: continuing... starting USB... USB0: USB EHCI 1.00 USB1: USB OHCI 1.0 scanning bus 0 for devices... 1 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Device 0: device type unknown ... is now current device ** Bad device usb 0 ** ** Bad device usb 0 ** BOOTP broadcast 1 BOOTP broadcast 2 BOOTP broadcast 3 BOOTP broadcast 4 BOOTP broadcast 5 BOOTP broadcast 6 BOOTP broadcast 7 BOOTP broadcast 8 BOOTP broadcast 9 BOOTP broadcast 10 BOOTP broadcast 11 BOOTP broadcast 12 BOOTP broadcast 13 BOOTP broadcast 14 BOOTP broadcast 15 BOOTP broadcast 16 BOOTP broadcast 17 Retry time exceeded; starting again missing environment variable: pxeuuid missing environment variable: bootfile Retrieving file: pxelinux.cfg/01-02-01-b3-6f-d0-61 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/00000000 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/0000000 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/000000 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/00000 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/0000 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/000 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/00 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/0 *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/default-arm-sunxi *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/default-arm *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/default *** ERROR: `serverip' not set Config file not found BOOTP broadcast 1 BOOTP broadcast 2 BOOTP broadcast 3 BOOTP broadcast 4 Abort BOOTP broadcast 1 BOOTP broadcast 2 BOOTP broadcast 3 BOOTP broadcast 4 Abort
  2. OrangePI PC2 Problem report of the current state and improvement favor. --------------------------------------- Armbian_5.40_Orangepipc2_Ubuntu_xenial_next_4.14.15_desktop Keyboard and the monitor resolution.. other All kinds' setting, reboot, when, everything goes off. Therefore it isn't used. --------------------------------------- Armbian_5.34.171121_Orangepipc2_Ubuntu_xenial_next_4.13.14_desktop A keyboard is the monitor resolution only. It's preserved and it's practicable somehow. (1) Setting of other than above, reboot, when, please disappear. I close. (2) Cash of Root becomes full right now, even Mozc, install, can. --------------------------------------- The priority issues which is most: Setting of the resolution of the monitor is of 1980x1080. The user who can use it in the environment, probably, hardly. The high-definition television television by which I who isn't here am a living room, too After O occupies and initializes. It's used in its monitoring (1280x1024). This is other ones, could you also settle it above all? It's a problem of top priority. Daily debugging is thank you. Above, please take care. I'm waiting for completion of early software for 1 day.
  3. Anybody know how install ARDUINO IDE on ARMBIAN orange pi pc 2? Can I drop tar archive to home/pi/arduino
  4. Hi, I'd like to use kvm on the Orange Pi PC2, but the Armbian 4.14.12-sunxi64 kernel doesn't seem to enable it (or possibly the boot loader doesn't put the CPU in the right mode?). If I google: allwinner h5 kvm then the first hit shows a kernel boot log which shows kvm enabled on an Orange Pi PC2, so it looks like it's possible. I'm happy to recompile the kernel myself, but wanted to know if there were any gotchas that might mean this is disabled by default on purpose? Cheers, Tim.
  5. DO NOT READ FURTHER I GOT IT COMPILED after typing "apt-get install htop" it started to install the headers.... strange ------------------------------------------------------------ Hey guys, I am stuck: Followed this: https://docs.armbian.com/User-Guide_Advanced-Features/#how-to-build-a-wireless-driver Try to port it to r8152.ko (RTL8153) / ax88179_178.ko I. (Before I started "apt-get update && upgrade") 1. Install Armbian Headers via armbian-config (Check) 2. wget http://www.asix.com.tw/FrootAttach/driver/AX88179_178A_LINUX_DRIVER_v1.18.0_SOURCE.tar.bz2 (Check) 3. aptitude install build-essential linux-headers-$(uname -r) (Check) 4. tar -xjf AX88179_178A_LINUX_DRIVER_v1.18.0_SOURCE.tar.bz2 (Check) 5. cd AX88179_178A_LINUX_DRIVER_v1.18.0_SOURCE/ (Check) 6. chmod a+x Makefile (Check) 7. make Then this comes: I checked path : "/lib/modules/4.14.4-sunxi64/build" and it is not existing. II. Tryed to change Path of Makefile "KDIR = /usr/src/linux-headers-4.14.4-sunxi64" Then i get III. then i tried : :/ - Just want to have the latest drivers for the USB3.0 to Ethernet Cards..... ANybody maybe successfull with that ?
  6. Hi, is it possible to install RealVNC Server with the title setup ? I use around 7 Devices with RealVNC. I prefer to use this for the 8th too.
  7. Hi...Is support for using Mali GPU of Orangepi PC2 enabled for armbian? I'm trying to install the mesa-dri utilities and getting stuck in the libc-bin segmentation fault? Is it because of lack of support or something else? Also I'm getting issues of protobuf while compiling Opencv for Orangepi PC2. If anybody can help!!
  8. Hello, I know this is slightly the wrong subforum... I'm using an OrangePi PC2 with ARMBIAN 5.34.171109 nightly Ubuntu 16.04.3 LTS 4.13.11-sunxi64 I tried installing rpimonitor using rpimonitor -r after creating a "pi" user and a "pi" group That part worked. Afterwards, it told me that the webserver would be available at 192.168.0.xxx:8888 I tried that. Surprisingly, not the customized version of OrangePi-Monitor appeared, but the "original" RPI Verison. I fixed that copying /etc/rpimonitor/template/OrangePI_xx.conf to /etc/rpimonitor/template/data.conf. After restarting, it actually works, but placeholders are not filled. Is there any change I have to do? Any support would be greatly appreciated
  9. Hi, https://www.armbian.com/orange-pi-pc2/ states: "Following features should work:" ... "SPI+USB boot" . I was trying to load u-boot from the SPI (but without success). I followed the instructions in u-boot/board/sunxi/README.sunxi64 : $ ./sunxi-fel spiflash-write 0 spl/sunxi-spl.bin $ ./sunxi-fel spiflash-write 32768 u-boot.itb Booting from SPI ends with an exception: U-Boot SPL 2017.09-armbian (Sep 13 2017 - 12:23:18) DRAM: 1024 MiB Trying to boot from sunxi SPI "Synchronous Abort" handler, esr 0x02000000 ELR: 4a000000 LR: 125cc x 0: 000000004a000000 x 1: 0000000000000000 x 2: 0000000000007000 x 3: 0000000077777777 As if SPL could find/execute u-boot or SPI at all. Does anybody have any success with booting from SPI on OPI PC2?
  10. Hello, installed nightly image on OPI PC 2. I get a black monitor saying "no signal" and screen is black. But it does not go into sleep mode. Dmesg output is : [ 1.273359] simple-framebuffer 7e05c000.framebuffer: framebuffer at 0x7e05c000, 0x1fa4000 bytes, mapped to 0xffff00000a000000 [ 1.273367] simple-framebuffer 7e05c000.framebuffer: format=x8r8g8b8, mode=3840x2160x32, linelength=15360 [ 1.420280] Console: switching to colour frame buffer device 480x135 [ 1.566153] simple-framebuffer 7e05c000.framebuffer: fb0: simplefb registered! AFAIK simple-framebuffer uses a framebuffer already initialized by the bootloader. So I suppose parameters between both don't match. Same problem with OPI PC and mainline. Is there a way to get hdmi output? Thanks.
  11. Hello, all. My Orange Pi PC2 recently broke when doing an upgrade. So I hooked a serial cable to it and watched what it did. The error was that it couldn't find the dtb file. It was looking for "/boot/dtb/allwinner/allwinner/sun50i-h5-orangepi-pc2.dtb" and "/dtb/allwinner/allwinner/sun50i-h5-orangepi-pc2.dtb", but the former fails because the file is at "/boot/dtb/allwinner/sun50i-h5-orangepi-pc2.dtb". So, I put a simlink in dtb/allwinner called 'allwinner' and pointing to the parent directory. Now the device boots. I'm not sure if that's the proper fix, but it works for now and I'll fix it if I manage to break something with it later on. This brings me to the real questions which I discovered as I tried to debug this. While booting uboot says it loads something--it dosn't say what--and reports "6944 bytes read in 180 ms (37.1 KiB/s)" That looks like it was the boot.bmp file. Which--according to 'file'--is really a BMP file. But it looks like uboot wasn't expecting that because it says "Unknown command 'bmp' - try 'help'" That probably come from the 'BMP' magic entry at the beginning of the boot.bmp file. So, first question: Why are we loading a .bmp file? uboot clearly doesn't expect it and doesn't seem to know what to do with it. Where does uboot get the idea that it should even load that file? The next set of quesitons come from what uboot does next. It does "2253 bytes read in 191 ms (10.7 KiB/s)" which is the right size to be boot.scr. That file seems to start with some non-printable garbage which doesn't seem to upset uboot. It uses a bunch of predefined variables and I can't find where they are defined--the location of the dtb files in particular are what I was trying to determine the source of. Where does uboot get this? The armbianEnv.txt file doesn't have it. I'd like to know more about how the boot process works. If anyone could point me to a good source of information about this, I would appreciate it. The uboot documentation is very generic and doesn't deal with the specifics of how armbian handles things. Thank you!
  12. Hi, I performed an apt-get upgrade on my system, and it installed the 4.13 kernel. After the reboot, i started getting the message "bad CRC - using default environment". I spent the whole day reading many threads but still didn't manage to come with a solution. I tried the symlink to /boot/dtb/allwinner from the PC2 forum, but with no luck. I bought this board recently, it is my first board and i am very new to this, although i have decent Linux knowledge. Could you point out what i might have done wrong or if i'm missing something?
  13. anyone know if the onboard mic works in armbian? ive tried using arecord on the default audio device but no output.
  14. Hello so i got Orange Pi PC 2 today and installed armbian from here : https://www.armbian.com/orange-pi-pc2/ i can SSH to it. but i dont know how to get AV out to work :/ can u help me ? im a total Beginner i just need to get Tv out to work and start learning. I know that armbian for H5 is in the early development state.
  15. I got my OPi PC2 last week and flashed the latest armbian server version. Every time I enter "reboot" on SSH to reboot the system, or plug in the power cable. The system can not boot up with a great probability. My power source is the charger for SAMSUNG smartphone. The specification indicates it can provide 5V/2A current. With the UART, I found the uboot process was stuck after the statement "INFO: BL3-1: Next image address: 0x4a000000, SPSR: 0x3c9". The LED is OFF in that moment. After plugging out/in the power cable multiple times, the system can be boot up successfully finally and works very well. I'd like to know anyone has the same problem? How can I solve this issue?
  16. Hi armbians, I was wondering how do you trigger the red LED for other devices like USB r/w or wifi tx/rx . echo mmc0 > /sys/class/leds/orangepi:red:status/trigger works like a charm for microSD r/w. I want to trigger it for my wifi interface which is "wlx0013ef6d5c23" . Any thoughts? Detailed log uploaded at http://sprunge.us/gCjP
  17. Help I'm trying to get my t230 dvb stick to work with my orange pi pc2 I copied the .fw files across and reboot but it will not load the firmware can anyone help please
  18. Hello I installed today image version: Armbian_5.24.170129 (CLI version) Image starting fine but after some time i'm unable to login via ssh and hdmi showing something like this: Any ideas? Its on sandisk card class 10.. (brand new ) but kingston (used for 1,5 y)card also class 10 warking fine,
  19. Just found it on Aliexpress: https://www.aliexpress.com/item/New-Orange-Pi-PC2-H5-64bit-Support-the-Lubuntu-linux-and-android-mini-PC-Beyond-Raspberry/32761481418.html I ordered one to go and try it out / check the features. I am very interested in seeing the performance / heat dissipation...
×
×
  • Create New...