Jump to content

Search the Community

Showing results for tags 'rockpi-4b'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Armbian
    • Armbian project administration
  • Community
    • Announcements
    • SBC News
    • Framework and userspace feature requests
    • Off-topic
  • Using Armbian
    • Beginners
    • Software, Applications, Userspace
    • Advanced users - Development
  • Standard support
    • Amlogic meson
    • Allwinner sunxi
    • Rockchip
    • Other families
  • Community maintained / Staging
    • TV boxes
    • Amlogic meson
    • Allwinner sunxi
    • Marvell mvebu
    • Rockchip
    • Other families
  • Support

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Matrix


Mastodon


IRC


Website URL


XMPP/Jabber


Skype


Github


Discord


Location


Interests

  1. Hi people! I'm trying to use Armbian 23.8.1 CLI with the Rock 4 SE board without success. I write the eMMC in the classic way: xzcat Armbian_23.8.1_Rockpi-4b_bookworm_current_6.1.50.img.xz | sudo dd of=/dev/sdb bs=4M status=progress; sync but nothing seems to happens, i have only the green led on, the blue led is not blinking and the display says "no hdmi signal". No problems with the image from radxa. Do you have any idea what's going wrong?
  2. Hi Does anyone have a working U-boot or CLI image with serial console disabled for Rock Pi 4b or Rock 4SE? Been struggling for a week to build my own with ./compile.sh and user patch but no success, U-boot hangs at user input prompt because gps sends data from power on. Have tried all suggestions on the forum.
  3. Hello everyone. Please help me with the following problem. I have a Rock Pi 4b 1.4 (with SPI flash). I did the boot from the NVMe SSD using the image rkspi_loader-v20.11.2-trunk-v2.img according to the instructions. I installed Armbian 23.11 Jammy XFCE on NVMe SSD KingSpec NX 1TB. I’m using a power supply Baseus 65W GaN Pro (with PD). The system loads and works well. However, the system cannot reboot. When i click on reboot, the system starts to reboot and after the reset goes into a cyclic reboot. I need to turn off the power to reboot. What could be the problem and how to solve it? UART (Serial console) log: " " $&0 f@`B@@NF0f@`B@@NF 0f@`B@@NF@@@LN`b`N" " 0 "$`@@NN`0@b`@``@LFbpb`@H U-Boot TPL 2020.07-armbian (Dec 04 2020 - 22:10:39) Channel 0: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB Channel 1: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB 256B stride 256B stride lpddr4_set_rate: change freq to 400000000 mhz 0, 1 lpddr4_set_rate: change freq to 800000000 mhz 1, 0 Trying to boot from BOOTROM Returning to boot ROM... U-Boot SPL 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) Trying to boot from SPI NOTICE: BL31: v1.3(debug):42583b6 NOTICE: BL31: Built : 07:55:13, Oct 15 2019 NOTICE: BL31: Rockchip release version: v1.1 INFO: GICv3 with legacy support detected. ARM GICV3 driver initialized in EL3 INFO: Using opteed sec cpu_context! INFO: boot cpu mask: 0 INFO: If lpddr4 need support multi frequency, INFO: please update loader! INFO: Current ctl index[0] freq=400MHz INFO: Current ctl index[1] freq=800MHz INFO: plat_rockchip_pmu_init(1190): pd status 3e INFO: BL31: Initializing runtime services WARNING: No OPTEE provided by BL2 boot loader, Booting device without OPTEE initialization. SMC`s destined for OPTEE will return SMC_UNK ERROR: Error initializing runtime service opteed_fast INFO: BL31: Preparing for EL3 exit to normal world INFO: Entry point address = 0x200000 INFO: SPSR = 0x3c9 U-Boot 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) SoC: Rockchip rk3399 Reset cause: RST Model: Radxa ROCK Pi 4B DRAM: 3.9 GiB PMIC: RK808 MMC: mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0 Loading Environment from SPI Flash... SF: Detected XT25F32B with page size 256 Bytes, erase size 4 KiB, total 4 MiB *** Warning - bad CRC, using default environment In: serial Out: vidconsole Err: vidconsole Model: Radxa ROCK Pi 4B Net: eth0: ethernet@fe300000 Hit any key to stop autoboot: 0 Card did not respond to voltage select! Card did not respond to voltage select! "Synchronous Abort" handler, esr 0x96000210 elr: 000000000022d918 lr : 000000000022d8b4 (reloc) elr: 00000000f3f5a918 lr : 00000000f3f5a8b4 x0 : 00000000f8000000 x1 : 0000000000000001 x2 : 0000000000000000 x3 : 0000000000100000 x4 : 00000000f1f36b30 x5 : 0000000000100000 x6 : 0000000000000001 x7 : 00000000f3fcd888 x8 : 0000000000000000 x9 : 0000000000000008 x10: 00000000ffffffe8 x11: 0000000000000010 x12: 000000000000149c x13: 00000000f1f149fc x14: 00000000f1f15b20 x15: 0000000000000020 x16: 00000000f3f5a878 x17: 0000000000060001 x18: 00000000f1f26dc0 x19: 00000000f1f14970 x20: 0000000000000001 x21: 0000000000000000 x22: 0000000000010000 x23: 00000000f3fd37f8 x24: 0000000000010000 x25: 00000000f3fba3f2 x26: 0000000000000000 x27: 0000000000000000 x28: 00000000f1f36a40 x29: 00000000f1f148d0 Code: 540000c1 350000a5 93407c05 f9400080 (b86068a0) Resetting CPU ... resetting ... U-Boot TPL 2020.07-armbian (Dec 04 2020 - 22:10:39) Channel 0: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB Channel 1: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB 256B stride 256B stride lpddr4_set_rate: change freq to 400000000 mhz 0, 1 lpddr4_set_rate: change freq to 800000000 mhz 1, 0 Trying to boot from BOOTROM Returning to boot ROM... U-Boot SPL 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) Trying to boot from SPI NOTICE: BL31: v1.3(debug):42583b6 NOTICE: BL31: Built : 07:55:13, Oct 15 2019 NOTICE: BL31: Rockchip release version: v1.1 INFO: GICv3 with legacy support detected. ARM GICV3 driver initialized in EL3 INFO: Using opteed sec cpu_context! INFO: boot cpu mask: 0 INFO: If lpddr4 need support multi frequency, INFO: please update loader! INFO: Current ctl index[0] freq=400MHz INFO: Current ctl index[1] freq=800MHz INFO: plat_rockchip_pmu_init(1190): pd status 3e INFO: BL31: Initializing runtime services WARNING: No OPTEE provided by BL2 boot loader, Booting device without OPTEE initialization. SMC`s destined for OPTEE will return SMC_UNK ERROR: Error initializing runtime service opteed_fast INFO: BL31: Preparing for EL3 exit to normal world INFO: Entry point address = 0x200000 INFO: SPSR = 0x3c9 U-Boot 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) SoC: Rockchip rk3399 Reset cause: RST Model: Radxa ROCK Pi 4B DRAM: 3.9 GiB PMIC: RK808 MMC: mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0 Loading Environment from SPI Flash... SF: Detected XT25F32B with page size 256 Bytes, erase size 4 KiB, total 4 MiB *** Warning - bad CRC, using default environment In: serial Out: vidconsole Err: vidconsole Model: Radxa ROCK Pi 4B Net: eth0: ethernet@fe300000 Hit any key to stop autoboot: 0 Card did not respond to voltage select! Card did not respond to voltage select! "Synchronous Abort" handler, esr 0x96000210 elr: 000000000022d918 lr : 000000000022d8b4 (reloc) elr: 00000000f3f5a918 lr : 00000000f3f5a8b4 x0 : 00000000f8000000 x1 : 0000000000000001 x2 : 0000000000000000 x3 : 0000000000100000 x4 : 00000000f1f36b30 x5 : 0000000000100000 x6 : 0000000000000001 x7 : 00000000f3fcd888 x8 : 0000000000000000 x9 : 0000000000000008 x10: 00000000ffffffe8 x11: 0000000000000010 x12: 000000000000149c x13: 00000000f1f149fc x14: 00000000f1f15b20 x15: 0000000000000020 x16: 00000000f3f5a878 x17: 0000000000060001 x18: 00000000f1f26dc0 x19: 00000000f1f14970 x20: 0000000000000001 x21: 0000000000000000 x22: 0000000000010000 x23: 00000000f3fd37f8 x24: 0000000000010000 x25: 00000000f3fba3f2 x26: 0000000000000000 x27: 0000000000000000 x28: 00000000f1f36a40 x29: 00000000f1f148d0 Code: 540000c1 350000a5 93407c05 f9400080 (b86068a0) Resetting CPU ... resetting ... U-Boot TPL 2020.07-armbian (Dec 04 2020 - 22:10:39) Channel 0: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB Channel 1: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB 256B stride 256B stride lpddr4_set_rate: change freq to 400000000 mhz 0, 1 lpddr4_set_rate: change freq to 800000000 mhz 1, 0 Trying to boot from BOOTROM Returning to boot ROM... U-Boot SPL 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) Trying to boot from SPI NOTICE: BL31: v1.3(debug):42583b6 NOTICE: BL31: Built : 07:55:13, Oct 15 2019 NOTICE: BL31: Rockchip release version: v1.1 INFO: GICv3 with legacy support detected. ARM GICV3 driver initialized in EL3 INFO: Using opteed sec cpu_context! INFO: boot cpu mask: 0 INFO: If lpddr4 need support multi frequency, INFO: please update loader! INFO: Current ctl index[0] freq=400MHz INFO: Current ctl index[1] freq=800MHz INFO: plat_rockchip_pmu_init(1190): pd status 3e INFO: BL31: Initializing runtime services WARNING: No OPTEE provided by BL2 boot loader, Booting device without OPTEE initialization. SMC`s destined for OPTEE will return SMC_UNK ERROR: Error initializing runtime service opteed_fast INFO: BL31: Preparing for EL3 exit to normal world INFO: Entry point address = 0x200000 INFO: SPSR = 0x3c9 U-Boot 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) SoC: Rockchip rk3399 Reset cause: RST Model: Radxa ROCK Pi 4B DRAM: 3.9 GiB PMIC: RK808 MMC: mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0 Loading Environment from SPI Flash... SF: Detected XT25F32B with page size 256 Bytes, erase size 4 KiB, total 4 MiB *** Warning - bad CRC, using default environment In: serial Out: vidconsole Err: vidconsole Model: Radxa ROCK Pi 4B Net: eth0: ethernet@fe300000 Hit any key to stop autoboot: 0 Card did not respond to voltage select! Card did not respond to voltage select! "Synchronous Abort" handler, esr 0x96000210 elr: 000000000022d918 lr : 000000000022d8b4 (reloc) elr: 00000000f3f5a918 lr : 00000000f3f5a8b4 x0 : 00000000f8000000 x1 : 0000000000000001 x2 : 0000000000000000 x3 : 0000000000100000 x4 : 00000000f1f36b30 x5 : 0000000000100000 x6 : 0000000000000001 x7 : 00000000f3fcd888 x8 : 0000000000000000 x9 : 0000000000000008 x10: 00000000ffffffe8 x11: 0000000000000010 x12: 000000000000149c x13: 00000000f1f149fc x14: 00000000f1f15b20 x15: 0000000000000020 x16: 00000000f3f5a878 x17: 0000000000060001 x18: 00000000f1f26dc0 x19: 00000000f1f14970 x20: 0000000000000001 x21: 0000000000000000 x22: 0000000000010000 x23: 00000000f3fd37f8 x24: 0000000000010000 x25: 00000000f3fba3f2 x26: 0000000000000000 x27: 0000000000000000 x28: 00000000f1f36a40 x29: 00000000f1f148d0 Code: 540000c1 350000a5 93407c05 f9400080 (b86068a0) Resetting CPU ... resetting ...
  4. IT'S FINALLY HERE... THE OFFICIAL ROCKCHIP-LEGACY MULTIMEDIA INTEGRATION After two years of using a separate script to enable the multimedia features in RK3399 Legacy Kernel, the whole framework has been incorporated to the official Armbian packaging system. The choice distro for this integration is Debian Buster (see FAQ at the end of this post about the reasons). I. Installation Download a Armbian Buster Legacy Desktop image for your board, and install it with the standard Armbian method. Install the complete multimedia solution with sudo apt update && sudo apt upgrade sudo apt install media-buster-legacy-rk3399 --install-recommends The switch "--install-recommends" will add the whole Kodi binary addons collection (retro-gaming cores, music visualizations, screensavers, additional media decoders/encoders, vfs, etc.), plus the GLES-to-OpenGL wrapper "gl4es". II. Features Accelerated GLES/EGL X desktop: No action needed. Accelerated Chromium, with WebGL and video display acceleration: No action needed Desktop video player capable of smooth 4K HEVC-HDR: Use the "Rockchip Gst Player" from the Multimedia menu, or choose it with right-click on the media file. Command-line 4K playing is also possible with "gst-play-1.0 --videosink=kmssink". RKMPP-accelerated MPV: Use normally for standard operation (windowed with mouse-operated GUI). For fullscreen, keyboard-operated mode, use the command line switch "--gpu-context=drm" (this will allow you to play smooth 4K). - See instructions below, in the next post, for playing YouTube videos up to 4K with this MPV. ISP Camera with real-time h.264/1080p HW encoding: Using the Gstreamer Plugin. Check this wiki for instructions on how to use it. Most of it applies to Armbian, except for the selection of ov5647/imx219 camera, which must be done using DT overlays. OpenCL 1.2 support: It will be fully functional, no further action needed. You can download some tests and examples from this link. Kodi 18.9 Leia with full RKMPP+GBM acceleration, 4K-HDR capable: You can start it from LightDM menu as your user account: Alternatively, you can also run it as a system service with these command lines: sudo systemctl disable lightdm sudo systemctl enable kodi-gbm sudo reboot Full collection of Kodi binary add-ons: Includes retrogaming cores, media encoders and decoders, PVR, screensavers, vfs and audio visualizations. They are all installed with the package "kodi-addons-full", but are disabled by default. They need to be enabled individually within the Kodi GUI. OpenGL 2.1 support through the gl4es wrapper: It is installed with the package "gl4es", with no further action needed. III. Sources This is the list of the sources used for the packages: IV. FAQ ¿Why did you use Debian Buster as a base for this implementation? It was the most appropriate for several reasons. Upstream Rockchip-Linux developers use Debian buster, so the software could be ported with less modifications than if we chose a different distro. Besides, it is a completely stable distro, unlike Bullseye, which is a moving target as of today. It also has Chromium as a package, unlike Focal that uses snap instead. For last, it has a good backports repo, with several libs that would otherwise need to be compiled and maintained if we chose, for example, Focal. ¿Why Legacy instead of Mainline? This is an implementation based on the vendor's BSP kernel. It has been tested and is reliable, which many people will prefer rather than having a bleeding-edge, less stable implementation. In addition to that, Mainline upstream multimedia support is still a WIP, and lacks many features that are only present on Legacy kernels. ¿Will you add new features to this implementation? No, this implementation will only receive bug fixes if necessary. From now on, all multimedia work will be focused on Mainline and recent distros (like Focal or Bullseye). All new features will go there.
  5. I used iperf3 to monitor the LAN perferomance. It seems the LAN Port only runs on 100 Mbit how can I get a 1GBit speed ? Accepted connection from 192.168.xxx.xxx, port 64266 [ 5] local 192.168.xxx.xxx port 5201 connected to 192.168.xxx.xxx port 64267 [ ID] Interval Transfer Bitrate [ 5] 0.00-1.00 sec 10.7 MBytes 90.1 Mbits/sec [ 5] 1.00-2.00 sec 11.3 MBytes 94.8 Mbits/sec [ 5] 2.00-3.00 sec 11.3 MBytes 94.7 Mbits/sec [ 5] 3.00-4.00 sec 11.3 MBytes 94.9 Mbits/sec [ 5] 4.00-5.00 sec 11.3 MBytes 94.8 Mbits/sec [ 5] 5.00-6.00 sec 11.3 MBytes 94.7 Mbits/sec [ 5] 6.00-7.00 sec 11.3 MBytes 94.7 Mbits/sec [ 5] 7.00-8.00 sec 11.3 MBytes 94.9 Mbits/sec [ 5] 8.00-9.00 sec 11.3 MBytes 94.8 Mbits/sec [ 5] 9.00-10.00 sec 11.3 MBytes 94.9 Mbits/sec [ 5] 10.00-10.04 sec 441 KBytes 95.0 Mbits/sec - - - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate [ 5] 0.00-10.04 sec 113 MBytes 94.3 Mbits/sec receiver
  6. Hi, i use a Rock Pi 4b with a external USB3 Seagate 4TB HDD on USB3 Port on RockPi 4B. Der HardDisk ist ext4 formatet und mounted via fstab The maximum troughput over Samba Share is around 11 Mbit The same USB HDD on a Odroid with same samba settings has an troughput over 100 MBit Any Ideas ? Thanks Ingo
  7. I have a rock 4b+ and I used it as an android box for a while. Then today I tried to flash it with latest armbian image (23.8.1) and it does not boot in microSD or when I flash it through USB OTG. I have erased the SPI flash completely and install the correct spi_loader. It also boots properly with Radxa debian image. Initially I though this is a boot issue, but after checking with a serial cable, it turns out this is a HDMI issue.. After I finish the usual procedure to setup password etc... I got this: Now starting desktop environment... root@rockpi-4b:~# [ 633.211385] hdmi-audio-codec hdmi-audio-codec.5.auto: Only one simultaneous stream supported! [ 633.212145] hdmi-audio-codec hdmi-audio-codec.5.auto: ASoC: error at snd_soc_dai_startup on i2s-hifi: -22 [ 633.212986] ff8a0000.i2s-i2s-hifi: ASoC: error at __soc_pcm_open on ff8a0000.i2s-i2s-hifi: -22 [ 639.440718] rockchip-pinctrl pinctrl: pin gpio3-29 already requested by leds; cannot claim for ff880000.i2s [ 639.441636] rockchip-pinctrl pinctrl: pin-125 (ff880000.i2s) status -22 [ 639.442248] rockchip-pinctrl pinctrl: could not request pin 125 (gpio3-29) from group i2s0-8ch-bus-bclk-off on device rockchip-pinctrl [ 639.443344] rockchip-i2s ff880000.i2s: Error applying setting, reverse things back [ 639.444084] rockchip-i2s ff880000.i2s: bclk disable failed -22 Help / hints are highly appreciated!
  8. Hi, working on Rock Pi 4B++ and trying to make our displays work. Armbian Bookworm 23.8 Raspberry Pi 7" official touchscreen Officialy supported by Radxa (https://wiki.radxa.com/Rockpi4/Raspberry_Pi_official_LCD) but it does not work on Armbian at all. Works on official Radxa Debian image. No display on Armbian. Using device tree overlay from Radxa image - does not work, of course. Waveshare 4.3" touchscreen HDMI (https://www.waveshare.com/wiki/4.3inch_HDMI_LCD_(B)) It works. Image is visible, touchscreen works but the resolution seems to be scrambled. It is 800x480 and it is correctly reported, but the image is somehow distorted. I guess the problem is the aspect ratio which is 15:9. On Raspberry Pi, it works correctly but the following settings is required: How to correct this on Armbian? Waveshare 4.3" touchscreen DSI We also have DSI version of the above display. We have not tried yet but I guess what the result will be, right? So my question is How to make these displays work correctly on Armbian? Thank you.
  9. Hello all, I have a RockPi 4B in use and wanted to connect my 7" display from Raspberry via the display port. According to these instructions, it should also work. https://wiki.radxa.com/Rockpi4/hardware/display#Raspberry_Pi_7_inch_Touch_Display But unfortunately I can't find this file under "boot" because I'm using an ARMBIAN image. How can I address this 7" display? Can anyone help me here? Best regards from Berlin Z. Matthias
  10. Hello, I have a Radxa Rock 4se with an RK3399 Rockchip on board. On my host system I run virtualbox with Ubuntu 22.04. I have build succesfully an armbian configuration for the Rock 4se with an edge kernel(6.6.xx) and it runs perfectly on my board, which also has an Raspbbery Pi camera v2 with the IMX219 which also runs okay. However know I would like to make some adjustments to the imx219.c driver, I know that in the cache directory the linux kernel is available. Can I adjust the imx219.c driver in the cache/sources/linux-kernel-worktree/6.6__rockchip64__arm64 and recompile only the kernel, without that the kernel completly is recompiled only difference so it will generate a new imx219.ko file. Kind regards
  11. With Armbian v20.11 one can write mainline u-boot image to board's SPI and enjoy booting nvme drives without any mmc devices. Prerequisities: ROCK Pi 4(A/B/C) v1.4 or 1.3 with SPI soldered in (v1.3 comes without SPI flash from the factory). If you already have Radxa's u-boot written to SPI you need to short pins 23 and 25 for Armbian to boot Boot fresh image of Armbian v20.11.x for ROCK Pi 4(A/B/C) Add the following lines to /boot/armbianEnv.txt overlays=spi-jedec-nor param_spinor_spi_bus=1 Reboot If you shorted 23-25 pins in 1.) then: disconnect them after the ROCK Pi 4 fully boot's enable spi-nor by executing (as root): echo spi1.0 > /sys/bus/spi/drivers/spi-nor/bind verify that the SPI mtd interface is enabled by running ls /dev/mtdblock0 if the last command does not list any file then something went wrong between 3.) and 5.) Run nand-sata-install choose option: "Boot from SPI - system on SATA, USB or NVMe" choose NVMe partition, eg. /dev/nvme0n1p1 accept erasing of the choosen partition with "Yes" choose fs type (tested with ext4) wait a few minutes for rootfs transfer to chosen partition choose writing SPI bootloader with "Yes" confirm that you want to flash it with "Yes" wait ~60 seconds for writing choose Exit Reboot Enjoy Armbian booting with SPI / NVMe Why bother with mainline u-boot? It is known to boot some NVMe drives that legacy u-boot from Radxa has issues with, eg. SAMSUNG 970 EVO Plus and SAMSUNG PM981. This does not mean that all NVMe drives are supported, YMMV. Which NVMe drives are known to be working? Corsair MP510 240GB/480GB/960GB Gigabyte SSD M.2 2280 PCIe x2 Model:GP-GSM2NE8128GNTD HP SSD EX900 M.2 NVMe 120GB. Model: 2YY42AA#ABB Intel SSD 660p Model:SSDPEKNW512GB Kingston A1000 SSD 240GB (PHISON PS5008-E8-10) Kingston A2000 M.2 2280 PCIe NVMe PNY 250GB XLR8 CS3030 M.2 NVMe SSD PCIe Gen3 x4 Sabrent Rocket 256GB NVMe PCIe M.2 2280 Samsung 970 EVO Plus SSD 250GB M.2 2280, PCIe 3.0 x4, NVMe, 3500/2300 MB/s Samsung PM981 256GB XPG SX6000 Lite 128GB (ASX6000LNP-128GT-C) Why not using Radxa's u-boot SPI image? Ambian's u-boot configuration is incompatible with Radxa's SPI image Why Armbian is using u-boot that is incompatible with Radxa's? It uses mainline u-boot with Open Source TPL/SPL/proper and BL31 from Rockchip packaged into u-boot and we may switch to using open source ATF instead of the BL31 in the future. Can I boot Radxa's images with Armbian's u-boot written to SPI? Yes. Armbian's SPI u-boot is compatible with Radxa's images available here: https://github.com/radxa/rock-pi-images-released/releases It may not be compatible with some older images (released before July 2020) because of the device tree filename change.
  12. I changed this in the dt and got more than double the speeds from my Samsung U3 SD card: However I have no idea what the process of getting this into the kernel source looks like. --- rk3399-rock-pi-4b.dts 2023-10-04 15:36:05.031221270 +0200 +++ rk3399-rock-pi-4b-mod.dts 2023-10-04 00:34:15.773888431 +0200 @@ -342,6 +342,7 @@ disable-wp; pinctrl-names = "default"; pinctrl-0 = <0x26 0x27 0x28 0x29>; + sd-uhs-sdr104; phandle = <0xce>; };
  13. Hi, I'm new to armbian and I've started with RockPi4b board. I would like to add fan control with PWM, but adding pwm (or pwm0) overlay doesn't work. I can't also find the overlay for it at /boot/dtb-5.8.6-rockchip64/rockchip/overlay/. Is it supported? I've checked and the /sys/class/pwm/pwmchip0 is present, but accessing export, as described here : doesn't work and /sys/class/pwm/pwmchip0/pwm0 is not present. I've tried to find pwm access examples for this board, but none of it works on armbian (all are vendor builds specific). Can anybody point me in the right direction or give any hint how to enable pwm? EDIT : I've managed to enable/dosable PWM pin with sudo mraa-gpio set 11 1 Although, its GPIO, rather PWM access so I can't control the FAN speed and only power on/off the fan.
  14. I plan to upgrade my NVMe memory. I currently boot off it - I set this up using the Armbian installer. Before doing the upgrade I'd like to know that I can boot off my SD card, should anything go wrong with the upgrade. But I'm unsure how to disable the NVMe boot sequence (which I think is SPI flash --> eMMC/mmcboot --> NVMe). If I insert my Armbian SD card, the system doesn't start. I've tried shorting pins 23/25 to disable the SPI flash but this has no effect. I am assuming that I can complete the upgrade by amending armbianEnv.txt to make the 'rootdev=UUID' line point to the new NVMe's UID? Is there a known solution to my query?
  15. Опубликовано: только что · Hidden - This content must be approved before it can be edited. HOT NEWS!!! With Armbian Armbian 23.02.2 Jammy with Linux 5.15.93-rockchip64 on (rockpi-4b plus v.1.72) Add (do it elso on all booting fevices = MMC, NVME, MPD, SD) the following lines to /boot/armbianEnv.txt overlays=spi-jedec-nor param_spinor_spi_bus=1 Reboot If you shorted 23-25 pins in 1.) then: disconnect them after the ROCK Pi 4 fully boot's enable spi-nor by executing (as root): echo spi1.0 > /sys/bus/spi/drivers/spi-nor/bind verify that the SPI mtd interface is enabled by running ls /dev/mtdblock0 if the last command does not list any file then something went wrong between 3.) and 5.) Run sudo nand-sata-install choose option: "Boot from SPI or MPD - system on SATA, USB or NVMe" choose NVMe partition, eg. /dev/nvme0n1p1 accept erasing of the choosen partition with "Yes" choose fs type (tested with ext4) wait a few minutes for rootfs transfer to chosen partition choose writing SPI bootloader with "Yes" confirm that you want to flash it with "Yes" wait ~60 seconds for writing choose Exit IN /boot/armbianEnv.txt choose your needing booting UUID, use command: sudo blkid it look like this: /dev/nvme0n1p1: UUID="ca927a6a-b2f0-4184-ab0f-5719e34172db" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="19354531-01" /dev/mmcblk1p1: LABEL="armbi_root" UUID="cfd67d21-5d00-4032-823e-b68830ca3543" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="22fbd54f-01" /dev/zram0: UUID="de7c0efa-e9cc-11ed-885d-c3fae5811b14" TYPE="swap" /dev/zram1: LABEL="log2ram" UUID="906b40da-e43c-4971-bff5-e9e402eada77" BLOCK_SIZE="4096" TYPE="ext4" in /boot/armbianEnv.txt look like it: sudo nano /boot/armbianEnv.txt verbosity=1 bootlogo=true overlay_prefix=rockchip fdtfile=rockchip/rk3399-rock-pi-4b.dtb rootdev=UUID=ca927a6a-b2f0-4184-ab0f-5719e34172db rootfstype=ext4 overlays=spi-jedec-nor param_spinor_spi_bus=1 usbstoragequirks=0x2537:0x1066:u,0x2537:0x1068:u Reboot Enjoy Armbian booting with SPI / NVMe sudo curl https://raw.githubusercontent.com/TheRemote/PiBenchmarks/master/Storage.sh | sudo bash without pci2.0 in /boot/armbianEnv.txt verbosity=1 Category Test Result HDParm Disk Read 609.77 MB/s HDParm Cached Disk Read 726.72 MB/s DD Disk Write 232 MB/s FIO 4k random read 54613 IOPS (218453 KB/s) FIO 4k random write 16151 IOPS (64605 KB/s) IOZone 4k read 132479 KB/s IOZone 4k write 79127 KB/s IOZone 4k random read 54327 KB/s IOZone 4k random write 89006 KB/s Score: 19365 and with pci2.0 in sudo nano /boot/armbianEnv.txt verbosity=1 bootlogo=true overlay_prefix=rockchip fdtfile=rockchip/rk3399-rock-pi-4b.dtb rootdev=UUID=ca927a6a-b2f0-4184-ab0f-5719e34172db rootfstype=ext4 overlays=pcie-gen2 spi-jedec-nor param_spinor_spi_bus=1 usbstoragequirks=0x2537:0x1066:u,0x2537:0x1068:u Category Test Result HDParm Disk Read 579.83 MB/s HDParm Cached Disk Read 695.44 MB/s DD Disk Write 225 MB/s FIO 4k random read 57206 IOPS (228826 KB/s) FIO 4k random write 18720 IOPS (74881 KB/s) IOZone 4k read 131620 KB/s IOZone 4k write 79301 KB/s IOZone 4k random read 65461 KB/s IOZone 4k random write 117974 KB/s Score: 22989 All it tested on Brand:Samsung M.2 NVMe 980 Pro Board: Radxa ROCK Pi 4B plus v.1.72 hardware Device: Samsung SSD 980 PRO 1TB Class:SSD (M.2 NVMe) Изменено только что пользователем Cyrill PS. Создано с использованием материала от пользователя Igor, на этом же сайте и танцев с бубнами с материали RADXA. За что и благодарю, чем могу, сообщество и его верных пользователей.... на базе данного решения настроен NAS на базе urbackup server/client 2.5.31 - но это отдельная песня...
  16. I have a Nebra hotspot with a Rockpi 4 plus v1.73 card. I can't find the Armbian image file to install Crankk mining. I only have 4A, 4B, 4C, and 4C+ img but no 4 plus. Help me! Is there a solution?
  17. Hello, how to get I2C-2 device support in overlay? I have checked /boot/dtb/rockchip/overlay/README.rockchip-overlays and only i2c-7 and i2c-8 seems to be there. GPIO pins are here GPIO2_A0 and GPIO2_A1 https://wiki.radxa.com/Rockpi4/hardware/gpio#Rock_Pi_4A_.2F_4A_Plus_.2F_4B_.2F_4B_Plus_.2F_4C_.2F_4C_Plus.28.3E.3DV1.2.29_general_purpose_input-output_.28GPIO.29_connector Thank you!
  18. Hi, i just received my Rock 4 Se and a 32GB eMMC module today, and i'm currently not sure if the Image is incompatible, or if my storage modules are broken. I tried emmc standalone and SD for boot with nvme (from an dell notebook) for rootfs When i use the emmc, the filesystem goes into read only as soon as i do some apt upgrade. On reboot i often end up in initramfs nd have to fsck. I could gether some dmesg output: After this trace i get a lot of I/O Errors: Im not sure if this is an os or an emmc module issue. Any guess whats going wrong here? after that i coppied the current image ( Armbian_22.11.1_Rockpi-4b_bullseye_current_5.15.80.img.xz) onto a micro SD card, addedthe nvme drive, bootet that and made an armbian-install to migrate the rootfs to the nvme. After a reboot, i could actually start to instlall software. But after a while i still had some freeze of the whole system, so i had to power the board off and turn it on again. Sadly i do not have any more output from this situation. i'm also going to try a version with older kernel, will reportlater if that worked
  19. Hello, I have this combinations which was probably a mistake, because I cannot get the camera running whatever I do. Was someone able to get it up or give me some advice, lead me a good direction? Thanks a lot.
  20. I try to boot Armbian build for Rock Pi Model B but the screen stays black. The Armbian Download Page says for Model SE use Model B builds. Is there a configuration that i can change to make it work. I hope somebody can help me.
  21. I have a Rock4 SE Board (or Rock Pi 4 SE) and I'm using the Armbian_23.02.2_Rockpi-4b_bullseye_current_5.15.93 Debian version. (Linux rockpi-4b 5.15.93-rockchip64 #23.02.2 SMP PREEMPT Fri Feb 17 23:48:36 UTC 2023 aarch64 GNU/Linux) I am trying to set up the correct Device Tree Overlay configuration for my intended application. If I use Armbian-config as a tool to demonstrate the issue here. It starts by listing I2C7 and then I2C8. If I go to the Rock4 SE schematic and search for I2C8, it is not even setup as I2C: Then where is I2C6, for example. It's supposed to be there. If I then look further through the list, it is using RK3318 files (according to Internet search, they are from same 3300 family of chips but the 3318 has 4 x ARM Cortex-A53 @ 1.5 GHz cores). So are these correct. I'm rather confused by these. Could anyone explain. Thanks Colin PS. If I enable spi-spidev and then set the spi parameter to 0 it references SPI0, which is linked to the Ethernet port. I don't believe this is correct behaviour. The reason for this is that when setting it to 0, I cannot SSH into my board. When I set it to 1, I can. However when setting to 1, it shows the following (/dev/spidev1.0) when running ls /dev/spidev*
  22. Hello, did somebody already have success connecting a Raspberry Pi 7 inch display to the current Armbian build? I already tried to add this overlay via armbian-add-overlay, but this did not work. What am I missing? Thank you for your help!
  23. Hello, I have been looking for the solution to give access to the GPIO from the PI user for several weeks, does anyone have the solution? For information, I use a RockPI 4B+ under Armbian 22.11.4. Thank you in advance for your help. Regards Laurent
  24. Hello There! I'm currently using a Rock 4SE, tagged it as 4B because armbian says I should use the version for the board. I'm using a manually built image of armbian, though without any changes. I'm currently trying to figure out how to get faster boot times on SDDMC. So far: 1 - I've disabled some systemd services. Bluetooth related services have made a big difference. 2 - I've tried to disable USB and network support on U-Boot, though unsuccessful, in order to make U-Boot spend less time before booting the kernel. By applying some patches to U-Boot I got to the point where it either compiles and doesn't start the system because of some runtime error about drivers, or doesn't compile at all. Now I'm currently trying to use suspend mode in order to get faster startup times... The problem is that I'm able to enter suspend mode, but I've got no idea on how to wake the system up. I've searched a lot but couldn't find any definitive answer, so I wanted to at least look for directions here. Here, on the armbian forums, I've seen people talking about modifying the devicetree... Though I have absolutely no idea about what changes should be made in that case. On radxa's forums, all I've seen is people asking but having no answers about how that would work... I'm still awaiting a reply of an e-mail I sent to dev@radxa.com. Does the fact that the system supports going into suspend mode implies it has a way to wakeup? If so, is the devicetree the only thing that needs to be modified in order for it to wakeup? Can any GPIO be used for wakeup functionality? Or does it need to be a specific pin? Did anyone get a rockpi board to wakeup from suspend mode??
  25. I know that not all features of legacy vendor kernels can be supported in mainline kernels. However, has anyone considered and/or attempted to get the OTG capability working in a current/mainline kernel? I have a couple different projects where I need to have OTG working so I can have the RockPi 4 be a USB device (e.g. mass storage, ethernet, etc.). For the time being this means I can only use the legacy kernels, but I am hoping that might change in the future. There are a number of different RK3399 boards with DWC3 controllers that could benefit from such a feature being available, right? Since I don't understand the kernel/driver/platform glue layers well enough to make an attempt myself, I am hoping someone who knows more about this might have some extra info? Is it planned for the future? Too complex? Something else?
×
×
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines