JMCC

  • Content Count

    849
  • Joined

  • Last visited

6 Followers

About JMCC

  • Rank
    Embedded member

Recent Profile Visitors

9685 profile views
  1. You failed to provide the necessary information that we need to help you.
  2. Package update in the repos. It reverts back the addition of station-m1 and station-p1 kernels, to the previous state, when everything worked fine. We are keeping the "Depends" relationship to the legacy kernel, since the package actually depends on the legacy kernel: it won't work with a different kernel, and even more it will break the system if installed.
  3. If you are referring to the info that's necessary for us to help you, as @Werner stated above, you've got it in the forum rules and in the warning you receive when you are going to post. You need to provide that if you want any help from our side. My suggestion assumed that it was you who wanted to try the fix by yourself.
  4. It seems like images have not finished uploading yet, some of the links are broken. Just wait a few hours...
  5. My first suggestion is to isolate the patch that makes the changes you need. Right now, your link simply points to a list of zip files with whole kernel sources. Once you have the patch you need, applying it with the Armbian Build System is a piece of cake.
  6. You've got other RK3399 alternatives supported by Armbian, like NanopiM4, NanoPCT4, or Station P1
  7. Sorry, I was away. I'll try to fix it ASAP
  8. I have found a bit too hard to configure HW encoding with TVHeadend. It doesn't give you the possibility of specifying custom ffmpeg commands, so your only chance is creating a pipe in each mux, which AFAIK it can only be done with IPTV muxes. I haven't even tried this. What I do is using the Jellyfin TVHeadend plugin, so I let Jellyfin do the transcoding. That also gives me easy and secure access to my TV channels from outside my home. The device I am using is a Odroid HC1. XU4 and its derivatives (HC1/HC2/MC1) has always been my recommended device for anything requiri
  9. I just tested it and it works for me as expected. Maybe some problem with the mirror sync?
  10. RK BSP kernel uses a special camera interface (RK-ISP1). The best way to make it work, in my experience, is with the RK GStreamer plugin. In the MM Framework documentation (1st post) you have a link to the TInkerBoard wiki, where they explain how to use it. The plugin is ready to go when you install the MM Framework. The media-buster-legacy-rk3399 package will install desktop. You have two options: 1. Disable desktop with "systemctl disable lightdm" 2. Install only the required packages manually without installing the media-buster-legacy-rk3399 metapackage, and probab
  11. You need to use the legacy kernel for the camera to work, not current. And you also need to install the multimedia framework: Remember, you need an Armbian Buster Legacy Desktop image, and install the framework as described in the post. For last, you need to enable the camera using a overlay: $ sudo armbian-config Then select System > Hardware > rpi-cam-imx219 Please post the results of your tests. I have been looking for someone to test the imx219 for a while (I only have a ov5647)
  12. Sounds weird. And even more weird, the link to the armbianmonitor output is broken Can you post another one? That will increase the chances to figure out the problem. Also if you are using legacy kernel, try with current, or vice versa.
  13. Yes, that was my guess. That will require a kernel fix. No, it's the golden connector on the top right corner, next to the GPIO pins
  14. Try different ethernet cables. Or your network interface may be broken. Or many other things. The best option would be to use a UART to USB adapter, log into the machine and see what is happening.