1 1
ArmBoy1988

[solved] NanoPC T4 - Headless Server - File Serving Stops

Recommended Posts

I'm setting up a NanoPC T4 as a network server running OpenMediaVault.  I wasn't sure where to post this and I thought I'd start here.  I'm replacing an existing BananaPi and I have it and the T4 up at the same time.  I've used the BananaPi to stream video files to Raspberry Pi clients running Kodi.  The BananaPi has been working well with an older version of Linux and OpenMediaVault.

 

What's happening is video served from the T4 starts playing well but then stops shortly after playback has started.  The same video file works well on the BananaPi.  I've tried placing the file on an NVMe M.2 drive as well as USB 3.0 and USB 2.0 connected hard disks.  I've tried this through NFS as well as Samba and the same things happen with both.

 

I tried this with both the nightly Armbian Stretch 4.20.x image and the legacy Armbian Stretch 4.4.x image with the same issue happening.

 

The BananaPi and the T4 are both wired to a router with the T4 directly connected to a router port and the BananaPi connected through a small unmanaged switch.

 

At this point, it looks like it may be some network related issue as this seems like the common point for all of these devices/attempts.

 

I'm not sure how to confirm this and if this is the issue, how it can be corrected.

 

Any help is appreciated. 

 

Thank you

Share this post


Link to post
Share on other sites

This is solved.  Nothing was changed on the T4, Armbian or OpenMediaVault.  I've decided to stick with the 4.4.x version of Armbian as the shutdown and a few other functions perform/work better than the 4.20.x version.

 

I was trying to set up some testing of the NFS mounts between the client and server and couldn't use the built-in NFS mounting in Kodi as there is no way to change options., etc.  So, I set up external mounts of the drives.  Following that, the issue no longer occurred.  I tried to use NFS version 4, but that isn't supported.  I specified NFS version 3 and no issues.  I tried skipping around and no hanging...I played a video file that was about 1hr 30min and it played properly to completion.

 

So, this is really a workaround.  I use LibreElec version of Kodi on the Raspberry Pi's.  This issue is either in Kodi or the LibreElec version built-in NFS handling.  It could be some mismatched configuration or options.  In any case, the workaround, mounting the drives before starting Kodi, seems to work properly.

 

Issue closed.  I'll post on the Kodi and LibreElec forums.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1