0
Mr Blood

Orange Pi Lite 2 Wi-Fi problem

Recommended Posts

Hi!  I have a problem with my Orange Pi Lite 2 I tried to connect my device to my home WiFi.

But the device does not see the wifi, at a distance of 10 centimeters.

 

I try to launch commands: 

 

nmtui-connect *name to my WIFI* 

 

nmtui-connect for show all WiFi Network. 

 

But in neither case does the device manage to identify the network.

 

 

I tried using:

 

vim /etc/wpa_supplicant.conf

 

I tried to edit the file and to insert the data of my network but nothing.

 

 

Can anyone give me a hand to solve this problem? 

 

Thanks everyone in advance!

 

 

Share this post


Link to post
Share on other sites

Yes, I see wlan0,

but it does not appear simply wlan0 but wlan0: avahi:

 

I tried to connect to another connection and it works perfectly.

In fact I managed to update the libraries and update the bootloader sequence.

But I don't understand why it doesn't let me use my connection and instead the other ones.

It is configured to perfection. SSID, password, DHCP, firewall, everything as it should be.

But it does not detect it.

Share this post


Link to post
Share on other sites
5 hours ago, Mr Blood said:

I tried to connect to another connection and it works perfectly.

Do you mean that connecting to other routers is working, but not the one you wished ?

5 hours ago, Mr Blood said:

But it does not detect it.

Maybe this specific router is set as "hidden" ...

Share this post


Link to post
Share on other sites

Exactly. It quietly detects all the other wifi in my area.

 

 

The problem is that if I use Ubuntu Mate 16.04 for Orange Pi lite 2 it connects without problems.

Only Armbian does not detect the router.

Share this post


Link to post
Share on other sites
3 minutes ago, Mr Blood said:

Only Armbian does not detect the router.

Did you tried removing the "hidden" setting in your router to see if it can connect ?

Share this post


Link to post
Share on other sites

Forgive me for ignorance but I have no idea how to do it.

My router is TP-Link TD-W8951ND.

 

 

Share this post


Link to post
Share on other sites
29 minutes ago, Mr Blood said:

Forgive me for ignorance but I have no idea how to do it.

My router is TP-Link TD-W8951ND.

In the Admin Web page, there is probably somewhere a checkbox or some other gui to tell "broadcast SSID" enabled or not ...

Share this post


Link to post
Share on other sites

In the end I managed to find a solution.

To be safe, I reset the router and set all the parameters correctly. And now it works perfectly.

 

 

One last thing, I think I found an Armbian bug.

If I am already connected to the network and modify some small parameters on the Armbian router it does not

circumvent the configuration and automatically does not connect. You must disconnect from the network and re-access.

 

By a small parameter, I simply mean changing the router time zone or simply updating the router statistics.

 

I very much hope you can help improve the system.

 

Thanks @martinayotte for helping me, you have been very kind and very helpful.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0