1 1
FranckM

RFCOMM TTY support not available

Recommended Posts

Dear all,

 

I'm looking for help on having  RFCOMM TTY working on a Tinker Board S. Any help will be welcome !!

 

Using : Ubuntu Bionic with Armbian Linux 4.19.69-rockchip

# uname -a
Linux astrotinker 4.19.69-rockchip #5.95 SMP PREEMPT Mon Sep 2 07:34:36 CEST 2019 armv7l armv7l armv7l GNU/Linux


I'm trying to have rfcomm tty working with a bt HC-05 dongle, but RFCOMM TTY seems not to be available. The BT HC-05 is well reconized and connected:

 # bluetoothctl
[NEW] Controller 80:C5:F2:46:E2:C2 astrotinker [default]
[NEW] Device 00:14:03:06:04:ED HC-05_TIC
Agent registered

 

# systemctl restart bluetooth.service

# systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-11-25 22:23:51 CET; 3min 30s ago
     Docs: man:bluetoothd(8)
  Process: 5198 ExecStartPost=/usr/bin/rfcomm bind rfcomm1 00:14:03:06:04:ED (code=exited, status=0/SUCCESS)
 Main PID: 5196 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4784)
   CGroup: /system.slice/bluetooth.service
           └─5196 /usr/lib/bluetooth/bluetoothd -E

Nov 25 22:23:51 astrotinker bluetoothd[5196]: System does not support network plugin
Nov 25 22:23:51 astrotinker bluetoothd[5196]: Bluetooth management interface 1.14 initialized
Nov 25 22:23:51 astrotinker bluetoothd[5196]: Endpoint registered: sender=:1.129 path=/MediaEndpoint/A2DPSource
Nov 25 22:23:51 astrotinker bluetoothd[5196]: Endpoint registered: sender=:1.129 path=/MediaEndpoint/A2DPSink
Nov 25 22:23:51 astrotinker bluetoothd[5196]: Endpoint registered: sender=:1.73 path=/MediaEndpoint/A2DPSource
Nov 25 22:23:51 astrotinker bluetoothd[5196]: Endpoint registered: sender=:1.73 path=/MediaEndpoint/A2DPSink
Nov 25 22:23:51 astrotinker bluetoothd[5196]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Nov 25 22:23:51 astrotinker bluetoothd[5196]: RFCOMM server failed for :1.73/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb:
Nov 25 22:23:51 astrotinker rfcomm[5198]: RFCOMM TTY support not available
Nov 25 22:23:51 astrotinker systemd[1]: Started Bluetooth service.
 

# journalctl -u bluetooth.service
-- Logs begin at Mon 2019-11-25 00:30:28 CET, end at Mon 2019-11-25 22:23:52 CET. --
Nov 25 00:30:35 astrotinker systemd[1]: Starting Bluetooth service...
Nov 25 00:30:35 astrotinker bluetoothd[1466]: Bluetooth daemon 5.48
Nov 25 00:30:35 astrotinker bluetoothd[1466]: Starting SDP server
Nov 25 00:30:35 astrotinker bluetoothd[1466]: kernel lacks bnep-protocol support
Nov 25 00:30:35 astrotinker bluetoothd[1466]: System does not support network plugin
Nov 25 00:30:35 astrotinker bluetoothd[1466]: Bluetooth management interface 1.14 initialized
Nov 25 00:30:35 astrotinker rfcomm[1467]: RFCOMM TTY support not available


Regards

Franck

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, TonyMac32 said:

What is this kernel, self-compiled?

Sent from my Pixel using Tapatalk
 

Well, no, I did not compile the kernel. I think last update (apt upgrade) is from 13/11/19

Share this post


Link to post
Share on other sites

Hi,

 

It seems I'm not the only one https://forum.radxa.com/t/rfcomm-failures-in-ubuntu-server-image-and-debian-desktop-image/375

 

If linux-rockchip64-current.config is the right configuration for my Tinker Board, then RFCOMM is set to  # CONFIG_BT_RFCOMM is not set

 

Trying to buil da new kernel 

 

root@armbuild:~/build# ./compile.sh
[ o.k. ] Create example config file using template [ config-default.conf ]
[ o.k. ] Using config file [ /root/build/userpatches/config-example.conf ]
/root/build/lib/main.sh: line 136: dialog: command not found
[ error ] ERROR in function source [ main.sh:138 ]
[ error ] No option selected
[ o.k. ] Process terminated

 

Share this post


Link to post
Share on other sites

root@astrotinker:~# cat /boot/config-4.19.69-rockchip |grep -i rfcomm
CONFIG_BT_RFCOMM=y
# CONFIG_BT_RFCOMM_TTY is not set
 

Please can you enable this module ?

Share this post


Link to post
Share on other sites
On 11/27/2019 at 5:34 PM, FranckM said:

/root/build/lib/main.sh: line 136: dialog: command not found

This seems to be clear : "dialog" tool isn't present on your machine...

Share this post


Link to post
Share on other sites
3 hours ago, martinayotte said:

This seems to be clear : "dialog" tool isn't present on your machine...

Obvious, indeed :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1