Jump to content

CSC Armbian for RK322X TV Boxes


Recommended Posts

Hello i replaced rk322x-box.dtb  and tried again, result is different but again multitool stop.

End of log file:


Debian GNU/Linux 10 multitool ttyS2

multitool login: root (automatic login)

sh: 1: cannot create /run/motd.dynamic.new: Read-only file system

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
-bash: cannot set terminal process group (-1): Inappropriate ioctl for device
-bash: no job control in this shell
root@multitool:~# [    6.877807] FAT-fs (mmcblk0p1): Volume was not properly unm ounted. Some data may be corrupt. Please run fsck.
[    7.819053] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data  may be corrupt. Please run fsck.


Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

@tommyboy what do you mean with "multitool stops"? You are supposed to interact with it with a monitor attached to the board HDMI port or via SSH, not using the serial adapter port that is just for debugging. The log looks pretty fine to me, you should be able to use the multitool.

Link to comment
Share on other sites

@tommyboy mmmh, it looks like the trust os is bringing the board down for some reason. You can see that from the strange characters [6eggK... you get at the serial prompt.

Now I don't know which piece of software is misbehaving, if the trust of the multitool or the trust on the board, because the very first piece of the log is missing. You should set the serial adapter to 1.5mbps to grab the first part of the log, then post it here.


Link to comment
Share on other sites

Hi  I am not sure but set the serial adapter to 1.5mbps, and this the result.


DDR Version V1.09 20190628
Bus Width=32 Col=11 Bank=8 Row=14 CS=1 Die Bus-Width=32 Size=1024MB
Boot1 Release Time: 2017-06-12, version: 2.37
ChipType = 0xc, 291
SdmmcInit=2 0
FwPartOffset=2000 , 2000
SdmmcInit=0 0
FwPartOffset=2000 , 0
StorageInit ok = 288541
SecureMode : SBOOT_MODE_NS
Code check OK! theLoader 0x61000000, 343003
Code check OK! theLoader 0x68400000, 410912
Enter Trust OS
INF [0x0] TEE-CORE:init_primary_helper:377: Initializing (1.1.0-333-gc9d95d1 #2                       2018年 08月 17日 星期五 03:32:22 UTC arm)

INF [0x0] TEE-CORE:init_primary_helper:378: Release version: 2.0

INF [0x0] TEE-CORE:init_primary_helper:379: Next entry point address: 0x61000000

INF [0x0] TEE-CORE:init_teecore:83: teecore inits done


Link to comment
Share on other sites

The trust os of the original firmware is very old, but yet I don't know the reason why the trust os from the multitool is acting weird. Unfortunately that piece of code is a closed binary blob and I don't know what it is actually doing.


I arranged another multitool with a different trust os. It is not guaranteed to work, but you may try: https://drive.google.com/file/d/1b0BOwdr0J6XxYDyn1HfprtmBPhMHIfnV/view?usp=share_link

Link to comment
Share on other sites

Hello friends,


No request this time, just another success story, at least partial !

I managed to run multitool on a mxq pro tv box.

Now I will try to edit this image to make a linux image working from

the sd card, my parents still like too much their laggy android to delete it, hehe.


Installing linux on mini pcs is so useful, I have done it on many different ones.. Im curious on what people here are doing with their desktops and servers !

ok, all the best, greetings from Brazil, and thanks everyone for the work and research



Link to comment
Share on other sites

2 hours ago, tommyboy said:

Hi Joke, i tried with new multitool but result is same no success.

Maybe there is something wrong with the tv box, thanks for the help.

Well, I don't know exactly, but I don't think your board has a problem. Most probably the issue is in the closed binary code that does something that put the board in suspend. Usually this does not happen with other boards, just with yours and I have no explanation for that.

A possible solution would be to use an opensource trust os, which is available for rk322x, but it is something I can't do in a matter of few days but requires some further study to integrate it into the rockchip boot flow successfully.

Link to comment
Share on other sites

On 1/2/2023 at 6:41 AM, RaptorSDS said:

my solution was reflow/resolder a realtek RTL8723 DS/BS from ali... 


its pin and pin behavior compatible , but without a proper driver the AP S9012P is useless in linux

@RaptorSDS I'm in the same situation as described and am willing to solder another module found on AliExpress. In the joined photo you can see my board (there is a soldering pad for external module and already soldered circuit on board directy), so I'm thinking to get rid of all wifi segment components and directly solder one like this https://fr.aliexpress.com/item/32767855218.html or https://fr.aliexpress.com/item/32495116310.html whats do you think. if you have a datasheet of the S9012P it will be helpful for me to determine if its compatible with what im going to do.


Edited by Ferid Hentati
i forget the photo
Link to comment
Share on other sites

i have only a datasheet of later S9082 , maybe with some google you could also find S9012 .


RTL8723BS should be easy finding .


Most of this addon bords have same layout only some pins like EN (enable) my be variate in the beavior but not position


good price on ali ( at my time is was 10€ without shipping only by a coupon it was affordable (around 3€ inklude shipping)



Link to comment
Share on other sites

Hello Armbian fans,

I'm totally new to linux and I'm doing my first steps on a V88 4k box.
I have installed Armbian_22.02.0-trunk_Rk322x-box_focal_legacy_4.4.194_xfce_desktop.img.xz in the NAND.
rk322x-config and armbian config was set up and I did media_install after that. 
The menus on the desktop also open fast now. CPU LAst no longer goes high when moving windows but moving windows is extremely slow with streaks. Since I don't know anything about this, what do I have to do to get the 2D acceleration to work? The tip here from the forum does'nt work for me.

Thanks for the answer.

The official image with mainlione kernel works great from SD card but I wanted to have the system in NAND.


Translated with www.DeepL.com/Translator (free version)

Edited by regepower
Link to comment
Share on other sites

@regepower Hello, don't expect great desktop performance, the SoC is generally very limited and it was not its purpose to run x11 desktop. The best thing you can do, if you already didn't, is to disable the desktop compositor from setting -> windows manager tweaks -> compositor. Generally this helps a bit with performance, but as said, it won't change a mouse into a kangaroo 🙃

Link to comment
Share on other sites


xfce might be a heavy environment for your v88 box.

you may try lxde which is lighter ..

and even much lighter, there are the window managers, of which I recommend,

openbox + tint2

or jwm, which is the lightest usable option I know of,


I am not a mega X user, but I have tested these on a worse tv box, and

it actually made a difference.

have a good week

Link to comment
Share on other sites

@fangis do yo have link for a manual / instruction  for install JWM or Openbox+tint2


i have not much experience when the desktop not already preinstall and preconfig at startup


last time i install desktop without preinstall ( Dietpi and xfce ) all text and all symbol where missing . Thats was not a good experiance .




Link to comment
Share on other sites

Hello RaptorSDS

I have done it some years ago, so I don't remeber it all, but I recall it as being easy, just installed them with apt, as "apt install jwm" and then there was an option to switch between the different window managers on login, you can have many of them installed.

The defaults will probably work but for the links you asked, google for 'jwm window manager', 'openbox window manager' or the manuals, 'man jwm' , etc.

I think somehow in your setup there were libraries missing ...
Link to comment
Share on other sites

7 hours ago, RaptorSDS said:

last time i install desktop without preinstall ( Dietpi and xfce ) all text and all symbol where missing . Thats was not a good experiance .

Yup, often you need some other "recommended" packages to get the whole thing working right. Sometimes they are listed as reccomended/suggested packages by apt itself, some other time they even are not :D

That's the same for weston, for example: if you install the "weston" package it just does not work if there aren't the EGL/OpenGL libraries already installed.

Link to comment
Share on other sites

Hey guys!

I have a TVBox RK3228A NAND. I followed the procedures described on the first page and installed legacy ARMBIAN. The system crashed during boot...and the brick box. I managed to do the process with the screwdriver and erase the flash.... the box now runs(OK) Armbian from the SD card.

I would still like to boot from internal memory, but multitool no longer displays the option to write to NAND. ("Burn Armbian image via steP-nand")

ow do I switch back? Do I have alternatives to work without SD or external USB?

Link to comment
Share on other sites


eMCP is RAM and Flash on one Chip most time  , --> when you have only one big chip beside the CPU


NAND and eMMC is more tricky but its look the first picture , with the not solder Area ist the place for NAND ( often the NAND ships have many pins on both oposide ends)


to be really sure please look at the big ship below the AMS1117 power regulator


some hint the 4 smaller chip are the RAM (on top and below board)


Link to comment
Share on other sites

9 minutes ago, RaptorSDS said:

last picture right below corner 8 or B  JG22 .....MW or NW.... . chip   please google that this should be the flash memory


from here 

it's  NW814 but google don't tell nothing

Link to comment
Share on other sites

38 minutes ago, fabiobassa said:

Have you read the whole topic ?




Because at the beginning Is clear that multitool will warn you if inside the box there is a nand


That said , go read First post

yes, I have read the first post. So multiboot warn me only if there is a nand? In the case of emmc or encp there aren't warn? What is the precise message showed?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...