Armbian for Amlogic S905X3


Recommended Posts

On 9/18/2020 at 12:33 AM, rforcen said:

in a more general form:

 

ANDROID_SIZE=1500 # size in MB of android image file
BOOT_SIZE=`echo $ANDROID_SIZE+512|bc`
BOOT_SIZE1=`echo $BOOT_SIZE+1|bc`

parted -s "${DEV_EMMC}" mkpart primary fat32 "$ANDROID_SIZE"M "$BOOT_SIZE"M
parted -s "${DEV_EMMC}" mkpart primary ext4 "$BOOT_SIZE1"M 100%

Would this apply to the X96 Max+ also?

Link to post
Share on other sites
Donate and support the project!

using bash integrated arithmetics:

 

ANDROID_SIZE=1500 # size in MB of android image file

BOOT_SIZE=$(($ANDROID_SIZE+512));  BOOT_SIZE1=$(($BOOT_SIZE+1))

parted -s "${DEV_EMMC}" mkpart primary fat32 "$ANDROID_SIZE"M "$BOOT_SIZE"M
parted -s "${DEV_EMMC}" mkpart primary ext4 "$BOOT_SIZE1"M 100%

Link to post
Share on other sites
10 minutes ago, sgrayban said:

Well I hope this works because if it bricks my box I'll be sh*t outa luck because I have no idea how to recover from that.

i've done many successful installations by now,

 

but if it bricks, to recover you will need

 

1. x96max+ android 9 firmware, i downloaded from http://geekbuying.mediafire.com/file/n6pu4qiqalf56d1/aml_upgrade_package.img/file

2. male-2-male type A usb cable

3. win10 apps. and instrutions provided by wechipbox.com

 

hope this helps

Link to post
Share on other sites
On 8/5/2020 at 8:52 PM, zeyavkm said:

Dear Armin,

Can you please help me to solve my Tanix TX6 H6 tv box coming with Allwinner H6 chipset loaded with RTL8822CS module. Actually the stock firmware was flashed with another one and after that wifi and bluetooth not working. Then i couldn't find the stock firmware. Thinking that i have flashed with an older firmware and it doesn't support the RTL8822CS. Is there any solution to make the module detected with the chipset or kernel? Actually i am don't have that much exposure to the linux programming, but i can understand the things. I have already read the quoted text by you and I could find a comment related to 'aw h6'. Is that line to integrate the module with allwinner h6? Hope that i will get a solution to solve my issue.  Kindly advice me what steps i have to follow...... For your information, my email ID is zeyavkm@gmail.com.

Hello,

 

To be honest, I don't understand your problem and your question (especially related to the stock firmware).

 

If you need some help for Android (https://4pda.ru/forum/index.php?showtopic=929205) or for Armbian (https://4pda.ru/forum/index.php?showtopic=929205&st=12220#entry97197782) !

 

PS: Please to translate the page of the Russian forum to find firmware and instructions for your box

 

Link to post
Share on other sites
16 minutes ago, DevShanky said:

I tried comparing file sections and make adjustments to build modified dtb files but it does not help.

Apparently no one knows how to either 1)fix this to work or 2)is to lazy to help any of us with the same problem if they have already fixed it.

 

But it's not just the DTB file we need but the kernel mod also.

Link to post
Share on other sites
2 hours ago, Alexx said:

Because i am newbie to armbian, how can i use this file and what image?

Hi Alexx,
Always check the pinned thread on this forum:  Single Armbian image for RK + AML + AW (aarch64 ARMv8)
These instructions are in that post:

1.  Take for example this desktop.img from Sep. 24:  Armbian_20.09_Arm-64_focal_current_5.8.10_desktop.img.xz I've had really good results with 20.09 ubuntu focal & debian bullseye images.

2. now burn it to a usb with the program https://www.balena.io/etcher/
After it's done you're going to see 2 Partitions appear - you want to open the one says /BOOT.

3. Create your u-boot: Find this file: "u-boot-s905x2-s922" Copy and paste it with a new name of "u-boot.ext". It in fact works for s905x3 too.

4. Now inside /BOOT/dtb/amlogic these are your "Device Tree Binaries". Kernel uses it to detect all your hardware. The Trial and error part is finding the right one that makes your hardware work.
Scroll to the bottom you'll see 'meson-sm1-sei610.dtb'  rforcen is talking about Normally you have to copy & past .dtb files into this directory. But for now try that one! 

5. Configure your 'extlinux.conf'.  Edit /extlinux/extlinux.conf  and comment out or delete every line for other boards.  Near the end you want to uncomment FDT & APPEND for '# aml s9xxx' put in your dtb file from step 4. 

I have a very minimalist one looks like this:

LABEL Armbian
LINUX /zImage
INITRD /uInitrd

# aml s9xxx
FDT /dtb/amlogic/meson-sm1-sei610.dtb
APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0


Now All you have to is try to use a 'toothpick' to make it boot from external media! Search Google see if your box has a "Hidden" recovery button inside the Audio Jack? most do, but some have it more visibly outside. Press it with power unplugged. When you plug it in, keep holding it down until after you see your device's Logo.  I hold it about 6 sec after that. When you release it, the logo will go dark, and it's going into Armbian's boot process. Now it will reboot several times while it sets things up. Give it few minutes and you should have a running Armbian!

If this fails: try dtb files from earlier in this thread. I found almotra's list very helpful!  And try different images, try a server only image instead.

Note: Only run from external media. Do NOT try to install to eMMC yet! it will brick your device. Take a backup with `ddbr`

Link to post
Share on other sites
22 hours ago, Unicorn said:

Hi Alexx,
Always check the pinned thread on this forum:  Single Armbian image for RK + AML + AW (aarch64 ARMv8)
These instructions are in that post:

1.  Take for example this desktop.img from Sep. 24:  Armbian_20.09_Arm-64_focal_current_5.8.10_desktop.img.xz I've had really good results with 20.09 ubuntu focal & debian bullseye images.

2. now burn it to a usb with the program https://www.balena.io/etcher/
After it's done you're going to see 2 Partitions appear - you want to open the one says /BOOT.

3. Create your u-boot: Find this file: "u-boot-s905x2-s922" Copy and paste it with a new name of "u-boot.ext". It in fact works for s905x3 too.

4. Now inside /BOOT/dtb/amlogic these are your "Device Tree Binaries". Kernel uses it to detect all your hardware. The Trial and error part is finding the right one that makes your hardware work.
Scroll to the bottom you'll see 'meson-sm1-sei610.dtb'  rforcen is talking about Normally you have to copy & past .dtb files into this directory. But for now try that one! 

5. Configure your 'extlinux.conf'.  Edit /extlinux/extlinux.conf  and comment out or delete every line for other boards.  Near the end you want to uncomment FDT & APPEND for '# aml s9xxx' put in your dtb file from step 4. 

I have a very minimalist one looks like this:


LABEL Armbian
LINUX /zImage
INITRD /uInitrd

# aml s9xxx
FDT /dtb/amlogic/meson-sm1-sei610.dtb
APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0


Now All you have to is try to use a 'toothpick' to make it boot from external media! Search Google see if your box has a "Hidden" recovery button inside the Audio Jack? most do, but some have it more visibly outside. Press it with power unplugged. When you plug it in, keep holding it down until after you see your device's Logo.  I hold it about 6 sec after that. When you release it, the logo will go dark, and it's going into Armbian's boot process. Now it will reboot several times while it sets things up. Give it few minutes and you should have a running Armbian!

If this fails: try dtb files from earlier in this thread. I found almotra's list very helpful!  And try different images, try a server only image instead.

Note: Only run from external media. Do NOT try to install to eMMC yet! it will brick your device. Take a backup with `ddbr`

Thanks for your help. Do you have working link for desktop image?

Link to post
Share on other sites

I've tried what Unicorn suggested and my T95max plus only boot loops once I press reset with a toothpick and power it on.  Once I remove the SD card with the focal image on it it boots normally.  What am I doing wrong?  I've followed all the instructions and can't seem to get it to work.  Should I try another build besides desktop?

Link to post
Share on other sites
On 10/3/2020 at 9:23 PM, fireman644 said:

I've tried what Unicorn suggested and my T95max plus only boot loops once I press reset with a toothpick and power it on.  Once I remove the SD card with the focal image on it it boots normally.  What am I doing wrong?  I've followed all the instructions and can't seem to get it to work.  Should I try another build besides desktop?

The same result and here with Tanix Tx3 (s905x3) . Only boot loops.

Link to post
Share on other sites

from https://www.cnx-software.com/2019/04/10/amlogic-s905x3-s905y3-s905d3-quad-core-cortex-a55-ai-processors/

The “AI processor” is extra and likely the same 2.5/5.0 TOPS neural network accelerator as found in the upcoming Amlogic S922D processor.

 

so it seems that the S905x3 contains AI hw but it must be the -NON version,

 

to download the toolkit you must be a khadas registered user...

 

anyone has tried this before?

Link to post
Share on other sites
On 10/7/2020 at 11:03 AM, rforcen said:

from https://www.cnx-software.com/2019/04/10/amlogic-s905x3-s905y3-s905d3-quad-core-cortex-a55-ai-processors/

The “AI processor” is extra and likely the same 2.5/5.0 TOPS neural network accelerator as found in the upcoming Amlogic S922D processor.

 

so it seems that the S905x3 contains AI hw but it must be the -NON version,

 

to download the toolkit you must be a khadas registered user...

 

anyone has tried this before?

found a general arm nn sdk: https://github.com/ARM-software/armnn

 

Link to post
Share on other sites

hi anyone with a X88 Pro X3 can provide a dd backup ?? not sure what happened but my box became stuck on boot no way to flash it again


 

[10:31:07 117][HUB3-3][Inf]-------------Download DDR.USB-----------
[10:31:07 117][HUB3-3][Inf]--3-2-0-0
[10:31:07 117][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x000000b1
[10:31:07 619][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x00005183
[10:31:08 121][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x000000b1
[10:31:08 621][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x00005183
[10:31:09 122][HUB3-3][Inf]--Write initial succeed
[10:31:09 122][HUB3-3][Inf]--Upload encrypt at 0xff800228
[10:31:09 122][HUB3-3][Inf]--ulValue = 0x20444142
[10:31:09 122][HUB3-3][Inf]--Read encrypt value succeed
[10:31:09 122][HUB3-3][Inf]--Download DDR.USB,size: 65536!
[10:31:09 124][HUB3-3][Err]--Download file failed, sequence 0
[10:31:09 124][HUB3-3][Err]--usbWriteFile len=4096, ret=-5 error_msg=libusb0-dll:err [_usb_reap_async] reaping request failed, win error: A device attached to the system is not functioning.


[10:31:09 124][HUB3-3][Inf]--Failure : 1, FailureMax : 3
[10:31:19 625][HUB3-3][Err]--Download file failed, sequence 0
[10:31:19 625][HUB3-3][Err]--usbWriteFile len=4096, ret=-116 error_msg=libusb0-dll:err [_usb_reap_async] timeout error

[10:31:19 625][HUB3-3][Inf]--Failure : 2, FailureMax : 3
[10:31:30 127][HUB3-3][Err]--Download file failed, sequence 0
[10:31:30 127][HUB3-3][Err]--usbWriteFile len=4096, ret=-116 error_msg=libusb0-dll:err [_usb_reap_async] timeout error

[10:31:30 127][HUB3-3][Inf]--Failure : 3, FailureMax : 3
[10:31:30 136][HUB3-3][Err]--[0x10103003]Romcode/Initialize DDR/Download buffer/USB transfer error

 

 

Using android recovery it just show all options, but show error trying to mount /cache some I/O error before most operation.

 

Anyone can provide a dd image so I can put a full disk image back??

It's a bit strange happened after me try boot with armbian, I never got the box booting to home screen again, get stuck on android animation

 

 

Link to post
Share on other sites
11 hours ago, Nuno Cruz said:

hi anyone with a X88 Pro X3 can provide a dd backup ?? not sure what happened but my box became stuck on boot no way to flash it again


 


[10:31:07 117][HUB3-3][Inf]-------------Download DDR.USB-----------
[10:31:07 117][HUB3-3][Inf]--3-2-0-0
[10:31:07 117][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x000000b1
[10:31:07 619][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x00005183
[10:31:08 121][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x000000b1
[10:31:08 621][HUB3-3][Inf]--Control write pll reg1 0xfffa0000:0x00005183
[10:31:09 122][HUB3-3][Inf]--Write initial succeed
[10:31:09 122][HUB3-3][Inf]--Upload encrypt at 0xff800228
[10:31:09 122][HUB3-3][Inf]--ulValue = 0x20444142
[10:31:09 122][HUB3-3][Inf]--Read encrypt value succeed
[10:31:09 122][HUB3-3][Inf]--Download DDR.USB,size: 65536!
[10:31:09 124][HUB3-3][Err]--Download file failed, sequence 0
[10:31:09 124][HUB3-3][Err]--usbWriteFile len=4096, ret=-5 error_msg=libusb0-dll:err [_usb_reap_async] reaping request failed, win error: A device attached to the system is not functioning.


[10:31:09 124][HUB3-3][Inf]--Failure : 1, FailureMax : 3
[10:31:19 625][HUB3-3][Err]--Download file failed, sequence 0
[10:31:19 625][HUB3-3][Err]--usbWriteFile len=4096, ret=-116 error_msg=libusb0-dll:err [_usb_reap_async] timeout error

[10:31:19 625][HUB3-3][Inf]--Failure : 2, FailureMax : 3
[10:31:30 127][HUB3-3][Err]--Download file failed, sequence 0
[10:31:30 127][HUB3-3][Err]--usbWriteFile len=4096, ret=-116 error_msg=libusb0-dll:err [_usb_reap_async] timeout error

[10:31:30 127][HUB3-3][Inf]--Failure : 3, FailureMax : 3
[10:31:30 136][HUB3-3][Err]--[0x10103003]Romcode/Initialize DDR/Download buffer/USB transfer error

 

 

Using android recovery it just show all options, but show error trying to mount /cache some I/O error before most operation.

 

Anyone can provide a dd image so I can put a full disk image back??

It's a bit strange happened after me try boot with armbian, I never got the box booting to home screen again, get stuck on android animation

 

 

https://androidpc.es/firmware-x88-pro-x3/

Link to post
Share on other sites
  • Werner locked this topic
Guest
This topic is now closed to further replies.