Jump to content

TigerVNC problems


Recommended Posts

Dear community,


unfortunately, "armbianmonitor -u" doesn't give me a link anymore, and I'm not sure if uploading works at all. So I cant provide the information :(


As our deployment date approaches, we try to finalize our Armbian system for North Pacific seafloor... and found some unexpected problems (problems seem alwas to be unexpected):

The TigerVNC has two problems on Armbian, and it would be great if you could verify that issues and maybe problem some helpful ideas:


(1) TigerVNC (tigervnc-common/stable,now 1.9.0) needs the following workaround to start at all:

LD_PRELOAD=/lib/aarch64-linux-gnu/libgcc_s.so.1 vncserver :1 -localhost no

   Seems to be libunwind8 related, and is ugly, but not the main problem.


(2) TigerVNC can be started by crontab "@reboot", but fails to open a desktop. There are messages about dbus problems, the display closes afterwards.


I use Armbian NEXT, with Debian Buster, and kernel is locked to 4.19.90 (due to the various troubles with the new kernel, which seems to be optimzed for video playback but not stable operation).


Any help is appreciated, and if you need more information, please let me know.


So far, Michael



Link to comment
Share on other sites

Thanks, you helped me with the first part of fixing TigerVNC on current Armbian, hopefully I can help you with the second one:

# apt install dbus-x11


This package contains the program "dbus-launch".

For example the desktop environment Xfce, at least in our use case, tries to launch "dbus-launch", but won't find it. It seems the path environmental variables are not set when you launch something from within /etc/crontab. I load them with the "source" command (also available as ".") from /etc/profile. This could fix other possible bugs, too:



@reboot username . /etc/profile LD_PRELOAD=/lib/aarch64-linux-gnu/libgcc_s.so.1 tigervncserver -localhost no

Link to comment
Share on other sites

Thanks for the information.

At the moment, I'm happy with the rc.local solution, as it works :)

I was in contact with Adrian Bunk, who is maintaining libunwind (and was at university with me), but didn't get any response so far.


I will try the crontab solution as time permits, due to Corona we are delayed with deployment, and things might shift for at least six months :(

Link to comment
Share on other sites

Hi Linuxfan,


your line doesn't work for me. We use ZSH on the system, and executing the /etc/profile gives us a working VNC server, but no ZSH anymore. Which in turn leads to malfunctioning of the startup of hardware... if you can give me a hint on how to source the correct environment, it would be great.


See you, Michael

Link to comment
Share on other sites

Solved, finally. A collegue of mine (ZSH fan :) made it working.

Basically, the dbus_x11 was first part of problem, and the missing ZSH entry in the user crontab:



@reboot /usr/bin/zsh -l -c "LD_PRELOAD=/lib/aarch64-linux-gnu/libgcc_s.so.1 vncserver -localhost no"


Now we are just "stuck" with the libunwind problem, but that can be worked around by PRELOAD for now.

Somehow I'M a bit happy about the forced lockdown now, as it shifted deployment and allows us to solve some problems in a really good manner, and not under high time pressure :)

Link to comment
Share on other sites

This issue is fixed since version 1.10.1+dfsg-4 and Ubuntu 20.10 already ship newer package (1.10.1+dfsg-7).

You can use TigerVNC 1.10.1+dfsg-7 on Ubuntu 20.04 as well, but this will require manual downloading of tigervnc packages here: https://launchpad.net/ubuntu/+source/tigervnc


Relevant bugreports:



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines