0
UniformBuffer

Kernel Boot Parameters

Recommended Posts

Hi,

i have some difficulties to add some boot parameters to the kernel.

From what i read, the most safe procedure is to use the armbian-config tool, that will add the parameters to /boot/armbianEnv.txt file.

As i have understood, the armbianEnv will be readed by the boot.cmd/boot.scr at launch, without need to recompile anything.

I have added the needed parameters using armbian-config, but does not work.

To be precise, the commands that i have to add are:

Spoiler

video=composite-1:d
video=Composite-1:d

I need to disable the drm composite output because my monitor is.....well, not good and the composite output cause a lot of problems.

I have also tried to enable the boot logo changing the value from "disabled" to "enabled", but nothing has changed.

I'm doing something wrong? I miss something?

I have also tried using the procedure described here without success: https://docs.armbian.com/User-Guide_Fine-Tuning/

Can someone help me?

Thanks for the attention and the dedicated time.

Have a good day

Share this post


Link to post
Share on other sites

I would try "video=composite-1:d".. this goes in over u-boot variables, and they tend to mess up stuff.. cause it's then more like extraargs=video=composite-1:d whereas it should be extraargs="video=composite-1:d"..

 

 

Share this post


Link to post
Share on other sites
19 hours ago, chwe said:

I would try "video=composite-1:d".. this goes in over u-boot variables, and they tend to mess up stuff.. cause it's then more like extraargs=video=composite-1:d whereas it should be extraargs="video=composite-1:d"..

 

 

So you suggest to change the command to "command" right? I tried it but nothing happen. Maybe your suggestion works, but the command itself doesn't. As i know, all current kernel boot parameter can be found on /proc/cmdline file, but there isn't.

 

Solution found:

I tried to use some of the texts you suggest, specifically the extraargs=video=composite-1:d (without quotes) works.

Seems that the script look for the extraargs= prefix and add everything next to kernel parameters.

It appear on /proc/cmdline and the command seems to work, now that connector is listed ad "disconnected".

Thanks a lot for the help and the dedicated time!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0