Jump to content

Need help with building a gateway (OPi PC 2, Armbian, PiHole etc)


Go to solution Solved by bozden,

Recommended Posts

Hi friends, I've been away from SBC's (and you) for two years. With covid-19 at hand and all family at home remote working/learning, I wanted to redesign my home-office network. I bought two managed switches (Zyxel 1200GS-8) in order to introduce VLANs, transformed the office server to a router etc. I try to build a SBC gateway between public and home network but got myself into trouble. I'm working on this for three days now but couldn't get it working. I messed around a lot and got lost, need second (and more) eyes to debug it.


Here is the network layout: 


About the gateway:

  • OPi PC 2 ( has 1Gbps port connected to home NW) augmented with a 100 Mbps USB Ethernet (to router)
  • Latest (as of 2020/10) Armbian (Ubuntu 20.04.x based)
  • I removed Network Manager and switched to systemd & netplan (all my installations have these and they are very intuitive - and got stable)
  • Installed PiHole (manually from command line, disabling OS check) to serve .64.* home network.
  • Enabled ufw and handling the port/interface/subnet routing with before.rules


What is working:

  • Can ping/traceroute/dig from the gateway
  • Can ping/traceroute/dig from the server
  • PiHole up and running as DNS and DHCP, home network devices can get IP from the PiHole DHCP server


Problem: No internet connection on devices getting IP from PiHole DHCP


I saw many such posts with PiHole but each problem is unique - and PiHole is new to me. What I understand is it is not working like industry standart SW like Bind9 & ISC-DHCP. There are many many stuff in play and I've got lost.


(I played too much with the config files so I don't want to post them beforehand.)


How can I debug this? There must be something I'm missing...


Thanks in advance...

Bülent Özden


Link to comment
Share on other sites

Donate and support the project!

  • Solution

I feel so dumb !


After many hours of tcpdump'ing and log tailing I found my mistake... Just to record this unfortunate event:

I first installed pihole DHCP for the exterior network ( then moved to home-network ( side.

On the web interface there is a "Router (gateway) IP address" and my router is in at - I left it as it is :unsure: That should be on the same subnet of course :blink: Changed it  and it worked...


Sorry for your time 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...