Jump to content
  • 0

can't boot bootlogo fromd /boot/boot.bmp


Ghorban_pirizad
 Share

Question

4 answers to this question

Recommended Posts

  • 0
On 11/4/2020 at 11:28 PM, Ghorban_pirizad said:
 

hi

i try to load bootlogo from /boot/mmc on orange pi lite

when add bootlogo=true to armbianEnv only armbian logo show.

i check u-boot and it send an erro "Unknown command 'bmp' - try 'help'" 

i compiple u-boot and fix bmp issue but now i get 'Failed to load '/boot/boot.bmp'
There is no valid bmp file at the given address'

what's this error mean?!!

i don't change defualt bmp boot bmp file!!!!?

 

 

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

  • 0
On 11/6/2020 at 12:31 AM, Igor said:


That is kernel boot logo, unrelated to u-boot.

thanks but now my uboot have bmp function but get the error on start u-boot what is that error mean. is the format of original /boot/boot.bmp have problem or problem is another thing.

for now how we can change kernel boot logo. is there any way to change it.

on other problem I have is I use usb-otg  of orange pi lite as default sub and use it to run HDMI LCD. but because power delay LCD resolution by kernel isn't correct and i don't see kernel-logo on center. can I set default resolution in kernel before compile it.

Link to comment
Share on other sites

  • 0
17 minutes ago, Ghorban_pirizad said:

thanks but now my uboot have bmp function but get the error on start u-boot what is that error mean. is the format of original /boot/boot.bmp have problem or problem is another thing.


This is not exactly an Armbian issue. I can only give you a hint (that can save you hours / days looking into the code) - BMP has different variants and depths and I think only one is supported. Worse case its a bug.

 

17 minutes ago, Ghorban_pirizad said:

on other problem I have is I use usb-otg  of orange pi lite as default sub and use it to run HDMI LCD.


Since this is forum and not a professional support service I suggest you to search forums in deep and if you don't find related topic to the LCD issue, open a new one and describe everything you know about, also supply all logs. It also helps dramatically if you give something back before asking for more https://forum.armbian.com/subscriptions/ https://forum.armbian.com/crowdfunding/

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...