H96 max x3


sfs
 Share

1 1

Recommended Posts

TV Box Status Information Template Version 1.0

TV Box Name : H96 max x3

CPU: amlogic s905x3

Armbian build file name: Armbian_20.10_Arm-64_focal_current_5.9.0_desktop.img.xz

DTB file used: meson-sm1-sei610-ethfix.dtb

Kernel Version: 5.9.0

Distribution Installed (focal, buster, etc): focal

Working Ethernet (Yes/No): Yes

Max Ethernet Speed that works (100/1000): 1000

Does wifi work (Yes/No): Yes

Does bluetooth work (Yes/No): Yes

Does HDMI audio work (Yes/No): Yes

wifi+bt with BCM4335C0.hcd

Temperature: <70 C

SD boot: No
USB boot : Yes

 

Link to post
Share on other sites

Donate and support the project!

2 hours ago, sfs said:

DTB file used: meson-sm1-sei610-ethfix.dtb

 

 

@sfs  This is not a valid submission.  The dtb you reference is not part of the distribution.  So a new user couldn't follow the general installation instructions and get your results.  As was mentioned in the instructions, you need to only use files from the distribution.  You can add comments about how other settings/dtbs/tweeks improved your installation.  Also if you are referencing external code, I would request that you also include or link to source code not the compiled objects (i.e. dts vs. dtb).  That way in the future someone may be able to maintain this addon/feature as changes to the underlying kernel/environment require.

Link to post
Share on other sites

07.09.2021 в 15:38, uppi сказал:

how did you manage to boot it? Which method did you use?

tooth pick

07.09.2021 в 17:00, uppi сказал:

what configuration files you used?

With SD not managed to boot. In the second USB during the start of the download should be empty. Try another USB Flash

Link to post
Share on other sites

Thanks. But the newer version of the images  don't follow  same instructions and u-boot.ext was not working for me. So I started looking for the older image files

That worked perfectly for me. I have installed  it in eMMC and working great. Currently using  it as a headless server for my home network with Adguard and samba  server with External  HDD. USB 3.0 and  Gigabit Ethernet are working great.

Screenshot 2021-09-16 102251.png

Screenshot 2021-09-16 102646.png

Screenshot 2021-09-16 102602.png

241635604_259913919176239_2156219489608631628_n.png

Link to post
Share on other sites

On 9/9/2021 at 3:49 PM, sfs said:

tooth pick

With SD not managed to boot. In the second USB during the start of the download should be empty. Try another USB Flash

Btw , can you show me your BOOT disk files , if you have them? I was not able to boot the latest image, also which  u-boot file did you use?

Link to post
Share on other sites

 kernel with AUFS & UKSM

-rwxr-xr-x 1 root   root              709 дек 28  2020 aml_autoscript
-rwxr-xr-x 1 root   root                0 дек 28  2020 aml_autoscript.zip
-rwxr-xr-x 1 root   root              181 дек 28  2020 boot.ini
drwxr-xr-x 5 root   root             4096 мар  4  2021 dtb-5.10.9-au
-rwxr-xr-x 1 root   root              135 дек 28  2020 emmc_autoscript
drwxr-xr-x 2 root   root             4096 мар 12  2021 extlinux
-rw-r--r-- 1 ivanov domain users  1417732 фев 25  2021 initrd-lf10.xz
-rwxr-xr-x 1 root   root              537 дек 28  2020 s905_autoscript
-rwxr-xr-x 1 root   root           735459 дек 28  2020 u-boot.ext
-rwxr-xr-x 1 root   root           609247 дек 28  2020 u-boot-s905
-rwxr-xr-x 1 root   root           735459 дек 28  2020 u-boot-s905x2-s922
-rwxr-xr-x 1 root   root           650183 дек 28  2020 u-boot-s905x-s912
-rwxrwxrwx 1 ivanov domain users 30661120 мар 14  2021 vmlinuz-5.10.9-au
 

Link to post
Share on other sites

On 9/16/2021 at 7:42 AM, uppi said:

Thanks. But the newer version of the images  don't follow  same instructions and u-boot.ext was not working for me. So I started looking for the older image files

That worked perfectly for me. I have installed  it in eMMC and working great. Currently using  it as a headless server for my home network with Adguard and samba  server with External  HDD. USB 3.0 and  Gigabit Ethernet are working great.

Screenshot 2021-09-16 102251.png

Screenshot 2021-09-16 102646.png

Screenshot 2021-09-16 102602.png

241635604_259913919176239_2156219489608631628_n.png

Same issues that you had, cannot get it to boot, tried USB sticks and SD-cards, configurations.. Do you have links to the files you used, mainly the old image file? I am also going to use my H96 MAX X3 as a headless server.

Link to post
Share on other sites

 Share

1 1