BPI M2 Zero can't get spi to show

Go to solution Solved by martinayotte,

Recommended Posts




I am using the Image from the Armbian Download site: Armbian_20.11.6_Bananapim2zero_bullseye_current_5.10.4

and I am trying to get SPI to work,

enabled it using armbian-config

and through editing the /boot/armbianEnv.txt




But after a reboot it does not show in /dev/

(what seems odd, i2c-0 shows in /dev/ even though it is not enabled in the armbianEnv.txt)


As far as I understand it, the dts for h3 should be the same for h2+ ?

I also found a file called "sun8i-h2-plus-bananapi-m2-zero.dtb" under /boot/dtb after some research I found out that this is a device tree binary (thats also why I cant read it) but I couldn't find any information on how to use it. Or how I could replace the spi-spidev.dtd with this h2 one.


I also already tried the focal_current_5.10.4 Image same result.


Thanks in advance :)


Link to post
Share on other sites
Donate and support the project!

vor 8 Minuten schrieb martinayotte:

You've forgot to define "param_spidev_spi_bus" which is mandatory ...


Thank you very much, should the armbian-config have set this option ?


Sorry I didn't find it in overlay documentation that this flag is needed ^^

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.