Jump to content
  • 0

NanoPi M4V2 only 2GB RAM reported

Helder Pereira





I'm using a NanoPi M4V2 with 4GB of LPDDR4. Before installing Armbian, I tried FriendlyElec and the total amount of 4GB of RAM was detected. When moving to Armbian Buster with kernel 5.9.14-rockchip64, the system is detecting only 2GB of RAM (MemTotal:        1964780 kB).


I searched the forum to see if anyone else was having this problem but strangely I found no more reports of this issue. I also tried Armbian Focal, but the problem remains.


Thank you.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Sadly, my M4V2 is still on order, so can't verify this.


However, there's probably something different in u-boot, kernel configuration, or device tree, between the Armbian and FriendlyElec builds.


Kernel configuration is in /proc/config, or /boot/config-<version>. If you can get both configs, it should be pretty easy to pull it up in "meld" or whatever other diff program you like.


Device tree should be similar. Armbian's is in /boot/dtb. Not sure if FriendlyElec has it somewhere convenient, but you can dump it from a live system (see https://unix.stackexchange.com/questions/265890/is-it-possible-to-get-the-information-for-a-device-tree-using-sys-of-a-running).


Should be easy to decompile the DTB and see if there's any interesting differences.


$ dtc -o rk3399-nanopi-m4v2.dts rk3399-nanopi-m4v2.dtb


If you do find a difference, and it looks memory related (ie dram bank), you might try filing a bug here and clearly identify what you found: https://github.com/armbian/build/issues

Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines