Odroid C4, the system didn't boot with eMMc


Go to solution Solved by Igor,

Recommended Posts

Image used Armbian_20.11.10_Odroidc4_focal_current_5.9.14_desktop.img


It works with micro SD (eMMc not inserted)

Not booting with eMMc (SD not inserted),

With SD & eMMC, system boot from SD .. . I tried nand-sata-install -> "Update bootloader" script same problem.


see the attached output error from my monitor


Link to post
Share on other sites

Donate and support the project!

In preparation for my internet being locked down, I made a backup image of my existing odroid C4 Armbian operating system serving Emby.

I then use that image and wrote it to an emmc module, inserted it into another odroid C4 and I CAN get emby to work using localhost but networking is hosed.  Any suggestions?

I don't have direct access to the internet through the C4 but I do have access to the internet via a windows 10 laptop.


Link to post
Share on other sites

I am also having problems booting a C4 from EMMC. The Armbian image I am using is the latest, "Armbian_20.11.10_Odroidc4_focal_current_5.9.14_desktop". So, what I am wondering, even it sounds like a silly question to myself, what is the correct way of installing and booting Armbian to/from EMMC?


I used to do it the following way, which is working on e.g. my NanoPi Neo Plus2.

  1. etch the Armbian image to a SD card
  2. boot from SD, initial setup with root pwd, user
  3. do an apt update and apt upgrade
  4. install/update the bootloader
  5. shutdown SBC
  6. insert EMMC and boot
  7. using armbian-config/System/Install, copy system to EMMC using "Boot from emmc - system on emmc"
  8. shutdown SBC
  9. remove SD card
  10. (try to) boot


And here the boot process gets stuck. The C4 tries to boot at first emmc which cannot be found, I guess. See screenshot below. Then it is trying USB and then ethernet and gets stuck after some retries. What am I missing here or doing wrong? If I re-insert the SD card, the C4 boots from SD card, and the emmc can be mounted. AFAIK, booting should be possible w/o SD card and only emmc.


I also tried to etch the image directly to mmc with an adapter, but this is also not working/booting.(BTW, is this process supported at all?)




Edited by mar0ni
attached screenshot
Link to post
Share on other sites

Some updates.


I tried the same process of burning (flash image using Etcher on a Winsucks laptop with emmc connected using adapter) the Hardkernel Ubuntu Mate (ubuntu-20.04-4.9-mate-odroid-c4-hc4-20201020.img.xz) image and this is booting the C4 from emmc without an SD card inserted with no problems.


So, this tells me, the way I am doing it is basically right and also my hardware, the adapter and emmc is working as it should. But NO Armbian image is booting. And I tried current focal mainline desktop, current focal mainline minimal, nightly/test build XFCE, and legacy.


Is there any way to debug this on my side to get more information about this problem?


Another question, the output you can see on the pictures above from me and 2020, is this output of U-Boot?

Link to post
Share on other sites

Tested this morning!

I tried with other OS with the same methode direct on my USB EMMC Module Writer attached to my Ubuntu computer.


ubuntu-20.04-4.9-minimal-odroid-c4-hc4-20201212: OK

DietPi_OdroidC4-ARMv8-Buster: OK

CoreELEC-Amlogic-ng.arm-9.2.5-Odroid_C4: OK

selfinstall-odroidc4-49-64bit-20210108: OK

Manjaro ARM 20.12: OK

ArchLinuxARM Image Generator: Fail

Armbian_20.11.10_Odroidc4_focal_current_5.9.14: Fail


Link to post
Share on other sites

  • Solution

Armbian is (probably) the the only distribution that doesn't use u-boot from 2015. All others are still using stock private Hardkernel boot loader ... We try to get rid of vendors dirty security hazardous code as soon as possible and problems as such is the price that we need to pay.


Currently we use u-boot based on 2020.xx, but it looks like it's possible that we need the one from 2021 as this is the case with C2. Some eMMC needs this. Mine obviously don't since it works without any intervention.

Try this image:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.