MariaDB docker version 10.2ff


FredK
 Share

1 1

Recommended Posts

Let me ask a question in a armbian-forum where I found up til now no solution.

After updating nextcloud to 20.0.5 (now I use 20.0.7) I get the following warning in OMV5 Settings->Overview:

Zitat

MariaDB version "10.1.47-MariaDB-0ubuntu0.18.04.1" is used. Nextcloud 21 will no longer support this version and requires MariaDB 10.2 or higher.

Asking thas question in the OMV-forum I received the following answer from the user "Morlan":

Zitat

This is a complicated issue. Because MariaDB is not officially compiled for arm32 devices the linuxserver image is stuck on 10.1.*. I don't know if that will change. I tried to find an alternative this morning, but I have not found an easy solution .. Maybe someone else has an idea?

A missing MariaDB docker version 10.2ff could be a show-stopper if nextcloud v21 will be available for Helios4.

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

This seems to be a OMV specific problem. I just checked my clearfogpro with Armbian (Debian Buster) and it reports MariaDB 10.3:

 

user@cfp-router:~# apt list --installed | grep maria

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libmariadbclient18/now 10.1.41-0+deb9u1 armhf [installed,local]
mariadb-backup/stable,now 1:10.3.27-0+deb10u1 armhf [installed]
mariadb-client-10.3/stable,now 1:10.3.27-0+deb10u1 armhf [installed,automatic]
mariadb-client-core-10.3/stable,now 1:10.3.27-0+deb10u1 armhf [installed,automatic]
mariadb-common/stable,now 1:10.3.27-0+deb10u1 all [installed,automatic]
mariadb-server-10.3/stable,now 1:10.3.27-0+deb10u1 armhf [installed,automatic]
mariadb-server-core-10.3/stable,now 1:10.3.27-0+deb10u1 armhf [installed,automatic]
mariadb-server/stable,now 1:10.3.27-0+deb10u1 all [installed]

 

So it should absolutely be possible to also go to higher versions on helios4.

 

I've never used OMV so not sure if you can just update your packages with APT or might break some

thing, maybe poke the OMV guys more or risk it?

 

Quote

MariaDB version "10.1.47-MariaDB-0ubuntu0.18.04.1" is used. Nextcloud 21 will no longer support this version and requires MariaDB 10.2 or higher.

 

This is also confusing me, I though OMV was going on top of Debian? Why is it using a ubuntu package?

Link to post
Share on other sites

vor 5 Stunden schrieb Heisath:

This is also confusing me, I though OMV was going on top of Debian? Why is it using a ubuntu package?

OMV5 on Helios4 is on top of Armbian Buster (see my signature). OMV5 doesn't support nextcloud + MariaDB + swag(letsencrypt) directly. It supports docker plus portainer and yacht for container management.  Docker version is:

root@helios4:~# apt list --installed | grep docker

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

docker-ce-cli/buster,now 5:20.10.3~3-0~debian-buster armhf [installed,automatic]
docker-ce/buster,now 5:20.10.3~3-0~debian-buster armhf [installed]
docker-compose/stable,now 1.21.0-3 all [installed]
golang-docker-credential-helpers/stable,now 0.6.1-2 armhf [installed,automatic]
python3-docker/stable,now 3.4.1-4 all [installed,automatic]
python3-dockerpty/stable,now 0.4.1-1 all [installed,automatic]
python3-dockerpycreds/stable,now 0.3.0-1 all [installed,automatic]

 

"Inside" the MariaDB container mariadb is 10.1.47:

root@helios4:~# !494
docker exec -it nextclouddb /bin/bash
root@6f5d32139adf:/# apt list --installed | grep maria

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

mariadb-client-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]
mariadb-client-core-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]
mariadb-common/now 1:10.1.47-0ubuntu0.18.04.1 all [installed,local]
mariadb-server/now 1:10.1.47-0ubuntu0.18.04.1 all [installed,local]
mariadb-server-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]
mariadb-server-core-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]

 

The mariadb docker image is from bionic (ubuntu 18.04).

build_version 	Linuxserver.io version:- 110.4.17mariabionic-ls9 Build-date:- 2021-01-30T06:00:22+00:00

Bionic was the last ubuntu release supporting 32bit.

 

vor 5 Stunden schrieb Heisath:

I've never used OMV so not sure if you can just update your packages with APT

An apt-get update takes packages from "http://ports.ubuntu.com/ubuntu-ports bionic". And 10.1.47 is the latest available release.

 

Link to post
Share on other sites

vor 2 Minuten schrieb Heisath:

Maybe find a docker image then with Debian and MariaDB?

I'll ask again in the OMV forum how to proceed, in particular why the mariadb image is bound to ubuntu bionic.

Link to post
Share on other sites

vor 4 Stunden schrieb Mangix:

Hm. Using the attached docker-compose.yml the build version "110.4.17mariabionic-ls9" is updated to the fresh "110.4.17mariabionic-ls10".

But "inside" the mariadb container the version stayed at 10.1.47.

# docker exec -it nextclouddb /bin/bash
root@7f6f464c863c:/# apt list --installed | grep maria

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

mariadb-client-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]
mariadb-client-core-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]
mariadb-common/now 1:10.1.47-0ubuntu0.18.04.1 all [installed,local]
mariadb-server/now 1:10.1.47-0ubuntu0.18.04.1 all [installed,local]
mariadb-server-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]
mariadb-server-core-10.1/now 1:10.1.47-0ubuntu0.18.04.1 armhf [installed,local]

What am I doing wrong?

 

EDIT: See the following post in https://forum.openmediavault.org/index.php?thread/28242-nextcloud-with-letsencrypt-using-omv-and-docker-compose-q-a/&postID=265371#post265371

docker-compose.yml

Edited by FredK
Verweis auf OMV forum
Link to post
Share on other sites

Let me describe the solution of the problem, possibly for help another users of Helios4+OMV5+Nextcloud. The individual steps are mentioned in the OMV forum in the thread https://forum.openmediavault.org/index.php?thread/28242-nextcloud-with-letsencrypt-using-omv-and-docker-compose-q-a.

 

User "Morlan" proposed to exchange linuxserver/mariadb by webhippie/mariadb, he prepared a how-to in post #533, I make minor amendments in #536. Now I'm "back in business", MariaDB version is 10.4.8.

 

Link to post
Share on other sites

 Share

1 1